File yast2-printer.spec of Package yast2-printer

#
# spec file for package yast2-printer
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           yast2-printer
Summary:        YaST2 - Printer Configuration
License:        GPL-2.0
Group:          System/YaST
Version:        2.23.1
Release:        0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        yast2-printer-%{version}.tar.bz2
BuildRequires:  update-desktop-files
BuildRequires:  xorg-x11-libX11-devel
BuildRequires:  yast2
BuildRequires:  yast2-core-devel
BuildRequires:  yast2-devtools
BuildRequires:  yast2-testsuite
Recommends:     cups-client
Recommends:     iptables
Recommends:     netcat
Recommends:     samba-client
Requires:       /bin/mktemp
Requires:       /bin/ping
Requires:       /usr/bin/sed
Requires:       yast2 >= 2.16.12
# Used to exclude libX11, libXau, libxcb, and libxcb-xlib from the requires list
# which are pulled in by Autoreqprov because of the basicadd_displaytest tool:
%define my_requires /tmp/my-requires

%description
This package contains the YaST2 component for printer configuration.

%package devel-doc
BuildRequires:  cups-devel
BuildRequires:  yast2-core-devel
Summary:        Developer documentation for yast2-printer
License:        GPL
Group:          Documentation/SUSE

%description devel-doc
This package contains the developer documentation for yast2-printer.

%prep
%setup -q

%build
make -f Makefile.cvs
export CFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
export CXXFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
# V=1: verbose build in case we used AM_SILENT_RULES(yes)
# so that RPM_OPT_FLAGS check works
make %{?jobs:-j%jobs} V=1

%install
make install DESTDIR="$RPM_BUILD_ROOT"
%suse_update_desktop_file -d ycc_printer printer
# Exclude libX11, libXau, libxcb, and libxcb-xlib from the requires list
# which are pulled in by Autoreqprov because of the basicadd_displaytest tool:
cat << EOF > %{my_requires}
grep -v 'basicadd_displaytest' | %{__find_requires}
EOF
chmod 755 %{my_requires}
%define __find_requires %{my_requires}

%clean
rm -rf "$RPM_BUILD_ROOT"

%files
%defattr(-,root,root)
%dir /usr/share/YaST2/include/printer
/usr/share/applications/YaST2/printer.desktop
/usr/share/YaST2/modules/*.y*
/usr/share/YaST2/clients/printer*
/usr/share/YaST2/include/printer/*
/usr/share/YaST2/schema/autoyast/rnc/printer.rnc
/usr/share/YaST2/data/testprint.ps
/usr/share/YaST2/data/testprint.2pages.ps
/usr/lib/YaST2/bin/autodetect_print_queues
/usr/lib/YaST2/bin/autodetect_printers
/usr/lib/YaST2/bin/create_printer_ppd_database
/usr/lib/YaST2/bin/determine_printer_driver_options
/usr/lib/YaST2/bin/cups_client_only
/usr/lib/YaST2/bin/modify_cupsd_conf
/usr/lib/YaST2/bin/test_device
/usr/lib/YaST2/bin/test_remote_ipp
/usr/lib/YaST2/bin/test_remote_lpd
/usr/lib/YaST2/bin/test_remote_novell
/usr/lib/YaST2/bin/test_remote_smb
/usr/lib/YaST2/bin/test_remote_socket
/usr/lib/YaST2/bin/basicadd_displaytest
%dir /usr/share/doc/packages/yast2-printer
/usr/share/doc/packages/yast2-printer/COPYING
%readme /usr/share/doc/packages/yast2-printer/README

%files devel-doc
%defattr(-,root,root)
%doc /usr/share/doc/packages/yast2-printer
%exclude /usr/share/doc/packages/yast2-printer/COPYING
%exclude /usr/share/doc/packages/yast2-printer/README

%changelog