File evolution-ews.spec of Package evolution-ews

#
# spec file for package evolution-ews
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           evolution-ews
# This should be updated upon major version changes; it should match BASE_VERSION as defined in configure.in.
%define evolution_base_version 3.4
Version:        3.4.4
Release:        0
Summary:        Exchange Connector for Evolution, compatible with Exchange 2007 and later
License:        LGPL-2.1
Group:          Productivity/Networking/Email/Clients
Url:            http://projects.gnome.org/evolution/
Source:         http://download.gnome.org/sources/evolution-ews/3.4/%{name}-%{version}.tar.xz
BuildRequires:  fdupes
BuildRequires:  intltool
BuildRequires:  translation-update-upstream
# Only needed because we don't (and won't) support building xz tarballs by default... See bnc#697467
BuildRequires:  xz
BuildRequires:  pkgconfig(evolution-data-server-1.2)
BuildRequires:  pkgconfig(evolution-plugin-3.0)
BuildRequires:  pkgconfig(evolution-shell-3.0)
BuildRequires:  pkgconfig(gconf-2.0) >= 2.0.0
BuildRequires:  pkgconfig(glib-2.0) >= 2.16.1
BuildRequires:  pkgconfig(gtk+-3.0) >= 2.90.4
BuildRequires:  pkgconfig(libebackend-1.2)
BuildRequires:  pkgconfig(libedata-book-1.2)
BuildRequires:  pkgconfig(libedata-cal-1.2)
BuildRequires:  pkgconfig(libedataserver-1.2)
BuildRequires:  pkgconfig(libedataserverui-3.0)
BuildRequires:  pkgconfig(libemail-engine) >= 3.2.0
BuildRequires:  pkgconfig(libsoup-2.4) >= 2.30
Recommends:     %{name}-lang
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
The EWS Exchange Connector for Evolution provides a Exchange backend
from evolution-data-server as well as plugins for Evolution to access
Exchange features.

The EWS Exchange Connector is using the Exchange Web Services interface
and is therefore compatible with Exchange 2007 and later.

Provides exchange connectivity for exchange server 2007 and later using
exchange web services protocol.

%package  -n libeews-1_2-0
Summary:        Client library for Accessing Exchange Servers
Group:          System/Libraries

%description -n libeews-1_2-0
This library is a client library for accessing Exchange servers through
the Exchange Web Services interface (compatible with Exchange 2007 and
later).

%package  -n libewsutils0
Summary:        Client library for Accessing Exchange Servers -- Utilities library
Group:          System/Libraries

%description -n libewsutils0
This library provides utilities API for EWS Exchange Connector.

%package  -n liblzx0
Summary:        Client library for Accessing Exchange Servers - LZX library
Group:          System/Libraries

%description -n liblzx0
This library is an implementation of the LZX compression algorithm.

%package devel
Summary:        Client library for Accessing Exchange Servers -- Development Files
Group:          Development/Libraries/C and C++
Requires:       libeews-1_2-0 = %{version}
Requires:       libewsutils0 = %{version}
Requires:       liblzx0 = %{version}

%description devel
This library is a client library for accessing Exchange servers through
the Exchange Web Services interface (compatible with Exchange 2007 and
later).

%lang_package
%prep
%setup -q
translation-update-upstream

%build
%{configure} \
  --disable-static
make %{?_smp_mflags}

%install
%make_install
find %{buildroot}%{_libdir} -name '*.la' -delete -print
%find_lang evolution-ews %{?no_lang_C}
%fdupes %{buildroot}

%post -n libeews-1_2-0 -p /sbin/ldconfig

%postun -n libeews-1_2-0 -p /sbin/ldconfig

%post -n libewsutils0 -p /sbin/ldconfig

%postun -n libewsutils0 -p /sbin/ldconfig

%post -n liblzx0 -p /sbin/ldconfig

%postun -n liblzx0 -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc COPYING README
%{_libdir}/evolution-data-server/addressbook-backends/libebookbackendews.so
%{_libdir}/evolution-data-server/calendar-backends/libecalbackendews.so
%{_libdir}/evolution-data-server/camel-providers/libcamelews.so
%{_libdir}/evolution-data-server/camel-providers/libcamelews.urls
%{_libdir}/evolution/%{evolution_base_version}/plugins/liborg-gnome-exchange-ews.so
%{_libdir}/evolution/%{evolution_base_version}/plugins/org-gnome-exchange-ews.eplug

%files -n libeews-1_2-0
%defattr(-, root, root)
%dir %{_libdir}/evolution-data-server-%{evolution_base_version}
%{_libdir}/evolution-data-server-%{evolution_base_version}/libeews-1.2.so.*

%files -n libewsutils0
%defattr(-, root, root)
%dir %{_libdir}/evolution-data-server-%{evolution_base_version}
%{_libdir}/evolution-data-server-%{evolution_base_version}/libewsutils.so.*

%files -n liblzx0
%defattr(-, root, root)
%{_libdir}/liblzx.so.*

%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/libeews-1.2.pc
%dir %{_libdir}/evolution-data-server-%{evolution_base_version}
%{_libdir}/evolution-data-server-%{evolution_base_version}/libeews-1.2.so
%{_libdir}/evolution-data-server-%{evolution_base_version}/libewsutils.so
%{_libdir}/liblzx.so
%dir %{_includedir}/evolution-data-server-%{evolution_base_version}
%{_includedir}/evolution-data-server-%{evolution_base_version}/ews/

%files lang -f evolution-ews.lang

%changelog