File perl-Scope-Upper.changes of Package perl-Scope-Upper

-------------------------------------------------------------------
Wed Dec 28 19:27:53 UTC 2011 - coolo@suse.com

- update to 0.18
     + Add : The uid() function returns an unique identifier for each dynamic
             scope. The validate_uid() function can be used to check whether
             one such identifier is valid (i.e. that the scope it refers to
             is still alive).
     + Chg : It is no longer possible on perl 5.6 to call goto() in an
             uplevel callback to replace the uplevel call. This change was
             needed in order to ensure consistency between platforms
             regarding to the following fix just below.
     + Fix : The uplevel() tests now pass on Windows.
             Thanks C.H. Kang for bringing this to my attention.

-------------------------------------------------------------------
Fri Apr 29 05:25:29 UTC 2011 - coolo@opensuse.org

- updated to 0.14
       + Fix : [RT #64997] : Compatibility with perl 5.13.10.
               Thanks Dave Mitchell for the notice.
       + Tst : Lengthy tests have been ported to Test::Leaner, making the
               whole test suite about 50% faster.
  
       + Fix : [RT #61904] : Stack corruption when using unwind() under
               Devel::NYTProf.
               Thanks Sergey Aleynikov for contributing a fix.
       + Fix : [RT #63378] : Compatibility with perl 5.13.8.
               Thanks Andreas J. K├Ânig for bisecting the issue.
       + Tst : Threads tests are now only run on perl 5.13.4 and higher.
               They could segfault randomly because of what seems to be an
               internal bug of Perl, which has been addressed in 5.13.4.
               There is also an environment variable that allows you to
               forcefully run those tests, but it should be set only for
               author testing and not for end users.

-------------------------------------------------------------------
Wed Dec  1 13:35:06 UTC 2010 - coolo@novell.com

- switch to perl_requires macro

-------------------------------------------------------------------
Mon Nov 29 18:31:01 UTC 2010 - coolo@novell.com

- remove /var/adm/perl-modules

-------------------------------------------------------------------
Thu Nov  4 19:38:22 UTC 2010 - pascal.bleser@opensuse.org

- initial version (0.12)