File rubygem-rails-2_3.changes of Package rubygem-rails-2_3

-------------------------------------------------------------------
Wed Aug 17 12:14:55 UTC 2011 - mrueckert@suse.de

- update to version 2.3.14
  - adding notification for rdoc
- drop rails-2.3.12-missing_rdoc_requires.patch:
  patch upstreamed

-------------------------------------------------------------------
Tue Aug  2 19:24:16 UTC 2011 - mrueckert@suse.de

- added rails-2.3.12-missing_rdoc_requires.patch
  make rake tasks work again. the port of the documentation task to
  the new API forgot some important bits

  for details see:
  https://github.com/rails/rails/issues/2403
- package now requires rubygem-rdoc

-------------------------------------------------------------------
Mon Jun 20 20:18:05 UTC 2011 - mrueckert@suse.de

- update to version 2.3.12
  - fixes for newer rubygems

-------------------------------------------------------------------
Fri Feb 18 13:20:43 UTC 2011 - mrueckert@suse.de

- update to version 2.3.11: (bnc#668817)
  - XSS Risk in mail_to :encode=>:javascript CVE-2011-0446
  - CSRF Bypass Risk CVE-2011-0447
  - Filter Problems on Case Insensitive Filesystems CVE-2011-0449
  - Potential SQL Injection with limit() CVE-2011-0448

-------------------------------------------------------------------
Wed Oct 27 11:45:43 UTC 2010 - mrueckert@suse.de

- update to version 2.3.10
  * Version bump

-------------------------------------------------------------------
Sun Sep  5 11:20:46 UTC 2010 - mrueckert@suse.de

- update to version 2.3.9
  * Deprecates config.load_(once_)paths in favor of
    autolaod_(once_)paths. [fxn]

-------------------------------------------------------------------
Tue Aug 31 15:23:36 UTC 2010 - mrueckert@suse.de

- fix update alternatives priority

-------------------------------------------------------------------
Tue May 25 16:16:07 UTC 2010 - mrueckert@suse.de

- update to version 2.3.8
  * Version bump.
- additional changes from version 2.3.7
  * Version bump.
- additional changes from version 2.3.6
  * Added config/initializers/cookie_verification_secret.rb with an
    auto-generated secret for using
    ActionController::Base#cookies.signed [DHH]
  * Fixed that the debugger wouldn't go into IRB mode because of
    left-over ARGVs [DHH]

-------------------------------------------------------------------
Tue Jan  5 14:07:57 UTC 2010 - prusnak@suse.cz

- readd missing macro %mod_branch

-------------------------------------------------------------------
Tue Dec  1 17:34:46 UTC 2009 - chris@computersalat.de

- update to version 2.3.5
  * Fixed that the debugger wouldn't go into IRB mode because of
    left-over ARGVs [DHH]
  * 1.9 compatibility

-------------------------------------------------------------------
Thu Sep 10 12:02:37 UTC 2009 - adrian@suse.de

- update to version 2.3.4
  * I18n support for plugins.  #2325 [Antonio Tapiador, Sven Fuchs]

-------------------------------------------------------------------
Mon Mar 16 20:52:10 CET 2009 - mrueckert@suse.de

- starting package for the rails 2.3 series

-------------------------------------------------------------------