File banshee-dmcs-before-gmcs.patch of Package banshee

From 3d3f7899465ee46e634b53c236401f612dac1492 Mon Sep 17 00:00:00 2001
From: Andres G. Aragoneses <knocte@gmail.com>
Date: Tue, 11 Dec 2012 00:28:51 +0000
Subject: configure: better guess for the C# compiler available

There are some distributions that bundle only a limited set of class
libraries to be able to meet size requirements better. Such is the case
of Ubuntu, which normally ships with only the subset compiled for the
4.0 version of the runtime.

In this case, the user may install the default Mono SDK packages when
asked by the configure script, which only includes the 4.0 compiler by
default (dmcs). At that point, banshee can already be compiled, but
the configure script would insist in requiring a 2.0 compiler. If the
user installs it, compiles Banshee and launches the "run" target, she
may get a runtime exception because of a runtime version mismatch, like
in bgo#675113.

This problem is commonly known, and there is a clear workaround for it:
http://orangesquash.org.uk/~laney/blog/posts/2011/10/mono-gotcha/
However it poses a small barrier of entry for new developers that try
to compile and run banshee from sources for the first time.

Now the configure script is smarter and tries to guess harder if there
is a C# compiler, even one that targets a higher version of the runtime
than the one that is required to compile banshee.

This possibility is only enabled in case the Mono version found is 2.8
or higher, because Mono 2.6.1 included the 4.0 profile only as a
"preview" [1] and might not be stable enough.

[1] http://www.mono-project.com/Release_Notes_Mono_2.6.4#C.23_Language
---
diff --git a/build/m4/shamrock/mono.m4 b/build/m4/shamrock/mono.m4
index c40ecbf..309e163 100644
--- a/build/m4/shamrock/mono.m4
+++ b/build/m4/shamrock/mono.m4
@@ -8,6 +8,20 @@ AC_DEFUN([SHAMROCK_FIND_MONO_2_0_COMPILER],
 	SHAMROCK_FIND_PROGRAM_OR_BAIL(MCS, gmcs)
 ])
 
+AC_DEFUN([SHAMROCK_FIND_MONO_2_0_COMPILER_OR_HIGHER],
+[
+	SHAMROCK_FIND_PROGRAM(MCS, gmcs)
+	if test "x$MCS" = "x" ; then
+		if pkg-config --atleast-version=2.8 mono; then
+			SHAMROCK_FIND_PROGRAM(MCS, dmcs)
+		fi
+	fi
+
+	if test "x$MCS" = "x" ; then
+		AC_MSG_ERROR([You need to install 'gmcs'])
+	fi
+])
+
 AC_DEFUN([SHAMROCK_FIND_MONO_4_0_COMPILER],
 [
 	SHAMROCK_FIND_PROGRAM_OR_BAIL(MCS, dmcs)
diff --git a/configure.ac b/configure.ac
index 50f2c4f..7ea5157 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,7 +67,7 @@ SHAMROCK_CHECK_GNOME_DOC_UTILS(0.17.3)
 
 dnl Mono and gmcs
 SHAMROCK_CHECK_MONO_MODULE(2.4.3)
-SHAMROCK_FIND_MONO_2_0_COMPILER
+SHAMROCK_FIND_MONO_2_0_COMPILER_OR_HIGHER
 SHAMROCK_FIND_MONO_RUNTIME
 SHAMROCK_CHECK_MONO_2_0_GAC_ASSEMBLIES([Mono.Cairo Mono.Posix ICSharpCode.SharpZipLib])
 
--
cgit v0.9.0.2


From dbc3f6acc380fda5b37dc12629df3336e6703027 Mon Sep 17 00:00:00 2001
From: "Andres G. Aragoneses" <knocte@gmail.com>
Date: Sat, 12 Jan 2013 19:42:39 +0000
Subject: [PATCH] build: test dmcs before gmcs when trying to find the
 compiler (bnc#798267)

In the previous improvement that had been done [1] in this mono.m4 macro
to find the 4.0 profile compiler in case it's mature enough (mono 2.8),
the scenario in which both compilers could be installed was not considered.

Now in this case, a higher version of the compiler (dmcs) will be used.

[1] http://git.gnome.org/browse/banshee/commit/?id=3d3f7899465ee46e634b53c236401f612dac1492
---
 build/m4/shamrock/mono.m4 |    8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/build/m4/shamrock/mono.m4 b/build/m4/shamrock/mono.m4
index 309e163..1338a39 100644
--- a/build/m4/shamrock/mono.m4
+++ b/build/m4/shamrock/mono.m4
@@ -10,11 +10,11 @@ AC_DEFUN([SHAMROCK_FIND_MONO_2_0_COMPILER],
 
 AC_DEFUN([SHAMROCK_FIND_MONO_2_0_COMPILER_OR_HIGHER],
 [
-	SHAMROCK_FIND_PROGRAM(MCS, gmcs)
+	if pkg-config --atleast-version=2.8 mono; then
+		SHAMROCK_FIND_PROGRAM(MCS, dmcs)
+	fi
 	if test "x$MCS" = "x" ; then
-		if pkg-config --atleast-version=2.8 mono; then
-			SHAMROCK_FIND_PROGRAM(MCS, dmcs)
-		fi
+		SHAMROCK_FIND_PROGRAM(MCS, gmcs)
 	fi
 
 	if test "x$MCS" = "x" ; then
-- 
1.7.10.4
openSUSE Build Service is sponsored by