File digikam-3.0.0.no-kdcraw.version-check.patch of Package digikam

diff -U3 -dHrN digikam-3.0.0/core/CMakeLists.txt digikam-3.0.0.no-kdcraw.version-check/core/CMakeLists.txt
--- digikam-3.0.0/core/CMakeLists.txt	2013-02-07 00:51:27.000000000 +0100
+++ digikam-3.0.0.no-kdcraw.version-check/core/CMakeLists.txt	2013-02-11 22:33:47.088164540 +0100
@@ -199,21 +199,23 @@
 
 # check the libkdcraw version
 
+# Check is done by FindKdcraw.cmake in another way - this way does not seem valid any more
+# TODO: find a proper fix
 SET(KDCRAW_MIN_VERSION "2.2.0")
 
-IF (KDCRAW_VERSION)
-
-    MESSAGE(STATUS "libkdcraw: Found version ${KDCRAW_VERSION} (required: ${KDCRAW_MIN_VERSION})")
-    IF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
-        SET(KDCRAW_FOUND FALSE)
-    ENDIF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
-
-ELSE (KDCRAW_VERSION)
-
-    MESSAGE(WARNING "libkdcraw: Version information not found, your version is probably too old.")
-    SET(KDCRAW_FOUND FALSE)
-
-ENDIF (KDCRAW_VERSION)
+# IF (KDCRAW_VERSION)
+# 
+#     MESSAGE(STATUS "libkdcraw: Found version ${KDCRAW_VERSION} (required: ${KDCRAW_MIN_VERSION})")
+#     IF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
+#         SET(KDCRAW_FOUND FALSE)
+#     ENDIF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
+# 
+# ELSE (KDCRAW_VERSION)
+# 
+#     MESSAGE(WARNING "libkdcraw: Version information not found, your version is probably too old.")
+#     SET(KDCRAW_FOUND FALSE)
+# 
+# ENDIF (KDCRAW_VERSION)
 
 # LCMS version 1 and 2 library handling
 # See B.K.O #294105
diff -U3 -dHrN digikam-3.0.0/extra/kipi-plugins/CMakeLists.txt digikam-3.0.0.no-kdcraw.version-check/extra/kipi-plugins/CMakeLists.txt
--- digikam-3.0.0/extra/kipi-plugins/CMakeLists.txt	2013-02-07 00:52:03.000000000 +0100
+++ digikam-3.0.0.no-kdcraw.version-check/extra/kipi-plugins/CMakeLists.txt	2013-02-11 22:33:47.104155757 +0100
@@ -131,21 +131,23 @@
 
 # Check the libkdcraw version
 
+# Check is done by FindKdcraw.cmake in another way - this way does not seem valid any more
+# TODO: find a proper fix
 SET(KDCRAW_MIN_VERSION "2.2.0")
 
-IF (KDCRAW_VERSION)
-
-    MESSAGE(STATUS "libkdcraw: Found version ${KDCRAW_VERSION} (required: ${KDCRAW_MIN_VERSION})")
-    IF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
-        SET(KDCRAW_FOUND FALSE)
-    ENDIF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
-
-ELSE (KDCRAW_VERSION)
-
-    MESSAGE(WARNING "libkdcraw: Version information not found, your version is probably too old.")
-    SET(KDCRAW_FOUND FALSE)
-
-ENDIF (KDCRAW_VERSION)
+# IF (KDCRAW_VERSION)
+# 
+#     MESSAGE(STATUS "libkdcraw: Found version ${KDCRAW_VERSION} (required: ${KDCRAW_MIN_VERSION})")
+#     IF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
+#         SET(KDCRAW_FOUND FALSE)
+#     ENDIF (${KDCRAW_VERSION} VERSION_LESS ${KDCRAW_MIN_VERSION})
+# 
+# ELSE (KDCRAW_VERSION)
+# 
+#     MESSAGE(WARNING "libkdcraw: Version information not found, your version is probably too old.")
+#     SET(KDCRAW_FOUND FALSE)
+# 
+# ENDIF (KDCRAW_VERSION)
 
 # Optional depencies detection required by some plugins
 MACRO_OPTIONAL_FIND_PACKAGE(EXPAT)                                       # For DNGConverter: XMP SDK need Expat library to compile.