File gnome-panel.spec of Package gnome-panel

#
# spec file for package gnome-panel
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           gnome-panel
Version:        3.6.2
Release:        0
# FIXME: gnome-main-menu not ported to new panel API, for this reason we do not Recommend gnome-main-menu.
Summary:        The GNOME Desktop Panel
License:        GPL-2.0+
Group:          System/GUI/GNOME
Url:            http://www.gnome.org
Source:         http://download.gnome.org/sources/gnome-panel/3.6/%{name}-%{version}.tar.xz
Source99:       baselibs.conf
# PATCH-FIX-UPSTREAM gnome-panel-recent-check-exists.patch -- Show an error when clicking on a recent item that doesn't exist anymore
Patch25:        gnome-panel-recent-check-exists.patch
# PATCH-FIX-UPSTREAM gnome-panel-beagle-search.patch bgo336726 -- Use nautilus search instead of gnome-search-tool
Patch34:        gnome-panel-beagle-search.patch
# PATCH-NEEDS-REBASE gnome-panel-run-fixes.patch bnc115576 bgo543604 -- Fix running a command like yast2 when we find the desktop file but the binary is not in $PATH (was PATCH-FIX-UPSTREAM)
Patch50:        gnome-panel-run-fixes.patch
BuildRequires:  fdupes
BuildRequires:  gnome-common
BuildRequires:  gnome-patch-translation
BuildRequires:  gobject-introspection-devel
BuildRequires:  gtk-doc
BuildRequires:  intltool
BuildRequires:  pkg-config
BuildRequires:  translation-update-upstream
BuildRequires:  update-desktop-files
BuildRequires:  yelp-tools
BuildRequires:  pkgconfig(NetworkManager)
BuildRequires:  pkgconfig(cairo)
BuildRequires:  pkgconfig(dconf) >= 0.13.4
BuildRequires:  pkgconfig(gconf-2.0) >= 2.6.1
BuildRequires:  pkgconfig(gdk-pixbuf-2.0) >= 2.25.2
BuildRequires:  pkgconfig(glib-2.0) >= 2.31.14
BuildRequires:  pkgconfig(gnome-desktop-3.0)
BuildRequires:  pkgconfig(gtk+-3.0) >= 3.3.8
BuildRequires:  pkgconfig(gweather-3.0) >= 3.5.1
BuildRequires:  pkgconfig(ice)
BuildRequires:  pkgconfig(libecal-1.2) >= 3.5.3
BuildRequires:  pkgconfig(libedataserver-1.2) >= 3.5.3
BuildRequires:  pkgconfig(libedataserverui-3.0)
BuildRequires:  pkgconfig(libgnome-menu-3.0) >= 3.1.4
BuildRequires:  pkgconfig(librsvg-2.0)
BuildRequires:  pkgconfig(libwnck-3.0)
BuildRequires:  pkgconfig(pango)
BuildRequires:  pkgconfig(polkit-gobject-1)
BuildRequires:  pkgconfig(sm)
BuildRequires:  pkgconfig(telepathy-glib)
BuildRequires:  pkgconfig(x11)
BuildRequires:  pkgconfig(xau)
Requires:       %{name}-branding = %{version}
# Required by clock/tz.c:
Requires:       timezone
Recommends:     %{name}-lang
# For user menu
Recommends:     gnome-control-center
# For change from gnome-panel-beagle-search.patch
Recommends:     tracker-gui
Obsoletes:      gnome-core
# For upgrade from SLE 10
Provides:       gnome-panel-nld > 2.12.3
Obsoletes:      gnome-panel-nld <= 2.12.3
# As of Jan 2008, intlclock is part of gnome-panel.
Provides:       intlclock = 1.0
Obsoletes:      intlclock < 1.0
# gnome-panel 3.0 no longer supports bonobo
Obsoletes:      gnome-panel-bonobo-support < 3.0
# Ease upgrades from 11.4 to 12.1 ; gnome-main-menu <= 0.9.16 is a GNOME 2.x applet, and it depends on old NM
Obsoletes:      gnome-main-menu <= 0.9.16
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%glib2_gsettings_schema_requires

%description
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

%package branding-upstream
Summary:        The GNOME Desktop Panel -- Upstream default layout
License:        GPL-2.0+
Group:          System/GUI/GNOME
Requires:       %{name} = %{version}
Provides:       %{name}-branding = %{version}
Conflicts:      otherproviders(%{name}-branding)
Supplements:    packageand(%{name}:branding-upstream)
BuildArch:      noarch
#BRAND: Provides /usr/share/gnome-panel/panel-default-layout.layout
#BRAND: which contains the default layout.
#BRAND: Branding package should require packages with applets in
#BRAND: the default layout.

%description branding-upstream
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

This package contains the upstream default layout for GNOME Panel.

%package -n libpanel-applet-4-0
Summary:        GNOME Panel Applet Library -- D-Bus-based library
License:        LGPL-2.1+
Group:          System/GUI/GNOME

%description -n libpanel-applet-4-0
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

This package contains the libpanel-applet library used by GNOME panel
applets, based on D-Bus.

%package -n typelib-1_0-PanelApplet-4_0
Summary:        GNOME Panel Applet Library -- Introspection bindings
License:        GPL-2.0+
Group:          System/Libraries

%description -n typelib-1_0-PanelApplet-4_0
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

This package provides the GObject Introspection bindings for the
libpanel-applet library used by GNOME panel applets.

%package extras
Summary:        Extra panel applets
License:        GPL-2.0+
Group:          System/GUI/GNOME
Requires:       %{name} = %{version}
Requires:       fortune
Recommends:     gnome-panel-extras-lang
# For upgrade from SLE 10
Provides:       gnome-panel-nld-extras > 2.12.3
Obsoletes:      gnome-panel-nld-extras <= 2.12.3
%glib2_gsettings_schema_requires

%description extras
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

This package contains extra panel applets such as Wanda the fish.

%package devel
Summary:        GNOME Panel Applet Library -- Development Files
License:        LGPL-2.1+
Group:          Development/Libraries/GNOME
Requires:       libpanel-applet-4-0 = %{version}
Requires:       typelib-1_0-PanelApplet-4_0 = %{version}
# For upgrade from SLE 10
Provides:       gnome-panel-nld-devel > 2.12.3
Obsoletes:      gnome-panel-nld-devel <= 2.12.3

%description devel
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

This package contains all necessary include files and libraries needed
to develop applications that require these.

%package doc
Summary:        GNOME Panel Applet Library -- Developer Documentation
License:        LGPL-2.1+
Group:          System/GUI/GNOME
Requires:       %{name} = %{version}
# For upgrade from SLE 10
Provides:       gnome-panel-nld-doc > 2.12.3
Obsoletes:      gnome-panel-nld-doc <= 2.12.3

%description doc
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

This package contains optional documentation provided in addition to
this package's base documentation.

%lang_package
%lang_package -n gnome-panel-extras
%prep
%setup -q
translation-update-upstream
gnome-patch-translation-prepare
%patch25 -p0
%patch34
# %patch50
gnome-patch-translation-update

%build
%configure --with-pic \
    --libexecdir=%{_libexecdir}/gnome-panel \
    --disable-static \
    --with-in-process-applets=all \
    --disable-schemas-install \
    --disable-scrollkeeper
make %{?_smp_mflags} V=1

%install
%makeinstall
%if 0%{?suse_version} <= 1110
%{__rm} %{buildroot}%{_datadir}/locale/ha/LC_MESSAGES/*
%{__rm} %{buildroot}%{_datadir}/locale/la/LC_MESSAGES/*
%{__rm} %{buildroot}%{_datadir}/locale/ig/LC_MESSAGES/*
%endif
%if 0%{?suse_version} <= 1120
%{__rm} %{buildroot}%{_datadir}/locale/en@shaw/LC_MESSAGES/*
%endif
install -d %{buildroot}%{_libdir}/gnome-panel/modules
touch %{buildroot}%{_libdir}/gnome-panel/modules/giomodule.cache
%suse_update_desktop_file gnome-panel
%find_lang %{name}-3.0 %{?no_lang_C}
%find_lang clock %{?no_lang_C} %{name}-3.0.lang
%find_lang fish %{?no_lang_C} %{name}-extras.lang
find %{buildroot}%{_libdir} -name '*.la' -type f -delete -print
%fdupes %{buildroot}

%clean
rm -rf %{buildroot}

%post
%desktop_database_post
%icon_theme_cache_post
%glib2_gsettings_schema_post

%postun
%desktop_database_postun
%icon_theme_cache_postun
%glib2_gsettings_schema_postun

%post -n libpanel-applet-4-0 -p /sbin/ldconfig

%postun -n libpanel-applet-4-0 -p /sbin/ldconfig

%post extras
%icon_theme_cache_post
%glib2_gsettings_schema_post

%postun extras
%icon_theme_cache_postun
%glib2_gsettings_schema_postun

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%doc %{_datadir}/help/C/clock/
%dir %{_libdir}/gnome-panel
# generic directory for in-process applets
%dir %{_libdir}/gnome-panel/4.0
# directory for modules to load applets
%dir %{_libdir}/gnome-panel/modules
%ghost %{_libdir}/gnome-panel/modules/giomodule.cache
%if "%{_libdir}" != "%{_libexecdir}"
# generic directory for normal applets, and helpers
%dir %{_libexecdir}/gnome-panel
%endif
%{_bindir}/gnome-desktop-item-edit
%{_bindir}/gnome-panel
%{_datadir}/applications/gnome-panel.desktop
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.applet.window-list.gschema.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.applet.workspace-switcher.gschema.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.applet.clock.gschema.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.enums.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.gschema.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.launcher.gschema.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.menu-button.gschema.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.object.gschema.xml
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.toplevel.gschema.xml
%{_datadir}/gnome-panel/
%{_datadir}/icons/hicolor/*/apps/gnome-panel*.*
%doc %{_mandir}/man?/gnome-panel.*
%{_libexecdir}/gnome-panel/gnome-panel-add
# Internal applets
%{_libdir}/gnome-panel/4.0/*.so
# Files that are in the extras package
%exclude %{_datadir}/gnome-panel/4.0/applets/org.gnome.panel.FishApplet.panel-applet
%exclude %{_datadir}/gnome-panel/fish/
%exclude %{_datadir}/icons/hicolor/*/apps/gnome-panel-fish.*
%exclude %{_libdir}/gnome-panel/4.0/libfish-applet.so
# Files from  branding-upstream
%exclude %{_datadir}/gnome-panel/panel-default-layout.layout

%files branding-upstream
%defattr (-, root, root)
%{_datadir}/gnome-panel/panel-default-layout.layout

%files -n libpanel-applet-4-0
%defattr (-, root, root)
%doc COPYING.LIB
# applets using this library must install a file in %%{_datadir}/gnome-panel/applets
%dir %{_datadir}/gnome-panel/
%dir %{_datadir}/gnome-panel/4.0
%dir %{_datadir}/gnome-panel/4.0/applets
%{_libdir}/libpanel-applet-4.so.*

%files -n typelib-1_0-PanelApplet-4_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/PanelApplet-4.0.typelib

%files lang -f %{name}-3.0.lang

%files extras-lang -f %{name}-extras.lang

%files extras
%defattr (-, root, root)
%doc %{_datadir}/help/C/fish/
# When changing the file list here, please update the excluded files in the main package
%{_datadir}/glib-2.0/schemas/org.gnome.gnome-panel.applet.fish.gschema.xml
%{_datadir}/gnome-panel/4.0/applets/org.gnome.panel.FishApplet.panel-applet
%{_datadir}/gnome-panel/fish/
%{_datadir}/icons/hicolor/*/apps/gnome-panel-fish.*
%{_libdir}/gnome-panel/4.0/libfish-applet.so

%files devel
%defattr (-, root, root)
%{_bindir}/panel-test-applets
%{_datadir}/gir-1.0/*.gir
%{_includedir}/gnome-panel-4.0/
%{_libdir}/libpanel-applet-4.so
%{_libdir}/pkgconfig/libpanelapplet-4.0.pc

%files doc
%defattr (-, root, root)
%{_datadir}/gtk-doc/html/panel-applet-4.0/

%changelog
openSUSE Build Service is sponsored by