File mono-kde4.spec of Package mono-kde4

#
# spec file for package mono-kde4
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           mono-kde4
Version:        4.10.0
Release:        0
Summary:        Kimono Mono-kde library
License:        LGPL-2.1+
Group:          Development/Libraries/KDE
Url:            https://projects.kde.org/projects/kde/kdebindings/csharp/kimono
Source0:        ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kimono-%{version}.tar.xz
Patch0:         kimono-soprano.patch
BuildRequires:  kdebase4-workspace-devel
BuildRequires:  libjasper-devel
BuildRequires:  libkdepimlibs4-devel
BuildRequires:  libmono-2_0-devel
BuildRequires:  libqimageblitz-devel
BuildRequires:  libsmokegen-devel
BuildRequires:  libsmokekde-devel
BuildRequires:  mono-devel
BuildRequires:  mono-qt4-devel
BuildRequires:  monodoc-core
BuildRequires:  okular-devel
BuildRequires:  sqlite-devel
BuildRequires:  xz
Requires:       mono-qt4 = %{version}
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%kde4_akonadi_requires
%kde4_runtime_requires

%description
.NET/Mono bindings for the KDE libraries.

%prep
%setup -q -n kimono-%{version}
%patch0 -p1

%build
  %cmake_kde4 -d build
  %make_jobs

%install
  cd build
  %kde4_makeinstall
  %kde_post_install

%files
%defattr(-,root,root)
%{_kde4_appsdir}/plasma_scriptengine_kimono
%{_kde4_libdir}/libakonadi-sharp.so
%{_kde4_libdir}/libkhtml-sharp.so
%{_kde4_libdir}/libkimono.so
%{_kde4_libdir}/libktexteditor-sharp.so
%{_kde4_libdir}/libnepomuk-sharp.so
%{_kde4_libdir}/libplasma-sharp.so
%{_kde4_libdir}/libsoprano-sharp.so
%{_kde4_modulesdir}/kimonopluginfactory.so
%{_kde4_prefix}/lib/mono/qyoto
%{_kde4_prefix}/lib/mono/gac/akonadi
%{_kde4_prefix}/lib/mono/gac/kde-dotnet
%{_kde4_prefix}/lib/mono/gac/khtml-dll
%{_kde4_prefix}/lib/mono/gac/ktexteditor-dotnet
%{_kde4_prefix}/lib/mono/gac/nepomuk-dll
%{_kde4_prefix}/lib/mono/gac/plasma-dll
%{_kde4_prefix}/lib/mono/gac/soprano
%{_kde4_servicesdir}/plasma-scriptengine-kimono-applet.desktop
%{_kde4_servicesdir}/plasma-scriptengine-kimono-dataengine.desktop

%changelog