File dbus-1-python3.changes of Package dbus-1-python

-------------------------------------------------------------------
Mon Jun  3 18:03:45 UTC 2013 - asterios.dramis@gmail.com

- Removed the %{RELEASE} from the dbus-1 Requires: entries (fixes also Factory
  auto check).

-------------------------------------------------------------------
Sun Jun  2 20:55:37 UTC 2013 - asterios.dramis@gmail.com

- Update to version 1.2.0:
  Dependencies:
  - libdbus 1.6 or later is now required.
  Enhancements:
  - Unicode Corrigendum 9: when used with a suitable version of libdbus
    (1.6.10 or later, or 1.7.2 or later), noncharacters in strings are
    now accepted
  Fixes:
  - Support DBusException('something with non—ASCII') under Python 2
    (Michael Vogt, smcv; fd.o #55899)
  - Correct some misleading wording in COPYING which was written under the
    assumption that libdbus could actually be relicensed to MIT/X11
    (Thiago Macieira)
  - Avoid variable-length arrays, because MSVC++ is still stuck in 1998
    (based on patches from Christoph Höger, fd.o #51725)
  - Remove unnecessary uses of stdint.h (fd.o #51725)
  - Add support for Unix compilers not supporting 'inline', for completeness
  - Use GObject.__class__ instead of GObjectMeta, which can no longer be
    imported from gi.repository.GObject in pygobject 3.8
  - Fix autoreconfiscation on Automake 1.13 (Marko Lindqvist, fd.o #59006)
- Removed libxml2-python3 runtime requirement (not needed).

-------------------------------------------------------------------
Mon Nov 19 18:33:27 UTC 2012 - asterios.dramis@gmail.com

- Update to version 1.1.1:
  Dependencies:
  - libdbus 1.6 or later is now recommended. It is not strictly required yet.
  Fixes:
  - Validate UTF-8 according to the rules libdbus uses, falling back to our
    own (inefficient) implementation if not compiled against dbus >= 1.6
    (fdo#40817)
  - Under Python 3, in the absence of introspection or signature='...',
    pass dbus.ObjectPath or dbus.Signature arguments with the obvious
    signature 'o' or 'g', not 's'. This previously only worked in Python 2.
    (fdo#50740)
  From version 1.1.0:
  Deprecations:
  - dbus.gobject_service is deprecated. Use dbus.gi_service and PyGI in new
    code.
  API changes:
  - dbus.gobject_service works in legacy PyGObject 2 applications again,
    like it did before 1.0. The down side is that it doesn't work in all PyGI
    applications any more, unlike 1.0. In PyGI applications, depend on
    dbus-python >= 1.1 and use dbus.gi_service instead - its API is the same.
    (fdo#48904, deb#670516)
  - dbus.gobject_service has been removed from Python 3 builds altogether.
  Enhancements:
  - Use DBusBasicValue from libdbus 1.5, if available, rather than reinventing
    it
  Fixes:
  - Put sockets for the regression tests in /tmp, not the builddir, fixing
    test failures in a really long builddir (fdo#46747)
  - Fix a reference leak in dbus_py_variant_level_set (fdo#47108)
  - Modify AM_CHECK_PYTHON_HEADERS so the "another way" works with Python 3

-------------------------------------------------------------------
Sun May 27 11:05:03 UTC 2012 - highwaystar.ru@gmail.com

- python3 package added
- api docs currently not built because there is no epydoc for py3
- dbus-python.h renamed to dbus-python-%{py3_ver}.h
- шdbus-python.pc renamed to dbus-python-%{py3_ver}.pc
openSUSE Build Service is sponsored by