File perl-common-sense.changes of Package perl-common-sense

-------------------------------------------------------------------
Thu Jul  2 09:34:30 UTC 2015 - coolo@suse.com

- updated to 3.74
   see /usr/share/doc/packages/perl-common-sense/Changes

  3.74 Mon Jun 29 14:39:26 CEST 2015
  	- the generated README file was empty.

-------------------------------------------------------------------
Tue Apr 14 19:19:52 UTC 2015 - coolo@suse.com

- updated to 3.73
   see /usr/share/doc/packages/perl-common-sense/Changes

  3.73 Sat May 31 22:37:21 CEST 2014
  	- remove "deprecated", as it turned out to be yet another time bomb
            as p5p don't care the least about backwards compatibility
            anymore (https://rt.perl.org/Public/Bug/Display.html?id=119123).
  	- switching paths once more as this turned out to be a doc bug
            in eumm.  this should not affect anything though.

-------------------------------------------------------------------
Sun Aug  4 15:06:29 UTC 2013 - coolo@suse.com

- updated to 3.72
       - install paths were wrong for current MakeMaker (reported
          by various people).
       - CPAN failed to parse the version number in 3.7, try to work
          around.
       - move pod to separate file, to further improve loading times.
       - make it arch-specific, adding a test that warns when an old
          version is still installed.
       - due to a logic glitch, warnings were not enabled at all on 5.16.

-------------------------------------------------------------------
Sat Jun 15 06:18:25 UTC 2013 - coolo@suse.com

- updated to 3.6
     - work around more 5.16 breakage - $^H doesn't work as nicely as
        p5p make you to believe.
      - add features: unicode_strings current_sub fc evalbytes.
      - disable features: array_base.

-------------------------------------------------------------------
Wed May 23 13:00:12 UTC 2012 - coolo@suse.com

- updated to 3.5
    - localise $^W, as this causes warnings with 5.16 when some lost
      soul uses -w. common::sense doesn't support $^W, but tries to
      shield module authors and programs from its ill effects. If you
      enable $^W, then you normally get to keep the pieces because you
      change semantics of other people's code.

-------------------------------------------------------------------
Fri Mar  4 18:25:31 UTC 2011 - chris@computersalat.de

- update to 3.4
  - remove "regexp" category. this is rather painful as it's a large
    class, but unfortunately, somebody thought emitting a warning when
    you match more than 32kb of text is in some way useful, which
    spoils the whole category.
  - use META.json instead of META.yml - apparently YAML parsers don't
    actually exist.
- recreated by cpanspec 1.78.03

-------------------------------------------------------------------
Tue Nov 30 19:19:59 UTC 2010 - coolo@novell.com

- switch to perl_requires macro

-------------------------------------------------------------------
Tue Jul  6 08:08:50 UTC 2010 - chris@computersalat.de

- update tp 3.3
  - removed "exiting" category - this is too useful to create new
    control statements, and fails utterly with eval, as eval will
    catch the (fatal) warning itself. Kind of hurts, but this is
    just another warning category which is too broad and has to be
    disabled fully because of a minority of issues.
- noarch package
  o remove .packlist/perllocal.pod

-------------------------------------------------------------------
Fri Apr 16 11:38:48 UTC 2010 - chris@computersalat.de

- update to 3.2
  - removed "substr" warning - while it overall is a good category,
    "substr '', 2" is entirely sensible.
- 3.1  Sat Apr  3 04:56:36 CEST 2010
  - removed "parenthesis" warning:
    sysread $fh, my $buf, -s $fh; # ok
    sysread $fh, my $buf, $size;  # warning
    Made no sense to me, especially as $size is in scope.
  - no longer hardcode warning/struct bits, calculate them at
    installation time, for when I will no longer be alive etc.
  - tweaked documentation.
- fixed perl-macros deps

-------------------------------------------------------------------
Mon Jan 18 10:31:48 UTC 2010 - jw@novell.com

- update to 3.0, as suggested by JSON::XS

-------------------------------------------------------------------
Fri Sep  4 21:33:28 CEST 2009 - chris@computersalat.de

- initial pkg 2.0