File python-zope.testrunner.changes of Package python-zope.testrunner

-------------------------------------------------------------------
Thu Jun 29 19:43:55 UTC 2017 - aloisio@gmx.com

- Added missing requires for update-alternatives

-------------------------------------------------------------------
Fri Jun 23 09:19:42 UTC 2017 - aloisio@gmx.com

- Update to 4.7.0
  * Drop all support for ``subunit``.
  4.6.0:
  * Make the ``subunit`` support purely optional: applications
    which have been getting the dependencies via
    ``zope.testrunner`` should either add
    ``zope.testrunner[subunit]`` to their ``install_requires`` or
    else depend directly on ``python-subunit``.
  * New option ``--ignore-new-thread=<regexp>`` to suppress
    "New thread(s)" warnings.
  * Support Python 3.6.
  4.5.1:
  * Fixed: Using the ``-j`` option to run tests in multiple
    processes caused tests that used the ``multiprocessing``
    package to hang (because the testrunner replaced ``sys.stdin``
    with an unclosable object).
  * Drop conditional dependency on ``unittest2`` (redundant after
    dropping support for Python 2.6).
  4.5.0:
  * Stop tests for all layers when test fails/errors when started
    with -x/--stop-on-error
    (`#37 <https://github.com/zopefoundation/zope.testrunner/pull/37>`_).
  * Drop support for Python 2.6 and 3.2.
  4.4.10:
  * Add support for Python 3.5
    (`#31 <https://github.com/zopefoundation/zope.testrunner/pull/31>`_).
  * Insert extra paths (from ``--path``) to the front of sys.argv
    (`#32 <https://github.com/zopefoundation/zope.testrunner/issues/32>`_).
  4.4.9:
  * When using ``-j``, parallelize all the tests, including the
    first test layer
    (`#28 <https://github.com/zopefoundation/zope.testrunner/issues/28>`_).

- Converted to single-spec

-------------------------------------------------------------------
Mon Aug 15 14:51:56 UTC 2016 - toddrme2178@gmail.com

- Fix update-alternatives implementation.

-------------------------------------------------------------------
Fri May 15 13:47:39 UTC 2015 - benoit.monin@gmx.fr

- update to version 4.4.8:
  * Support skipped tests in subunit output
  * More efficient test filtering
- additional changes from version 4.4.7:
  * Work around a bug in PyPy3’s curses module (#24).
- additional changes from version 4.4.6:
  * Restore support for instance-based test layers that regressed
    in 4.4.5 (#20).
- additional changes from version 4.4.5:
  * Sort related layers close to each other to reduce the number of
    unnecessary teardowns (fixes #14).
  * Run the unit test layer first (fixes LP #497871).
- additional changes from version 4.4.4:
  * When looking for the right location of test code, start with
    longest location paths first. This fixes problems with nested
    code locations.
- additional changes from version 4.4.3:
  * Added support for Python 3.4.
- additional changes from version 4.4.2:
  * Drop support for Python 3.1.
  * Fix post-mortem debugging when a non-printable exception
    happens (#8).
- add runtime requirements python-six, python-zope.exceptions,
  python-zope.interface
- update the test requirements (still commented out, tests fail)
- fix update-alternatives

-------------------------------------------------------------------
Sat Nov 08 20:11:00 UTC 2014 - Led <ledest@gmail.com>

- fix bashism in pre script

-------------------------------------------------------------------
Thu Nov 14 15:45:40 UTC 2013 - p.drouand@gmail.com

- Add update-alternative support

-------------------------------------------------------------------
Wed Nov 13 13:08:41 UTC 2013 - p.drouand@gmail.com

- Update to version 4.4.1
  + Updated boostrap.py to version 2.2.
  + Fix nondeterministic test failures on Python 3.3
  + Tear down layers after post_mortem debugging is finished.
  + Fix tests that write to source directory, it might be read-only.
- Changes from 4.4.0 
  + Fix tests selection when the negative "!" pattern is used several times
    (LP #1160965)
  +  Moved tests into a 'tests' subpackage.
  + Made python -m zope.testrunner work again.
  + Support 'skip' feature of unittest2 (which became the new unittest in Python 2.7).
  + Better diagnostics when communication with subprocess fails
    (https://github.com/zopefoundation/zope.testrunner/issues/5).
  + Do not break subprocess execution when the test suite changes the working
    directory (https://github.com/zopefoundation/zope.testrunner/issues/6).
  + Count test module import errors as errors (LP #1026576).
- Add python-unittest2 and python-zope.interface commented BuildRequires;
  these are new requirements for test but there are still broken
- Add fdupes BuildRequires and use fdupes to remove duplicate files

-------------------------------------------------------------------
Thu Oct 24 11:18:03 UTC 2013 - speilicke@suse.com

- Require python-setuptools instead of distribute (upstreams merged)

-------------------------------------------------------------------
Fri Mar 15 14:03:51 UTC 2013 - speilicke@suse.com

- Initial version
openSUSE Build Service is sponsored by