File giggle.changes of Package giggle

-------------------------------------------------------------------
Fri Oct 10 18:22:13 UTC 2014 - zaitor@opensuse.org

- Add giggle-vte-2.91.patch: Fix build with vte-2.91
- Replace pkgconfig(vte-2.90) for pkgconfig(vte-2.91), due to above
  patch.

-------------------------------------------------------------------
Wed Apr 17 15:31:47 UTC 2013 - dimstar@opensuse.org

- Fix giggle-gtksourceview38.patch: gtksource 3.8 change the main
  header from gtksourceview.h to gtksource.h.

-------------------------------------------------------------------
Wed Apr  3 20:29:38 UTC 2013 - dimstar@opensuse.org

- Add giggle-gtksourceview38.patch: Fix build against new
  gtksourceview 3.8.

-------------------------------------------------------------------
Wed Nov  7 01:46:42 UTC 2012 - douglarek@outlook.com

- Update to version 0.7:
  + Bump minimum GLib required version to 2.30
  + build: Depends on gettext 0.18.1
  + Use G_VALUE_INIT
  + Use g_cclosure_marshal_generic for all signals
  + Use g_clear_object() and g_list_free_full() convenience
    functions
  + Use GtkGrid instead GtkTable
  + Use GDK symbolic names
  + Use gdk_event_triggers_context_menu() instead of check for
    event->button == 3
  + Update FSF Address
  + Do not use deprecated libebook api
  + build: Use the gnulib manywarnings macros
  + src/giggle-revision-view.c: Use a GtkLabel instead a
    GtkLinkButton
- Add gettext BuildRequires: new versioned dependency.
- Drop pkgconfig(libebook-1.2) BuildRequires: no longer needed.

-------------------------------------------------------------------
Thu Nov  1 04:59:47 UTC 2012 - douglarek@outlook.com

- Update to version 0.6.2:
  + build: Explicitly link to gmodule-2.0.
  + use the giggle api instead g_object_get()
- Drop giggle-link-gmodule.patch: fixed upstream.
- Drop xz BuildRequires as it now comes for free in the build
  system.
- Only conditionally use find_lang variant on openSUSE <= 12.1.

-------------------------------------------------------------------
Sun Feb 26 14:09:45 UTC 2012 - vuntz@opensuse.org

- Change itstool BuildRequires to yelp-tools: this is really what
  is needed for build.

-------------------------------------------------------------------
Thu Jan 19 13:50:18 UTC 2012 - vuntz@opensuse.org

- Fix build by explictly linking to gmodule-2.0:
  + Add giggle-link-gmodule.patch.
  + Add gnome-common BuildRequires and call to gnome-autogen.sh,
    needed for above patch.

-------------------------------------------------------------------
Tue Nov 15 12:31:29 UTC 2011 - dimstar@opensuse.org

- Update to version 0.6.1:
  + Several bugfixes
  + Updated translations.
- Changes from version 0.6:
  + Port to GTK+3
  + Added new mallard documentation
  + Establish giggle as url-handler for git:// links
  + Allow diff view to display diffs by chunks, files or all
  + Several bugfixes
- Drop giggle-ld_fix.patch: fixed upstream.
- Remove gnome-common BuildRequires and call to gnome-autogen.sh.
- Replace pkgconfig(gtk+-2.0) with pkgconfig(gtk+-3.0),
  pkgconfig(gtksourceview-2.0) with pkgconfig(gtksourceview-3.0)
  and pkgconfig(vte) with pkgconfig(vte-2.90), following upstream
  changes.
- Add itstool BuildRequires.
- Add localized help to -lang package. Install section inspired by
  aisleriot, which does the same.

-------------------------------------------------------------------
Mon Sep 19 09:17:17 UTC 2011 - vuntz@opensuse.org

- Update giggle-ld_fix.patch to the upstream fix.
- Add gnome-common BuildRequires and call to gnome-autogen.sh, as
  needed for the patch.
- Remove now unneeded export SUSE_ASNEEDED=0.

-------------------------------------------------------------------
Sat Sep 17 14:20:05 UTC 2011 - suse-tux@gmx.de

- Add giggle-ld_fix.patch to fix build with new ld behavior.

-------------------------------------------------------------------
Thu Apr 28 12:58:47 CEST 2011 - vuntz@opensuse.org

- Move to pkgconfig()-style BuildRequires:
  + Old ones: evolution-data-server-devel, gtk2-devel,
    gtksourceview-devel, vte-devel.
  + New ones: glib-2.0, gtk+-2.0, gtksourceview-2.0, libebook-1.2,
    vte.

-------------------------------------------------------------------
Mon Feb 14 17:48:31 CET 2011 - sbrabec@suse.cz

- Added support for translation-update-upstream.

-------------------------------------------------------------------
Sat Feb 12 17:45:01 CET 2011 - vuntz@opensuse.org

- Call relevant macros in %post/%postun:
  + %desktop_database_post/postun because the package ships at
    least one desktop file.
  + %icon_theme_cache_post/postun because the package ships themed
    icons.
- Pass %{?no_lang_C} to %find_lang so that english documentation
  can be packaged with the program, and not in the lang subpackage.
- Change Requires of lang subpackage to Recommends, since the
  english documentation is not there anymore.

-------------------------------------------------------------------
Thu Aug 12 16:00:30 CEST 2010 - vuntz@opensuse.org

- Update to version 0.5:
  + Several performance improvements
  + Fix crash when searching
  + Improve responsiveness when executing git commands
  * Some memory fixes
  + Updated translations.

-------------------------------------------------------------------
Thu Apr  1 20:15:44 CEST 2010 - vuntz@opensuse.org

- Clean up packaging from Contrib for inclusion in Factory:
  + Drop giggle-0.4-desktop.patch and instead use options of
    suse_update_desktop_file.
  + Drop libglade2-devel, perl-XML-Parser BuildRequires.
  + Improve description.
  + Requires git-core instead of git.

-------------------------------------------------------------------
Thu Apr  1 11:54:12 UTC 2010 - prusnak@suse.cz

- updated to 0.4.97

-------------------------------------------------------------------
Tue Feb 24 14:51:57 CET 2009 - prusnak@suse.cz

- updated to 0.4.91

-------------------------------------------------------------------
Tue Oct 23 10:17:57 CDT 2007 - maw@suse.de

- initial package (version 0.3)
openSUSE Build Service is sponsored by