File bomberclone.spec of Package bomberclone

#
# spec file for package bomberclone (Version 0.11.7)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Name:           bomberclone
BuildRequires:  SDL_image-devel SDL_mixer-devel fdupes
Summary:        Clone of the game AtomicBomberMan
Version:        0.11.7
Release:        127
License:        GPL v2 or later
Url:            http://www.bomberclone.de
Group:          Amusements/Games/Action/Other
Source:         %{name}-%{version}.tar.bz2
Patch:          bomberclone-docpath.patch
Patch1:         %{name}-%{version}_array-subscript.patch
Patch2:         %{name}-%{version}_prototype.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
AutoReqProv:    on

%description
Clone of the game AtomicBomberMan



Authors:
--------
    Maintainer:
      Steffen Pohle (steffen@bomberclone.de)
    
    Coding:
      Steffen Pohle (steffen@bomberclone.de)
      Patrick Wilczek
    
    Graphics:
      TekkRat  (playergfx, bombs, some tilesets)
    
    Testing and Other Help:
      Martijn de Boer (martijn@duncan.xs4all.nl)
      The people from the #gametome channel on irc.Freenode.net

%prep
%setup
%patch
%patch1
%patch2

%build
aclocal
autoconf
automake
export CFLAGS="$RPM_OPT_FLAGS"
./configure --enable-sdlmixer   \
            --prefix=%_prefix   \
            --mandir=%_mandir   \
            --infodir=%_infodir \
            --datadir=%_datadir
make

%install
make DESTDIR=$RPM_BUILD_ROOT install
%fdupes $RPM_BUILD_ROOT
# NEWS is empty, INSTALL is generic instructions
rm $RPM_BUILD_ROOT/%{_docdir}/bomberclone/{NEWS,INSTALL}

%clean

%files
%defattr(-,root,root)
%_docdir/bomberclone
%_datadir/games/bomberclone
%_bindir/bomberclone

%changelog
* Tue Jan 29 2008 aj@suse.de
- Add prototypes to fix build.
- Use fdupes.
- Use rpmoptflags.
* Tue Mar 13 2007 pgajdos@suse.cz
- fixed: 'warning: array subscript is above array bounds' (#242031)
- array_subscript.patch
* Fri Sep 29 2006 hmacht@suse.de
- update to 0.11.7 which fixes some security issues
  (novell bug 206913)
- remove CVS directories and content from tarball
* Mon Sep 11 2006 hmacht@suse.de
- add autoconf invocation
* Mon Aug 14 2006 hmacht@suse.de
- initial package checkin
- add patch to install documentation in standard path