File flim-xemacs.spec of Package flim-xemacs

#
# spec file for package flim-xemacs (Version 1.14.7)
#
# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Name:           flim-xemacs
BuildRequires:  compface krb5 libpng-devel libtiff-devel openldap2-devel xemacs xorg-x11-devel
License:        GPL v2 or later
Group:          Productivity/Editors/Emacs
Requires:       xemacs
AutoReqProv:    on
Version:        1.14.7
Release:        145
Url:            ftp://ftp.m17n.org/pub/mule/flim/
# original source is gzipped.
Source0:        ftp://ftp.m17n.org/pub/mule/flim/flim-1.14/flim-1.14.7.tar.bz2
Patch0:         fix-build.patch
Patch1:         autoloads.patch
Summary:        Lisp Library for Basic Features Concerning Internet Messages
#Summary(ja):  Internet message に関する基礎的な機能を提供するための汎用部品です。
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
%define prefix  /usr

%description
FLIM is a library that provides basic features about message
representation or encoding.



%prep
%setup -q -n flim-%{version}
%patch0 -p1
%patch1 -p1

%build
%define xemacs_package_dir /usr/share/xemacs/site-packages/
make package PACKAGEDIR=%{xemacs_package_dir}

%install
make install-package PACKAGEDIR=$RPM_BUILD_ROOT%{xemacs_package_dir}

%files 
%defattr(-,root,root)
%doc FLIM* ChangeLog NEWS README* VERSION
%dir %{xemacs_package_dir}/
%{xemacs_package_dir}/*

%changelog
* Tue Dec 04 2007 - mfabian@suse.de
- remove openldap2 from BuildRequires.
* Wed Jan 25 2006 - mls@suse.de
- converted neededforbuild to BuildRequires
* Wed May 18 2005 - mfabian@suse.de
- fix build with XEmacs 21.5.20 (function 'batch-update-directory'
  has disappeared in XEmacs 21.5.20).
* Mon Jan 03 2005 - mfabian@suse.de
- update to 1.14.7.
- fix build with XEmacs 21.5.18 (the variable
  'generated-autoload-file' apparently needs to be set otherwise
  XEmacs does not write ./auto-autoloads.el but write
  /usr/share/xemacs/21.5.18/lisp/auto-autoloads.el instead
  which is not writable when not building as root and which is
  probably the wrong place to write the semi autoloads anyway.
* Wed Feb 04 2004 - hmacht@suse.de
- added option # norootforbuild in specfile
* Sat Aug 23 2003 - mfabian@suse.de
- update to version 1.14.5.
* Fri Aug 22 2003 - mfabian@suse.de
- add xemacs-packagages and xemacs-packages-info to
  "# neededforbuild".
* Fri Jun 13 2003 - mfabian@suse.de
- add %%dir %%{xemacs_package_dir}/ to file list
* Thu Mar 06 2003 - ro@suse.de
- removed cyrus-sasl from neededforbuild
* Wed Nov 13 2002 - ro@suse.de
- use x-devel-packages in neededforbuild
* Mon Aug 12 2002 - ro@suse.de
- added canna-libs to neededforbuild
* Mon Aug 12 2002 - mfabian@suse.de
- update to version 1.14.4
* Fri Feb 01 2002 - ro@suse.de
- changed neededforbuild <libpng> to <libpng-devel-packages>
* Fri Aug 10 2001 - mfabian@suse.de
- update to version 1.14.3
* Mon May 07 2001 - mfabian@suse.de
- bzip2 source
* Sat Mar 24 2001 - mfabian@suse.de
- new package: flim-xemacs, version 1.13.2