File it-modprobe.patch of Package itrace

---
 bin/pi_load.sh   |   19 +------------------
 bin/pi_unload.sh |    6 +-----
 2 files changed, 2 insertions(+), 23 deletions(-)

--- a/bin/pi_load.sh
+++ b/bin/pi_load.sh
@@ -32,29 +32,12 @@
 module="pitrace"
 device="pitrace"
 mode="666"
-kversion=$(uname -r)
 
-if grep -q "version 2\.6" /proc/version
+if ! /sbin/modprobe --first-time ${module}
 then
-	mod_suffix='.ko'
-	PI_MOD_LOCATION=/lib/modules/${kversion}/extra/${module}${mod_suffix}
-elif grep -q "version 2\.4" /proc/version
-then
-	mod_suffix='.o'
-	PI_MOD_LOCATION=${PWD}/../driver/${module}${mod_suffix}
-else
-	echo "Unsupported Kernel Version, exiting."
 	exit 1
 fi
 
-# Load module if not already loaded
-if ! /sbin/lsmod | grep -q "^${module}"
-then
-	if ! /sbin/insmod ${PI_MOD_LOCATION}
-	then
-		exit 1
-	fi
-fi
 
 # remove stale nodes if they exist
 rm -f /dev/${device}
--- a/bin/pi_unload.sh
+++ b/bin/pi_unload.sh
@@ -32,9 +32,5 @@ rm -f /dev/${device}
 rm -f /dev/${device}[1-2]
 
 # Unload module if present
-if /sbin/lsmod | grep -q "^${module0}"
-then
-	/sbin/rmmod ${module0}
-fi
-
+/sbin/modprobe -r ${module0}