File limal-apparmor-control.spec of Package limal-apparmor-control

#
# spec file for package limal-apparmor-control (Version 1.5.1)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Url:            http://forge.novell.com/modules/xfmod/project/?apparmor

Name:           limal-apparmor-control
Version:        1.5.1
Release:        1
License:        GPL v2 or later
Group:          Development/Libraries/C and C++
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        limal-apparmor-control-1.5.1.tar.bz2
Prefix:         /usr
%define		swiglibdir /usr/share/limal/typemaps 
BuildRequires:  curl gcc-c++ limal-devel limal-devtools limal-perl perl-gettext sgml-skel
Summary:        Limal pluglib to Control the AppArmor service

%description
Limal pluglib for AppArmor that provides hooks to enable and disable
the AppArmor service.



Authors:
--------
    mbarringer@suse.de

%package devel
License:        GPL v2 or later
Requires:       limal-apparmor-control = %version
Requires:       limal-devel
Group:          Development/Libraries/C and C++
Summary:        Development libraries and header files for the apparmor-control limal pluglib.

%description devel
Development libraries and header files for the apparmor-control limal
pluglib.



Authors:
--------
    mbarringer@suse.de

%package perl
License:        GPL v2 or later
Requires:       limal-perl
%if 0%{?fedora_version} >= 7
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%else
Requires:       perl = %{perl_version}
%endif
Group:          Development/Libraries/C and C++
Summary:        Limal pluglib for AppArmor that provides hooks to enable/disable the AppArmor service.

%description perl
Limal pluglib for AppArmor that provides hooks to enable/disable the
AppArmor service.



Authors:
--------
    mbarringer@suse.de

%prep
%setup -n limal-apparmor-control-1.5.1

%build
%{prefix}/bin/limaltool limalautoconf
%{prefix}/bin/limaltool limalautomake
autoreconf --force --install --verbose
export CFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
export CXXFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
%{?suse_update_config:%{suse_update_config -f}}
# workaround for fedora gettext check on x86_64
sed -i -e 's/return (int) gettext/return (long) gettext/g' ./configure
./configure --libdir=%{_libdir} --prefix=%{prefix} --mandir=%{_mandir} \
            --sysconfdir=/etc --localstatedir=/var
make %{?jobs:-j%jobs}

%install
make install DESTDIR="$RPM_BUILD_ROOT"
[ -e "%{prefix}/share/limal/devtools/NO_MAKE_CHECK" ] || \
           LIMALDATADIR="$RPM_BUILD_ROOT/usr/share/limal"  \
# required for perl test cases
export LD_LIBRARY_PATH="$RPM_BUILD_ROOT/usr/lib/limal"
make check DESTDIR="$RPM_BUILD_ROOT"
%find_lang %name 

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean
rm -rf "$RPM_BUILD_ROOT"

%files -f %name.lang
%defattr(-,root,root)
%dir %{_libdir}/limal
%{_libdir}/limal/lib*.so.*

%files devel
%defattr(-,root,root)
%dir %{_libdir}/limal
%{_libdir}/limal/lib*.so
%{_libdir}/limal/lib*.la
%dir %{_includedir}/limal/apparmor-control
%{_includedir}/limal/apparmor-control/*
%{_libdir}/pkgconfig/limal-apparmor-control.pc
%doc %{_prefix}/share/doc/packages/limal-apparmor-control

%files perl
%defattr(-,root,root)
%dir %{perl_vendorarch}/LIMAL
%dir %{perl_vendorarch}/auto/LIMAL
%dir %{perl_vendorarch}/auto/LIMAL/ApparmorControl/
%{perl_vendorarch}/auto/LIMAL/ApparmorControl/*
%{perl_vendorarch}/LIMAL/*.pm
%changelog
* Wed Nov 05 2008 mc@suse.de
- version 1.5.1
- update translation files
* Wed Sep 03 2008 mc@suse.de
- version 1.5.0
- update translation files
* Fri Jun 06 2008 mc@suse.de
- version 1.4.5
- update translation files
* Fri May 09 2008 mc@suse.de
- version 1.4.4
- update translation files
* Thu Apr 03 2008 mc@suse.de
- version 1.4.3
- use $limaldatadir/typemaps for own swig typemaps (bnc#373586)
- update translation files
* Wed Feb 13 2008 mc@suse.de
- version 1.4.2
- gcc fixes
- %%lang support in specfile
- update localization files
* Fri Nov 09 2007 mc@suse.de
- version 1.4.1
- build with new libblocxx-devel
- change SONAME because of new blocxx6
* Thu Oct 11 2007 mc@suse.de
- version 1.4.0
- update translation files
* Mon Aug 20 2007 mc@suse.de
- version 1.3.1
- update translation files
* Wed Jul 18 2007 mt@suse.de
- version 1.3.0
* Fri Apr 27 2007 mc@suse.de
- update translation files
* Mon Jan 15 2007 mc@suse.de
- merge proofreaded texts
* Fri Nov 17 2006 mc@suse.de
- version 1.2.6
- add translation
* Mon Nov 13 2006 mc@suse.de
- version 1.2.5
- update translations
* Mon Nov 06 2006 mc@suse.de
- version 1.2.4
- update translations
* Thu Nov 02 2006 mc@suse.de
- version 1.2.3
- update translation (de)
* Mon Oct 23 2006 mc@suse.de
- version 1.2.2
- add translations(pl fi)
* Mon Oct 16 2006 mc@suse.de
- add first set of translated texts
  (cs da de et hu id km lt mk nb pt ru tr)
* Thu Sep 28 2006 mt@suse.de
- version 1.2.1
- Adopted to build with blocxx-1.x as well as upcoming blocxx-2.x
- Fixed to use limal::Logger interface in skeleton testcases
- Commented out locale wildcard in spec file
* Tue Sep 26 2006 mc@suse.de
- merge proofreaded texts
* Wed Jul 26 2006 mt@suse.de
- version 1.2.0
- changed to use new gettext translation mechanisms
* Mon Apr 03 2006 mbarringer@suse.de
- Fixing bug 154394 - Reworked the code to clear up any conflicts,
  also to use limal-runlevel
* Sat Jan 28 2006 mbarringer@suse.de
- Changed references to support scripts as a result of the name
  change.
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Mon Jan 16 2006 mbarringer@suse.de
- created package (version 1.0.0)