File php-5.3.3-CVE-2010-4698.patch of Package php5

--- ext/gd/gd.c	2010/12/08 08:20:44	306074
+++ ext/gd/gd.c	2010/12/08 08:45:56	306075
@@ -4228,6 +4228,11 @@
 		return;
 	}
 
+	if (aa_steps != 4 && aa_steps != 16) {
+		php_error_docref(NULL TSRMLS_CC, E_WARNING, "Antialias steps must be 4 or 16");
+		RETURN_FALSE;
+	}
+
 	ZEND_FETCH_RESOURCE(bg_img, gdImagePtr, &img, -1, "Image", le_gd);
 	ZEND_FETCH_RESOURCE(f_ind, int *, &fnt, -1, "Type 1 font", le_ps_font);
openSUSE Build Service is sponsored by