File apache2-mod_jk.changes of Package apache2-mod_jk

-------------------------------------------------------------------
Tue Aug  3 13:01:34 UTC 2010 - gaboo@gaboo.org

- Update to version 1.2.30
  * Apache: Improve compatibility with Apache 2.3. (rjung)
  * AJP: Improve socket shutdown handling. (mturk)
  * AJP: Ensure we never reuse a non reusable socket. (mturk)
  * AJP: Tolerate a single excess packet when waiting for cpong. (mturk)
  * AJP: Check protocol correctness more strictly. (mturk)
  * other bug fixes and improvements
  * http://tomcat.apache.org/connectors-doc/miscellaneous/changelog.html

-------------------------------------------------------------------
Tue Oct 13 06:52:58 UTC 2009 - mvyskocil@suse.cz

- bnc#493575 - VUL-1: apache2-mod_jk: mod_jk information leak
  added jakarta-tomcat-connectors-4.1.30-src-CVE-2008-5519.patch
  http://svn.eu.apache.org/viewvc?view=rev&revision=702540

-------------------------------------------------------------------
Thu Sep 11 15:23:18 CEST 2008 - skh@suse.de

- update to version 1.2.26
- full changelog at
  http://tomcat.apache.org/connectors-doc/miscellaneous/changelog.html

-------------------------------------------------------------------
Mon Mar  5 14:57:06 CET 2007 - skh@suse.de

- update to version 1.2.21 (fix CVE-2007-0774: Long URL Stack Overflow
  Vulnerability, b.n.c. #248157)

-------------------------------------------------------------------
Wed Jan 17 13:48:16 CET 2007 - skh@suse.de

- update to newer (sic!) version 1.2.20
- remove apache13 cruft from spec file and patches

-------------------------------------------------------------------
Mon Oct 23 13:47:07 CEST 2006 - poeml@suse.de

- rename from mod_jk (name of source rpm) resp. mod_jk-ap20 (name
  of binary rpm) to apache2-mod_jk

-------------------------------------------------------------------
Tue Feb  7 14:27:23 CET 2006 - poeml@suse.de

- remove apr_sockaddr_port_get() call which is obsolete in libapr 1
- fix missing include
- bzip2 the source tarball

-------------------------------------------------------------------
Mon Jan 30 14:04:04 CET 2006 - poeml@suse.de

- removed libapr-util1-devel from BuildRequires (apache2-devel does
  require it)                                                                                                                                          

-------------------------------------------------------------------
Wed Jan 25 21:38:21 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Mon Jan 23 11:29:47 CET 2006 - poeml@suse.de

- make the package depend on the apache module API version

-------------------------------------------------------------------
Thu Jan 19 13:13:15 CET 2006 - cthiel@suse.de

- removed unneeded sources
  * apr-util-0.9.4.tar.gz 
  * apr_20030819101622.tar.bz2
  * apr_20030819101622-apache2_cflags.patch
  * apr_20030819101622.patch
- fixed build

-------------------------------------------------------------------
Tue Nov  8 14:10:56 CET 2005 - dmueller@suse.de

- don't build as root 

-------------------------------------------------------------------
Wed Sep 29 16:57:44 CEST 2004 - skh@suse.de

- Added better documentation and sample configuration (#46081)

-------------------------------------------------------------------
Mon Sep 13 16:08:02 CEST 2004 - skh@suse.de

- First separate package (no longer a subpackage of tomcat)
- Switch to JPackage package layout, but keep newer version 4.1.30 from
  former package apache2-jakarta-tomcat-connectors
openSUSE Build Service is sponsored by