File gcc41-makeinfo.patch of Package gcc41

2007-09-23  Jakub Jelinek  <jakub@redhat.com>

        * configure.ac (MAKEINFO): Handle makeinfo version 4.10 and above.
        * configure: Regenerated.

2007-09-15  Alan Modra  <amodra@bigpond.net.au>

        * configure.in: Correct makeinfo version check.
        * configure: Regenerate.

Index: configure
===================================================================
--- configure	(revision 128694)
+++ configure	(revision 128695)
@@ -3549,7 +3549,7 @@ case " $build_configdirs " in
     # For an installed makeinfo, we require it to be from texinfo 4.2 or
     # higher, else we use the "missing" dummy.
     if ${MAKEINFO} --version \
-       | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|[5-9])' >/dev/null 2>&1; then
+       | egrep 'texinfo[^0-9]*(4\.([2-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
       :
     else
       MAKEINFO="$MISSING makeinfo"
Index: gcc/configure
===================================================================
--- gcc/configure	(revision 128694)
+++ gcc/configure	(revision 128695)
@@ -7495,7 +7495,7 @@ else
   echo "configure:7495: version of makeinfo is $ac_prog_version" >&5
   case $ac_prog_version in
     '')     gcc_cv_prog_makeinfo_modern=no;;
-    4.[2-9]*)
+    4.[2-9]*|4.[1-9][0-9]*|[5-9]*|[1-9][0-9]*)
             gcc_cv_prog_makeinfo_modern=yes;;
     *)      gcc_cv_prog_makeinfo_modern=no;;
   esac
Index: gcc/configure.ac
===================================================================
--- gcc/configure.ac	(revision 128694)
+++ gcc/configure.ac	(revision 128695)
@@ -833,7 +833,7 @@ MISSING="${CONFIG_SHELL-/bin/sh} $srcdir
 # that we can use it.
 gcc_AC_CHECK_PROG_VER(MAKEINFO, makeinfo, --version,
   [GNU texinfo.* \([0-9][0-9.]*\)],
-  [4.[2-9]*])
+  [4.[2-9]*|4.[1-9][0-9]*|[5-9]*|[1-9][0-9]*])
 if test $gcc_cv_prog_makeinfo_modern = no; then
   MAKEINFO="$MISSING makeinfo"
   AC_MSG_WARN([
Index: configure.in
===================================================================
--- configure.in	(revision 128694)
+++ configure.in	(revision 128695)
@@ -2134,7 +2134,7 @@ changequote(,)
     # For an installed makeinfo, we require it to be from texinfo 4.2 or
     # higher, else we use the "missing" dummy.
     if ${MAKEINFO} --version \
-       | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|[5-9])' >/dev/null 2>&1; then
+       | egrep 'texinfo[^0-9]*(4\.([2-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
       :
     else
       MAKEINFO="$MISSING makeinfo"
openSUSE Build Service is sponsored by