File libgssglue.changes of Package libgssglue

-------------------------------------------------------------------
Sun Oct 31 12:37:02 UTC 2010 - jengelh@medozas.de

- Use %_smp_mflags

-------------------------------------------------------------------
Sat Apr 24 09:23:31 UTC 2010 - coolo@novell.com

- buildrequire pkg-config to fix provides

-------------------------------------------------------------------
Wed Oct 28 18:14:37 UTC 2009 - crrodriguez@opensuse.org

- libgssglue-devel Requires glibc-devel 

-------------------------------------------------------------------
Mon Aug  3 18:01:11 CEST 2009 - meissner@suse.de

- added missing fclose

-------------------------------------------------------------------
Wed Oct 22 16:17:18 CEST 2008 - mrueckert@suse.de

- fix debug_packages_requires define

-------------------------------------------------------------------
Fri Aug  1 17:32:08 CEST 2008 - ro@suse.de

- fix requires for debuginfo package

-------------------------------------------------------------------
Wed May  7 21:22:22 CEST 2008 - coolo@suse.de

- provide and obsolete in the same package

-------------------------------------------------------------------
Fri Mar 28 11:39:55 CET 2008 - lrupp@suse.de

- provide the latest used version (0.11) of old package

-------------------------------------------------------------------
Wed Mar 26 14:49:38 CET 2008 - mkoenig@suse.de

- update to version 0.1 of renamed libgssglue
- upstream library rename libgssapi -> libgssglue 
  to resolve conflicts with Heimdal and MIT libraries named
  libgssapi.
- package restucturing due to shlib policy:
  new packages libgssglue1, libgssglue-devel

-------------------------------------------------------------------
Mon Feb 25 06:46:29 CET 2008 - crrodriguez@suse.de

- fix library-without-ldconfig-postin errors 

-------------------------------------------------------------------
Fri May 11 18:14:54 CEST 2007 - mkoenig@suse.de

- update to version 0.11:
  * Add glue routine for gss_krb5_ccache_name

-------------------------------------------------------------------
Tue Sep  5 17:40:13 CEST 2006 - ro@suse.de

- added config file /etc/gssapi_mech.conf (#203248) 

-------------------------------------------------------------------
Wed Aug  9 01:06:25 CEST 2006 - ro@suse.de

- update to version 0.10 (changes since 0.6):
  - Add symbol versioning script and use it when linking
    the library.  This allows us to use the gss_* symbols
    from MIT gssapi_krb5 libraries without namespace
    collision problems.  This is required for use with
    MIT release 1.5 which no longer exports the krb5_gss_*
    symbols.  (This should also allow us to work with
    Heimdal as well. Currently untested.)
  - Remove code that tries to get symbols with names
    krb5_gss_*.
  - Correct declaration and implementation of
    gss_export_lucid_sec_context(). This results in an
    interface change.  The soname is updated to reflect this.
  - Memory leak: free union_name in gss_acquire_cred if
    it was allocated there.
  - Don't exit() the application if initialization fails,
    just fail the operation.
  - Add glue routines for gss_canonicalize_name and
    gss_export_name
  - Make "first-class" routines for gss_get_mic,
    gss_verify_mic, gss_wrap, and gss_unwrap
  - Clean up some clutter of unused #ifde'd code
  - Patch from Timo Aaltonen <tjaalton@cc.hut.fi> for
    Debian packaging.
  - Change union_name definition such that external_name
    is a gss_buffer_desc rather than gss_buffer_t.
    Eliminates unnecessary malloc'ing and freeing.
  - A patch from Olaf Kirch <okir@suse.de> to
    gss_inquire_cred() to remove a potential
    problem of an uninitialized variable and to return
    an error if generic_gss_copy_oid() fails.
  - Revert a bad change made to gss_free_lucid_sec_context().
  - Clean up some compiler warnings

-------------------------------------------------------------------
Wed Jan 25 21:37:29 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Mon Dec 12 12:44:24 CET 2005 - okir@suse.de

- Update to latest upstream version (0.6)

-------------------------------------------------------------------
Fri May 20 12:03:38 CEST 2005 - okir@suse.de

- Initial packaging