File libproxy.changes of Package libproxy.999

-------------------------------------------------------------------
Wed Oct 10 19:28:24 UTC 2012 - dimstar@opensuse.org

- Add libproxy-CVE-2012-4504.patch: Fix buffer overflow downloading
  large pac file (CVE-2012-4505, bnc#785235).

-------------------------------------------------------------------
Mon Aug  8 15:29:41 UTC 2011 - dimstar@opensuse.org

- Add libproxy-trim-ignores.patch: Trim strings in ignore list.
  Fix bnc#679322.

-------------------------------------------------------------------
Wed Jun 22 19:08:18 UTC 2011 - dimstar@opensuse.org

- Update to version 0.4.7 (for bnc#701059):
  + Support/require xulrunner 2.0+
  + Support linking againgst libwebkit-gtk3 (-DWITH_WEBKIT3=ON)
  + Port to gsettings for gnome3. (-DWITH_GNOME3=ON[default])
  + Issues closed:
    - #149: always test for the right python noarch module path
    - #155: Cannot compile with Firefox 4
    - #156: libproxy should build against webkitgtk-3.0
    - #158: Won't compile w/ xulrunner 2.0 final
    - #159: libproxy fails with autoconfiguration
            "http://proxy.domain.com"
    - #131: GSettings-based GNOME plugin
    - #150: SUSE sysconfig/proxy config support
- Build gnome2 module and webkitgtk linked against gtk2.
  -DWITH_GNOME3=OFF
  -DWITH_WEBKIGTK3=OFF

-------------------------------------------------------------------
Tue Feb 15 19:16:02 UTC 2011 - dimstar@opensuse.org

- Add libproxy-backports.patch: Backport critical fixes from 
  upstream codestream.

-------------------------------------------------------------------
Mon Feb 14 17:14:18 UTC 2011 - dimstar@opensuse.org

- Add libproxy-xul2.patch: Add compatibility to build against
  xulrunner 2.0. Patch submitted upstream, issue#155.
- Use xulrunner 2.0 on openSUSE 11.4.

-------------------------------------------------------------------
Mon Dec  6 16:32:28 CET 2010 - vuntz@opensuse.org

- Add libproxy-sysconfig-support.patch, to support the proxy
  configuration from sysconfig. Part of bnc#655483.
  Patch written by Duncan Mac-Vicar <dmacvicar@novell.com>.

-------------------------------------------------------------------
Thu Sep  2 09:38:47 CEST 2010 - dimstar@opensuse.org

- Update to version 0.4.6:
  + Fixed a crash in the URL parser
  + Fixed build issues with Visual Studio
  + Updated the INSTALL file
  + Install Python binding in prefix path if site-packages exists

-------------------------------------------------------------------
Fri Aug 20 15:16:46 UTC 2010 - dimstar@opensuse.org

- Mono bindings are not available for all supported platforms,
  thus wrapping it in a if have_mono [...] endif.

-------------------------------------------------------------------
Thu Aug 19 22:16:22 UTC 2010 - dimstar@opensuse.org

- Check for build_snapshot: the svn snapshot project contains
  unversioned tarballs.

-------------------------------------------------------------------
Thu Aug 19 15:49:02 UTC 2010 - dimstar@opensuse.org

- Update to version 0.4.5:
  + C# bindings are installable (-DWITH_DOTNET=ON)
  + C# bindings installation path can be changed using -DGAC_DIR=
  + Internal libmodman build fixed
  + Installation dirs are now all relative to CMAKE_INSTALL_PREFIX
  + Fixed test while using --as-needed linker flag
  + Fixed generation of libproxy-1.0.pc
  + Basic support for Mingw added (not yet 100% functional)
  + Ruby binding implemented (not yet in the build system)
  + Fixed modules not being found caused by relative
    LIBEXEC_INSTALL_DIR
  + Fixed bug with builtin plugins (Issue 133)
  + Vala bindings installation path can be changed using
    -DVAPI_DIR=
  + Python bindings installation path can be changed using
    -DPYTHON_SITEPKG_DIR=
  + Perl bindings can be installed in vendor directory
    (-DPERL_VENDORARCH=ON)
  + Perl bindings installation path can be change using
    -DPX_PERL_ARCH=
  + Unit test now builds on OSX
- Changes from version 0.4.4:
  + Add support for optionally building using a system libmodman
  + Rework build system to be cleaner
  + Fix two major build system bugs: 127, 128

-------------------------------------------------------------------
Mon Jul  5 21:42:37 UTC 2010 - dimstar@opensuse.org

- Add mono-devel BuildRequires to install the csharp bindings. 

-------------------------------------------------------------------
Tue Jun 22 17:48:31 UTC 2010 - dimstar@opensuse.org

- Initial work to support win32 cross building.

-------------------------------------------------------------------
Mon Jun 14 17:48:01 UTC 2010 - dimstar@opensuse.org

- Use external libmodman: add libmodman-devel BuildRequires.
- Drop libmodman0 subpackage

-------------------------------------------------------------------
Wed Jun  9 22:52:05 UTC 2010 - dimstar@opensuse.org

- Enable build on other distributions than openSUSE, wrapping
  openSUSE rpm tags like Recommends and Supplements in %if
  statements.

-------------------------------------------------------------------
Mon Jun  7 17:01:55 UTC 2010 - dimstar@opensuse.org

- Update to version 0.4.3:
  + Test can now be out-compiled using BUILD_TESTING=OFF
  + Fixed python binding not handling NULL pointer
  + Pyhton binding now support Python version 3
  + Rewrote URL parser to comply with unit test (bnc#612007)
  + Username and password are now URL encoded
  + Scheme comparison is now non-case sensitive
  + Fixed deadlock using WebKit as PAC runner
  + Fixed OS X compilation of Perl bindings
- libmodman0_0_0 is now correctly called libmodman0, follow this
  change also in baselibs.conf

-------------------------------------------------------------------
Tue May 25 16:04:53 UTC 2010 - dimstar@opensuse.org

- Update to version 0.4.2:
  + Fixed python bindings
  + Workaround cmake bug with dynamic libraries in non-standard
    folders.

-------------------------------------------------------------------
Tue May 18 18:39:50 UTC 2010 - dimstar@opensuse.org

- Update to version 0.4.1:
  + Improved cross-platform build
  + Added Perl and Vala bindings
  + Fix multiple infinite loop bugs
  + Fix random crash with Gnome backend
  + Standardized Gnome backend based on Mozilla and Chrome behavior
  + Removed dependency to X11 in Gnome backend
  + Allow disabling features at build time using WITH_* cmake
    options
  + Module path can now be altered using PX_MODULE_PATH environment
  + pxgconf helper location can be altered using PX_GCONF
    environment
  + Removed proxy scheme filtering, we now trust config modules
  + socks5:// and socks4:// is now allowed
  + Fix crash when password is empty string
  + Complete list of bug fixes:
    - #19, #59, #65, #86, #87, #88, #89, #90, #91, #92, #93, #97,
      #98, #99, #100, #101, #102, #103, #106, #108, #110
  + Known issues:
    + #109 - Scheme comparison is case sensitive
    + #112 - Username and password are not URI encoded

-------------------------------------------------------------------
Thu Mar 29 22:49:21 UTC 2010 - dimstar@opensuse.org

- Update to svn snapshot 626
  + No longer require xlib to detect session.
- Remove xorg-x11-libXmu-devel BuildRequires.

-------------------------------------------------------------------
Fri Mar 26 13:18:23 CET 2010 - vuntz@opensuse.org

- Build against mozilla-xulrunner192-devel on openSUSE > 11.2.

-------------------------------------------------------------------
Mon Mar 15 07:01:20 UTC 2010 - dimstar@opensuse.org

- Update to svn snapshot 621 in order to fix some serious crashes
  in config_gnome. This is close to what will be the 0.4.1 release.
- Drop all patches as they came from upstream and are included
  in this snapshot already.

-------------------------------------------------------------------
Wed Mar 10 10:41:45 UTC 2010 - dimstar@opensuse.org

- Do not forcibly require libmodman from the tools package. It's
  pulled in by library dependencies.

-------------------------------------------------------------------
Wed Mar 10 09:43:01 UTC 2010 - coolo@novell.com

- add libmodman0_0_0 to baselibs.conf

-------------------------------------------------------------------
Sat Mar  6 18:32:06 UTC 2010 - dimstar@opensuse.org

- Add libproxy-gcc45.patch to fix build with gcc 4.5. Patch comes
  from upstream svn, rev 599. 

-------------------------------------------------------------------
Fri Feb 26 09:44:18 CET 2010 - dimstar@opensuse.org

- Update to version 0.4.0:
  + C++ rewrite
  + Small API change (px_proxy_factory_get_proxy() can now return
    NULL)
  + SOVERSION bump
  + libmodman is now a separate library
  + Migrate to cmake
  + Windows support (config_w32reg, ignore_hostname; VC++ support)
  + MacOSX support (config_macosx, ignore_hostname)
  + Built-in modules support
  + Support for chunked encoding
  + Move to hidden visibility by default
  + KDE's KConfig semantics are fully supported
  + Removeal of all PX_* env variables (no longer needed)
  + Symbol based detection of relevant pacrunner
  + Reworked config_gnome to not suck (its *much* faster)
  + Many other things I can't remember  
- BuildRequire cmake, gccc-++ and zlib-devel
- Add libproxy-pysitelib.patch, as the python bindings are are
  arch-independent
- Add libproxy-libexecpatch.patch to move library helpers to proper
  libexecdir.
- Build the python-package as noarch
- sonum bump to 1, thus changing name to libproxy1
- Split out libmodman (will not follow the versioning of libproxy
  in the long run).
- Add libproxy-pkgconfig.patch to also install the .pc file.

-------------------------------------------------------------------
Tue Jan  5 17:17:30 CET 2010 - jengelh@medozas.de

- Package baselibs.conf

-------------------------------------------------------------------
Thu Oct  8 19:34:24 UTC 2009 - dimstar@opensuse.org

- Update to version 0.3.1
  + Bugfixes
    - config file parser reads all sections
    - KDE session detection based on environment varibales,
      as suggested by KDE upstream.
  + KDE configuration module is the first module in C++ and
    now links to libkdecore4 in order to properly detect the
    configuration folder for kde.
  + At the moment we're not compatible with KDE3. Sorry.
  + .NET bindings can now properly be installed and it should
    be possible for packagers to provide them.
- Add gcc-c++, libkde4-devel and libqt4-devel for updated kde mod.
- This update solves bnc#546199.

-------------------------------------------------------------------
Mon Aug 17 00:10:04 CEST 2009 - dominique-obs@leuenberger.net

- Update to version 0.3.0
  + WARNING!!! Slight API change!!! see docs for
    px_proxy_factory_get_proxies()
  + Credentials support (see API change above)
  + A complete rewrite of the module manager
  + file:// as valid PAC URLs
  + Sample Mono application
  + Automake 1.11 shaved output
  + gnome backend rewrite (now w/o thread issues)
  + Test suite base functionality exists
  + Many solaris build fixes
  + Seamonkey support as JS pacrunner
  + Bugfixes
  + Compiles for MS Windows using Mingw
- Split additional modules out in separate packages.

-------------------------------------------------------------------
Wed Aug 12 12:54:22 CEST 2009 - dominique-obs@leuenberger.net

- Use new python macros on openSUSE <= 11.1

-------------------------------------------------------------------
Sun Aug  9 12:43:26 CEST 2009 - coolo@novell.com

- use new python macros

-------------------------------------------------------------------
Mon Jun 22 12:46:40 CEST 2009 - dominique-obs@leuenberger.net

- Add libproxy-svn-303_as-needed.patch to successfully build with
  --as-needed

-------------------------------------------------------------------
Tue Jun 16 13:39:41 CEST 2009 - dominique-obs@leuenberger.net

- Extend baselibs.conf
  We also need the plugins 32bit. The 32bit plugin get's installed
  as soon as the 32bit librarz is installed. Same featureset is
  recommended, bnc#485543

-------------------------------------------------------------------
Wed May 13 03:38:07 CEST 2009 - vuntz@novell.com

- Tag patches.

-------------------------------------------------------------------
Wed May  6 15:08:14 CEST 2009 - vuntz@novell.com

- Build libproxy-plugins against mozilla-xulrunner191 on
  openSUSE > 11.1.

-------------------------------------------------------------------
Thu Apr 23 22:59:26 CEST 2009 - vuntz@novell.com

- Change Name to libproxy-plugins in libproxy-plugins.spec.

-------------------------------------------------------------------
Thu Apr 16 23:09:30 CEST 2009 - vuntz@novell.com

- Split the build in two steps, libproxy and libproxy-plugins, to
  avoid a build loop: libproxy depends on libwebkit which depends
  on libsoup which depends on libproxy. So we now have a new spec
  file for libproxy-plugins where the libwebkit dependency is.

-------------------------------------------------------------------
Sun Mar 15 00:10:29 CET 2009 - vuntz@novell.com

- Review changes.

-------------------------------------------------------------------
Sat Mar 14 09:41:22 CET 2009 - wr@rosenauer.org

- use correct mozilla/xulrunner dependencies

-------------------------------------------------------------------
Mon Feb 23 13:57:01 CET 2009 - vuntz@novell.com

- Revert the use of %{libproxy_shnum}: there are places where the
  macro cannot be used (%files, eg), and we want don't want to mix
  libproxy0 and libproxy%{libproxy_shnum} -- too likely to forget
  to update one of the two instances.

-------------------------------------------------------------------
Sun Feb 22 02:14:14 CET 2009 - vuntz@novell.com

- Review changes.
- Add Provides/Obsoletes after plugin packages renaming.
- Don't use %{name} everywhere: in some places, it doesn't help
  with clarity; in some others, it could be wrong in the future (in
  Supplements).

-------------------------------------------------------------------
Tue Feb 17 11:06:18 CET 2009 - domninique-obs@leuenberger.net

- Replace the %{name}0 all over by %{name}%{libproxy_shnum}, makes
  it easier for future updates by linking to variables.

-------------------------------------------------------------------
Tue Feb 17 09:55:00 CET 2009 - vuntz@novell.com

- Review changes.

-------------------------------------------------------------------
Tue Feb 17 09:49:12 CET 2009 - dominique-obs@leuenberger.net

- Have the plugin sub-packages follow the shlib name. The plugins
  are depending on a specific version of the lib and should be
  installable in parallel together with multiple libs.
  The plugins live in a versioned directory, so no conflicts can
  happen.

-------------------------------------------------------------------
Mon Feb 16 16:11:13 CET 2009 - ro@suse.de

- added baselibs.conf
  (libproxy0-32bit needed by libsoup-2_4-1-32bit) 

-------------------------------------------------------------------
Fri Feb  6 01:40:56 CET 2009 - vuntz@novell.com

- Add missing Requires on libproxy0 for the subpackages.

-------------------------------------------------------------------
Tue Feb  3 11:58:45 EST 2009 - hfiguiere@suse.de

- Initial packaging.
openSUSE Build Service is sponsored by