File pcsc-asedriveiiie-usb.spec of Package pcsc-asedriveiiie-usb

#
# spec file for package pcsc-asedriveiiie-usb (Version 3.5)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           pcsc-asedriveiiie-usb
%define _name asedriveiiie-usb
Summary:        ASEDrive IIIe USB Smart Card Reader Driver
Version:        3.5
Release:        121
License:        BSD 3-Clause
Group:          Productivity/Security
Url:            http://www.asedrive.com/downloads
Source:         %{_name}-%{version}.tar.bz2
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  libusb-devel pcsc-lite-devel pkg-config
Requires:       pcsc-lite
Supplements:    modalias(usb:v0DC3p0802d*dc*dsc*dp*ic*isc*ip*)
Supplements:    modalias(usb:v0DC3p1104d*dc*dsc*dp*ic*isc*ip*)
%define ifddir %(pkg-config libpcsclite --variable=usbdropdir)

%description
This package contains a driver for the ASEDrive IIIe USB smart card
reader.

This driver is meant to be used with the PCSC-Lite daemon from the
pcsc-lite package.



Authors:
--------
    Athena Smartcard Solutions

%prep
%setup -q -n %{_name}-%{version}

%build
%configure
make %{?jobs:-j%jobs} CC="%__cc" LD="%__ld" CPP="%__cpp" CXX="%__cxx"

%install
%makeinstall

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc ChangeLog LICENSE README
%{ifddir}/ifd-ASEDriveIIIe-USB.bundle

%changelog
* Wed Apr 08 2009 sbrabec@suse.cz
- Added USB modalias supplements.
- Require pcsc-lite.
* Wed Aug 01 2007 sbrabec@suse.cz
- New SuSE package, version 3.5 (FATE#301086).