File xfce4-dict-0.6.0-use-correct-xfcepanelplugin-instance.patch of Package xfce4-dict

From 1b9641f8a6a81e0a0c054c0ec46d760691d7cf2e Mon Sep 17 00:00:00 2001
From: Enrico Tröger <enrico.troeger@uvena.de>
Date: Sun, 05 Sep 2010 17:12:24 +0000
Subject: Use the correct XfcePanelPlugin instance when opening the preferences dialog to prevent crashes

---
diff --git a/panel-plugin/xfce4-dict-plugin.c b/panel-plugin/xfce4-dict-plugin.c
index 65eaa1b..6047db8 100644
--- a/panel-plugin/xfce4-dict-plugin.c
+++ b/panel-plugin/xfce4-dict-plugin.c
@@ -302,9 +302,10 @@ static void dict_plugin_properties_dialog_response(GtkWidget *dlg, gint response
 }
 
 
-static void dict_plugin_properties_dialog(XfcePanelPlugin *plugin, DictPanelData *dpd)
+static void dict_plugin_properties_dialog(GtkWidget *widget, DictPanelData *dpd)
 {
 	GtkWidget *dlg;
+	XfcePanelPlugin *plugin = dpd->plugin;
 
 	xfce_panel_plugin_block_menu(plugin);
 
--
cgit v0.8.3.4