File xfce4-panel.spec of Package xfce4-panel

#
# spec file for package xfce4-panel
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           xfce4-panel
Version:        4.8.1
Release:        5.<RELEASE3>
License:        GPLv2+ and LGPLv2.1+
Summary:        Panel for the Xfce Desktop Environment
Url:            http://www.xfce.org/projects/xfce4-panel/
Group:          System/GUI/XFCE
Source:         %{name}-%{version}.tar.bz2
Source1:        %{name}-rpmlintrc
# PATCH-FIX-UPSTREAM xfce4-panel-4.8.1-fix-install-documentation.patch bxo#7274 gber@opensuse.org -- Fixes a bug in the build system that prevents the installation of the HTML documentation
Patch0:         xfce4-panel-4.8.1-fix-install-documentation.patch
BuildRequires:  gtk-doc
BuildRequires:  intltool
BuildRequires:  perl-XML-Parser
BuildRequires:  pkgconfig(cairo)
BuildRequires:  pkgconfig(dbus-1)
BuildRequires:  pkgconfig(exo-1)
BuildRequires:  pkgconfig(garcon-1)
BuildRequires:  pkgconfig(gtk+-2.0)
BuildRequires:  pkgconfig(libstartup-notification-1.0)
BuildRequires:  pkgconfig(libwnck-1.0)
BuildRequires:  pkgconfig(libxfce4ui-1)
BuildRequires:  pkgconfig(libxfce4util-1.0)
BuildRequires:  pkgconfig(libxfcegui4-1.0)
BuildRequires:  pkgconfig(libxml-2.0)
BuildRequires:  update-desktop-files
BuildRequires:  xfce4-dev-tools
Requires:       %{name}-branding >= %{version}
Provides:       xfce4-panel-plugins = %{version}
Obsoletes:      xfce4-panel-plugins < %{version}
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
xfce4-panel is the panel for the Xfce desktop environment.

%package        devel
License:        GPLv2+ and LGPLv2.1+
Summary:        Development Files for xfce4-panel
Group:          Development/Libraries/C and C++
Requires:       %{name} = %{version}
Requires:       pkgconfig(cairo)
Requires:       pkgconfig(exo-1)
Requires:       pkgconfig(gtk+-2.0)
Requires:       pkgconfig(libstartup-notification-1.0)
Requires:       pkgconfig(libwnck-1.0)
Requires:       pkgconfig(libxfce4util-1.0)
Requires:       pkgconfig(libxfcegui4-1.0)

%description devel
The xfce4-panel-devel package contains development files needed to to develop
panel plugins.

%package -n libxfce4panel-1_0-3
License:        GPLv2+ and LGPLv2.1+
Summary:        Xfce Panel Library
Group:          System/Libraries

%description -n libxfce4panel-1_0-3
xfce4-panel is the panel for the Xfce desktop environment.

This package contains the xfce4-panel main library.

%package branding-upstream
License:        GPLv2+
Summary:        Upstream branding for xfce4-panel
Group:          System/GUI/XFCE
Supplements:    packageand(%{name}:branding-upstream)
Provides:       %{name}-branding = %{version}
Conflicts:      otherproviders(%{name}-branding)
#BRAND: Provide default panel configuration in /etc/xdg/xfce4/panel/default.xml
%if 0%{?suse_version} >= 1120
BuildArch:      noarch
%endif

%description branding-upstream
xfce4-panel is the panel for the XFce desktop environment.

This package contains the upstream branding.

%prep
%setup -q
%patch0 -p1

%build
xdt-autogen
%configure \
    --disable-static \
    --enable-gtk-doc

make V=1 %{?_smp_mflags}

%install
%make_install
rm -f %{buildroot}%{_libdir}/*.la %{buildroot}%{_libdir}/xfce4/panel/plugins/*.la
mkdir -p %{buildroot}%{_datadir}/xfce4/panel-plugins
mkdir -p %{buildroot}%{_libdir}/xfce4
mkdir -p %{buildroot}%{_libdir}/xfce4/panel-plugins
mkdir -p %{buildroot}%{_libexecdir}/xfce4
mkdir -p %{buildroot}%{_libexecdir}/xfce4/panel-plugins
%suse_update_desktop_file panel-desktop-handler
%suse_update_desktop_file panel-preferences
rm -rf %{buildroot}%{_datadir}/locale/{ast,kk,tl_PH,ur_PK}
%find_lang %{name}

%clean
rm -rf %{buildroot}

%post -n libxfce4panel-1_0-3 -p /sbin/ldconfig

%postun -n libxfce4panel-1_0-3 -p /sbin/ldconfig

%if 0%{?suse_version} >= 1140

%post
%desktop_database_post
%icon_theme_cache_post

%postun
%desktop_database_postun
%icon_theme_cache_postun
%endif

%files -f %{name}.lang
%defattr(-,root,root)
%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS
%{_bindir}/xfce4-panel
%{_bindir}/xfce4-popup-applicationsmenu
%{_bindir}/xfce4-popup-directorymenu
%{_bindir}/xfce4-popup-windowmenu
%{_libdir}/xfce4/panel
%dir %{_datadir}/xfce4/panel-plugins
%{_datadir}/xfce4/panel
%{_datadir}/icons/hicolor/*/apps/xfce4-panel*
%{_datadir}/applications/panel-*.desktop
%{_datadir}/doc/xfce4-panel
%dir %{_libdir}/xfce4
%dir %{_libdir}/xfce4/panel-plugins
%if "%{_libdir}" != "%{_libexecdir}"
%dir %{_libexecdir}/xfce4
%dir %{_libexecdir}/xfce4/panel-plugins
%endif
%dir %{_sysconfdir}/xdg/xfce4/panel

%files -n libxfce4panel-1_0-3
%defattr(-,root,root)
%{_libdir}/libxfce4panel-1.0.so.*

%files devel
%defattr(-,root,root)
%{_includedir}/xfce4/libxfce4panel-1.0
%{_libdir}/libxfce4panel-1.0.so
%{_libdir}/pkgconfig/libxfce4panel-1.0.pc
%{_datadir}/gtk-doc/html/libxfce4panel-1.0

%files branding-upstream
%defattr(-,root,root)
%config %{_sysconfdir}/xdg/xfce4/panel/default.xml

%changelog