File baselibs.conf of Package Mesa

Mesa
	# Include this special README file so dummy Mesa-<targettype> gets
        # build and other arch packages can supplement it.
	+/usr/share/doc/packages/Mesa/README.package.*
	# Must require the base Mesa package to get /etc/drirc configuration file.
	requires "Mesa = <version>"
	obsoletes "XFree86-Mesa-<targettype> xorg-x11-Mesa-<targettype>"
	provides  "XFree86-Mesa-<targettype> xorg-x11-Mesa-<targettype>"
	provides "Mesa-libIndirectGL1-<targettype> = <version>"
	obsoletes "Mesa-libIndirectGL1-<targettype> < <version>"
	requires "libglvnd-<targettype> >= 0.1.0"
	requires "Mesa-dri-<targettype> = <version>"
	requires "Mesa-gallium-<targettype> = <version>"

Mesa-devel
	#We need Mesa-<targettype>!, do not put requires -Mesa-<targettype>.
	requires "Mesa-<targettype> = <version>"
	requires "Mesa-libEGL-devel-<targettype> = <version>"
	requires "Mesa-libGL-devel-<targettype> = <version>"
	requires "Mesa-libGLESv1_CM-devel-<targettype> = <version>"
	requires "Mesa-libGLESv2-devel-<targettype> = <version>"
	requires "Mesa-libIndirectGL-devel-<targettype> = <version>"
	requires "Mesa-libglapi-devel-<targettype> = <version>"
	requires "libOSMesa-devel-<targettype> = <version>"
	requires "libgbm-devel-<targettype> = <version>"
	requires "libglvnd-devel-<targettype> >= 0.1.0"
	obsoletes "XFree86-Mesa-devel-<targettype> xorg-x11-Mesa-devel-<targettype>"
	provides  "XFree86-Mesa-devel-<targettype> xorg-x11-Mesa-devel-<targettype>"
	obsoletes "Mesa-libIndirectGL-devel-<targettype> < <version>"
	provides "Mesa-libIndirectGL-devel-<targettype> = <version>"

Mesa-libEGL1
	requires "libglvnd-<targettype> >= 0.1.0"
Mesa-libEGL-devel
	requires "Mesa-libEGL1-<targettype> = <version>"
	requires "Mesa-KHR-devel-<targettype> = <version>"
	requires "libglvnd-devel-<targettype> >= 0.1.0"
Mesa-libGL1
	requires "Mesa-<targettype> = <version>"
	requires "libglvnd-<targettype> >= 0.1.0"
Mesa-libGL-devel
	requires "Mesa-libGL1-<targettype> = <version>"
	requires "Mesa-KHR-devel-<targettype> = <version>"
	requires "libglvnd-devel-<targettype> >= 0.1.0"
Mesa-libGLESv1_CM1
	requires "libglvnd-<targettype> >= 0.1.0"
Mesa-libGLESv1_CM-devel
	requires "Mesa-libEGL-devel-<targettype> = <version>"
	requires "Mesa-libGLESv1_CM1-<targettype> = <version>"
	requires "Mesa-KHR-devel-<targettype> = <version>"
	requires "libglvnd-devel-<targettype> >= 0.1.0"
Mesa-libGLESv2-2
	requires "libglvnd-<targettype> >= 0.1.0"
Mesa-libGLESv2-devel
	requires "Mesa-libEGL-devel-<targettype> = <version>"
	requires "Mesa-libGLESv2-2-<targettype> = <version>"
	requires "Mesa-KHR-devel-<targettype> = <version>"
	requires "libglvnd-devel-<targettype> >= 0.1.0"
Mesa-libGLESv3-devel
	requires "Mesa-libEGL-devel-<targettype> = <version>"
	requires "Mesa-KHR-devel-<targettype> = <version>"
libOSMesa8
	obsoletes "libOSMesa9-<targettype> < <version>"
	provides "libOSMesa9-<targettype> = <version>"
libOSMesa-devel
	requires "libOSMesa8-<targettype> = <version>"
libgbm1
libgbm-devel
	requires "libgbm1-<targettype> = <version>"
Mesa-libglapi0
Mesa-libglapi-devel
	requires "Mesa-libglapi0-<targettype> = <version>"
Mesa-libd3d
	provides "d3dadapter9.so.1"
Mesa-libd3d-devel
	requires "Mesa-libd3d-<targettype> = <version>"
libvulkan_intel
	targetarch aarch64 +/usr/share/vulkan/icd.d/intel_icd.*.json
	targetarch ppc64 +/usr/share/vulkan/icd.d/intel_icd.*.json
	targetarch ppc64le +/usr/share/vulkan/icd.d/intel_icd.*.json
	targetarch x86_64 +/usr/share/vulkan/icd.d/intel_icd.*.json
libvulkan_radeon
	targetarch aarch64 +/usr/share/vulkan/icd.d/radeon_icd.*.json
	targetarch ppc64 +/usr/share/vulkan/icd.d/radeon_icd.*.json
	targetarch ppc64le +/usr/share/vulkan/icd.d/radeon_icd.*.json
	targetarch x86_64 +/usr/share/vulkan/icd.d/radeon_icd.*.json
Mesa-libVulkan-devel
	targetarch aarch64 requires "libvulkan_intel-<targettype> = <version>"
	targetarch aarch64 requires "libvulkan_radeon-<targettype> = <version>"
	targetarch ppc64 requires "libvulkan_intel-<targettype> = <version>"
	targetarch ppc64 requires "libvulkan_radeon-<targettype> = <version>"
	targetarch ppc64le requires "libvulkan_intel-<targettype> = <version>"
	targetarch ppc64le requires "libvulkan_radeon-<targettype> = <version>"
	targetarch x86_64 requires "libvulkan_intel-<targettype> = <version>"
	targetarch x86_64 requires "libvulkan_radeon-<targettype> = <version>"
libXvMC_nouveau
libXvMC_r600
libvdpau_nouveau
libvdpau_r300
libvdpau_r600
libvdpau_radeonsi
Mesa-dri-vc4
Mesa-dri-nouveau
Mesa-dri
	supplements "Mesa-<targettype> = <version>"
Mesa-gallium
	supplements "Mesa-<targettype> = <version>"