File ffado-mixer.changes of Package ffado

-------------------------------------------------------------------
Fri May 29 15:12:31 UTC 2020 - Edgar Aichinger <edogawa@aon.at>

- update to release 2.4.3
- removed unneeded Patch (fixed upstream):
  ffado-mixer-fixbuild.patch

-------------------------------------------------------------------
Thu Jan  2 09:40:57 UTC 2020 - Bjørn Lie <bjorn.lie@gmail.com>

- Replace pkgconfig(libxml++-2.6) with pkgconfig(libxml++-3.0)
  BuildRequires.

-------------------------------------------------------------------
Mon Feb  4 14:29:04 UTC 2019 - davejplater@gmail.com

- Change Buildrequires: pkgconfig(dbus-python-3.6) back to the plain
  python3-dbus-python-devel package, pkgconfig is no longer provided.

-------------------------------------------------------------------
Fri Jan  4 10:15:07 UTC 2019 - davejplater@gmail.com

- Update to release 2.4.1
- Fix build with ffado-mixer-fixbuild.patch.
- Removed uneeded and incorporated patches:
  libffado-SConstruct-py3.patch, ffado-gcc6.patch and byteswap.patch
- Upstream changes:
  *Fix some python syntax which was not compatible with python3.
   These were missed during the preparation of FFADO 2.4.0.
  *Modify the SCons build system to allow for scons running under
   python3.
  *Merge distribution patches provided by package maintainers.
  *Address some difficulties experienced by package maintainers
   when compiling FFADO.
  *Improve the output of ffado-diag.

-------------------------------------------------------------------
Sun Oct 21 09:06:50 UTC 2018 - schwab@suse.de

- byteswap.patch: ensure byte swap macros are available for all components

-------------------------------------------------------------------
Thu Feb  8 10:19:36 UTC 2018 - davejplater@gmail.com

- Update to release 2.4.0 and fix build against glibc-2.27
  see boo#1079938.
- Removed patches fixed upstream:
  ffado_SConstruct_powerpc_update.patch and sigev.patch.
- Rebased libffado-SConstruct-py3.patch partially fixed upstream.
- Added ffado-nosys.patch for missing import sys in SConstruct.
- Rebased ffado-gcc6.patch, partially fixed upstream.
- Upstream changes:
  *Numerous build system and code improvements to support
   architectures such as MIPS, x32 and various PowerPC flavours.
  *A large number of fixes for newer versions of gcc
  (particularly versions 6 and 7).
  *Initial support for the optional TCO module of the
   RME Fireface-800.
  *Expanded ffado-mixer support for the Phase88 device.
  *Initial work to make ffado-mixer compatible with
   python3/pyqt5.
  *Start work towards compatibility with scons3.

-------------------------------------------------------------------
Fri Nov 24 05:55:39 UTC 2017 - davejplater@gmail.com

- Added conditional for libffado-SConstruct-py3.patch to only apply
  if scons built with python 3.

-------------------------------------------------------------------
Thu Nov 23 12:02:50 UTC 2017 - astieger@suse.com

- Fix building with python3 scons, add libffado-SConstruct-py3.patch

-------------------------------------------------------------------
Mon Jul 31 12:08:17 UTC 2017 - schwab@suse.de

- sigev.patch: add missing header to define SIGEV_THREAD

-------------------------------------------------------------------
Fri Mar 31 15:35:32 UTC 2017 - davejplater@gmail.com

- Update to 2.3.0
- Removed api documentation package, no longer builds.
- See ffado.changes for common changes, no mixer changes.

-------------------------------------------------------------------
Wed Mar  2 19:00:04 UTC 2016 - dimstar@opensuse.org

- Add --std=gnu++11 to COMPILE_FLAGS.

-------------------------------------------------------------------
Wed Mar  2 17:08:05 UTC 2016 - dimstar@opensuse.org

- Replace libxmll++-devel BuildRequires with
  pkgconfig(libxml++-2.6) in order to be ready for the 
  compatibility package introduction (libxml++ goes 3.0).

-------------------------------------------------------------------
Mon Feb  8 11:51:37 UTC 2016 - rguenther@suse.com

- Add ffado-gcc6.patch to move #include <math.h> outside of a namespace
  and to not declare errno as local variable.

-------------------------------------------------------------------
Sat Jul  4 13:59:04 UTC 2015 - bwiedemann@suse.com

- require python-qt4 at runtime (bnc#937060)

-------------------------------------------------------------------
Wed Mar 11 13:58:21 UTC 2015 - normand@linux.vnet.ibm.com

- SConstruct is_powerpc and is_64bit to support ppc64le
  with new ffado_SConstruct_powerpc_update.patch

-------------------------------------------------------------------
Sun Sep 21 14:08:29 UTC 2014 - davejplater@gmail.com

- Update to version 2.2.1, no mixer changes.

-------------------------------------------------------------------
Thu Sep 18 15:17:30 UTC 2014 - fcrozat@suse.com

- Drop subversion BuildRequires, not needed at all.

-------------------------------------------------------------------
Mon Dec 24 19:15:05 UTC 2012 - p.drouand@gmail.com

- Update to 2.1.0 version:
  * Significantly improved support for the new "juju" firewire stack 
    found in newer kernels
  * Support for JACK freewheeling mode and set-buffer-size operation
  * Lower CPU usage
  * udev rules included in FFADO to give user access to audio device files
  * More stable streaming
  * Fix crash when realtime system clock was set
  * Fix race conditions and invalid memory accesses on shutdown
  * Fixes for clean compilation on recent gcc versions (up to 4.7)
  * ffado-diag enhanced to aid debugging efforts
  * Many bugs fixed 
- Remove patchs merged on upstream release:
  * ffado-gcc47.patch
  * libffado-bswap.patch
- Do not use and include ChangeLog in the package because the svn repo is down
  and this file could not be update
- Remove useless conditional macros

-------------------------------------------------------------------
Wed Jun 27 14:26:34 UTC 2012 - dvaleev@suse.com

- fix ppc64 build

-------------------------------------------------------------------
Tue Mar 13 16:20:30 UTC 2012 - davejplater@gmail.com

- Changed build to noarch as suggested by rpmlint

-------------------------------------------------------------------
Thu Mar  1 16:12:51 UTC 2012 - davejplater@gmail.com

- Update to version 2.0.1.2040
- ffado-dbus-server added
- See ffado's changelog

-------------------------------------------------------------------
Tue Nov  2 20:36:45 UTC 2010 - coolo@novell.com

- move doc generation into 2nd spec file

-------------------------------------------------------------------
Tue Nov  2 15:31:51 UTC 2010 - davejplater@gmail.com

- Fix some rpmlint errors

-------------------------------------------------------------------
Mon Nov  1 10:07:50 UTC 2010 - coolo@novell.com

- remove qt dependency, splitted into ffado-mixer spec file

-------------------------------------------------------------------
Thu Sep 30 10:38:42 UTC 2010 - davejplater@gmail.com

- Update to version 2.0.1
- Upstream changes :-
  Make it work on the new firewire-stack.
  Of course some more fixes went into the package. But its mostly
  intended for distributors so they can finally deprecate/disable the
  old firewire stack in kernels.
  For more changelog and instructions please look back at the 2.0.0
  release announcement http://www.ffado.org/?q=release/2.0.0

-------------------------------------------------------------------
Wed Jun 16 06:03:13 UTC 2010 - davejplater@gmail.com

- Update to svn 1856. 
- Upstream changes : Make it easier for distributions to define
  their own additional built-flags.
  Numerous bug fixes, see ChangeLog for details.

-------------------------------------------------------------------
Fri Apr 30 08:18:48 UTC 2010 - davejplater@gmail.com

- Created package ffado version 2.0.0
openSUSE Build Service is sponsored by