File tell-the-truth-about-private-api.patch of Package libqt5-qtbase

Index: qtbase-everywhere-src-5.11.2/mkspecs/features/qt_module.prf
===================================================================
--- qtbase-everywhere-src-5.11.2.orig/mkspecs/features/qt_module.prf
+++ qtbase-everywhere-src-5.11.2/mkspecs/features/qt_module.prf
@@ -215,9 +215,9 @@ android: CONFIG += qt_android_deps no_li
     QMAKE_LFLAGS += $${QMAKE_LFLAGS_VERSION_SCRIPT}$$verscript
 
     internal_module {
-        verscript_content = "Qt_$${QT_MAJOR_VERSION}_PRIVATE_API { *; };"
+        verscript_content = "Qt_$${QT_MAJOR_VERSION}.$${QT_MINOR_VERSION}.$${QT_PATCH_VERSION}_PRIVATE_API { *; };"
     } else {
-        verscript_content = "Qt_$${QT_MAJOR_VERSION}_PRIVATE_API {" \
+        verscript_content = "Qt_$${QT_MAJOR_VERSION}.$${QT_MINOR_VERSION}.$${QT_PATCH_VERSION}_PRIVATE_API {" \
                             "    qt_private_api_tag*;"
 
         private_api_headers = $$SYNCQT.PRIVATE_HEADER_FILES $$SYNCQT.QPA_HEADER_FILES