File make-setup.py-script-to-not-require-setuptools-9.1.patch of Package salt

From b73d7f73bebcde2936a55245471fbcb383778b6d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pablo=20Su=C3=A1rez=20Hern=C3=A1ndez?=
 <psuarezhernandez@suse.com>
Date: Wed, 25 Mar 2020 13:09:52 +0000
Subject: [PATCH] Make setup.py script to not require setuptools > 9.1

---
 setup.py | 8 --------
 1 file changed, 8 deletions(-)

diff --git a/setup.py b/setup.py
index e852080e4b..033ccee8c3 100755
--- a/setup.py
+++ b/setup.py
@@ -727,14 +727,6 @@ class Install(install):
         install.finalize_options(self)
 
     def run(self):
-        if LooseVersion(setuptools.__version__) < LooseVersion('9.1'):
-            sys.stderr.write(
-                '\n\nInstalling Salt requires setuptools >= 9.1\n'
-                'Available setuptools version is {}\n\n'.format(setuptools.__version__)
-            )
-            sys.stderr.flush()
-            sys.exit(1)
-
         # Let's set the running_salt_install attribute so we can add
         # _version.py in the build command
         self.distribution.running_salt_install = True
-- 
2.16.4