File gutenprint.changes of Package gutenprint

-------------------------------------------------------------------
Sun Jul  5 19:12:17 UTC 2020 - Atri Bhattacharya <badshah400@gmail.com>

- Update to 5.2.15 final version:
  * The following printers have been added: Canon SELPHY CP1300.
  * The following printers have seen bugfixes:
    - Sony UP-CR10L
    - Sony UP-DR150
    - Sony UP-DR200
  * Miscellaneous fixes for Shinko S1245, Sony UP-CR10L, UP-DR150,
    and UP-DR200, and Kodak.

-------------------------------------------------------------------
Mon Mar 16 11:07:50 UTC 2020 - Tomáš Chvátal <tchvatal@suse.com>

- Fix build with no python2 available by pulling in python3-cups

-------------------------------------------------------------------
Fri Mar 29 10:03:46 CET 2019 - jsmeix@suse.de

- Version upgrade to 5.2.14pre15.1 which is the
  first pre-release of Gutenprint 5.2.15.
  Changes in this release (compared to 5.2.14):
  * The following Epson inkjet printer has been added:
    Epson Expression ET-2600 EcoTank ET
  * Miscellaneous fixes for DNP DS80DX, DNP DS820,
    and Mitsubishi P95D.
  For details see the NEWS file.

-------------------------------------------------------------------
Mon Apr 23 10:43:27 CEST 2018 - jsmeix@suse.de

- Version upgrade to 5.2.14:
  Additional changes in this release (compared to 5.2.13pre14.2):
  * Color quality of the PCL 5c driver is significantly improved.
  For details see the NEWS file.

-------------------------------------------------------------------
Thu Jan  4 11:37:13 CET 2018 - jsmeix@suse.de

- Version upgrade to 5.2.13pre14.2 which is the
  second pre-release of Gutenprint 5.2.14.
  Major changes in this release (compared to 5.2.13):
  * The PCL driver now supports color laser printers
    that use PCL 5c natively (as opposed to emulation).
    The support is considered to be preliminary at this time.
    Tons of PCL printers have been added with color support.
    Please report success or failure with PCL color laser printers
    using the Generic PCL Color drivers.
    Based on feedback from this pre-release, some or all of these
    printers may be removed from the list prior to 5.2.14 release.
  * Support for the Brother HL-2030 and HL-2035 has been removed
    because these printers do not support standard PCL.
  * A crash that affected certain dyesub printers when used with
    simplified PPD files has been fixed.
  * Enhanced support for some dye-sublimation printers.
  For details see the NEWS file.

-------------------------------------------------------------------
Thu Aug 31 16:32:54 CEST 2017 - jsmeix@suse.de

- Version upgrade to 5.2.13:
  Major changes in this release (compared to 5.2.12):
  * Correct mis-defined paper type that collided with standard
    A4 paper. This resulted in some Canon and PCL printers
    mishandling A4 paper.
  * Code optimizations in the dye-sublimation driver, resulting
    in a significant (2x-2.7x) boost in performance.
  * The Canon driver has improved printer firmware papersize
    detection when using automatic paper source (Autofeed).
  * Added support for two Epson inkjet printers.
  * Added experimental support for many Canon printers.
  * Removed support for iP100 (unsupported).
  * Added the Datamax-O'Neil H class series of printers.
  For details see the NEWS file.
- For SLE11 and SLE10 it must be built --without-gimp2
  because since Gutenprint 5.2.13 the gimp_pixels_to_units function
  is called in in src/gimp2/print.c and according to
  https://developer.gimp.org/api/2.0/libgimpbase/libgimpbase-gimpunit.html
  the gimp_pixels_to_units function is available since GIMP 2.8
  but SLE11 provides GIMP 2.6.2 and SLE10 provides GIMP 2.2.10.
  Accordingly the main package conficts with an installed
  gutenprint-gimpplugin <= 5.2.12 which intentionally should
  break an automated RPM package version upgrade
  to make the user aware that by installing Gutenprint 5.2.13
  there is no longer a gutenprint-gimpplugin for SLE11 or SLE10.

-------------------------------------------------------------------
Wed Aug  2 20:22:44 UTC 2017 - tchvatal@suse.com

- Drop default configure options that do not need to be overriden
- Drop again static libraries that are forbidden by default
- Switch check to proper check phase to allow --no-check override
- Pass disable-silent-rules to see all the compile options for
  brp parsers
- Switch to full URL for sources to have autodownload/tarball
  verification working
- Make sure the tests are forced on during configure phase
- Drop initial rm in install phase as we by default have empty dir
  courtesy of OBS
- Remove libtool archives as they are not supposed to be shipped
  on today packages

-------------------------------------------------------------------
Tue Mar 14 11:18:06 CET 2017 - jsmeix@suse.de

- Have libgutenprint.a and libgutenprintui2.a
  in the gutenprint-devel sub-packege.

-------------------------------------------------------------------
Wed Feb  8 13:04:05 CET 2017 - jsmeix@suse.de

- Version upgrade to 5.2.12:
  For major changes in this release (compared to 5.2.11)
  see the next entry dated "Tue Sep 20 15:09:34 CEST 2016".
  For details see the NEWS file.

-------------------------------------------------------------------
Tue Sep 20 15:09:34 CEST 2016 - jsmeix@suse.de

- Version upgrade to 5.2.11pre12.2 which is the
  second pre-release of Gutenprint 5.2.12.
  Major changes in this release (compared to 5.2.11):
  * The Ghostscript IJS driver and Foomatic data generator
    have been removed.  CUPS is ubiquitous on Linux/UNIX systems,
    and the Ghostscript IJS driver and Foomatic data are
    not needed with CUPS.
  * Added support for some dye sublimation printers.
  * Improved support (and bugfixes) for several dye sublimation
    printers.
  * Backend now reports media status via standard CUPS marker
    attributes some particular dye sublimation printers.
  * Added support for some Epson inkjet printers.
  * Added support for most Datamax-O'Neil DPL printers.
  For details see the NEWS file.

-------------------------------------------------------------------
Wed Feb  3 09:51:56 CET 2016 - jsmeix@suse.de

- Version upgrade to 5.2.11:
  * Added and enhanced support (and bugfixes) for many
    dye sublimation printers.
    Some dye sublimation printer models utilize a print engine
    that requires the host system to process the print data using
    unknown algorithms. Until these algorithms can be determined
    and re-implemented, these models are unsuitable for general
    use due to very poor output quality.
  * Added support for some Datamax-O'Neil PCL printers.
  * Added support for some Epson inkjet printers.
  * Added support for many Canon inkjet printers
    (mostly for PIXMA, PIXUS and MAXIFY models)
    and bugfixes (mainly for several BJC models).
    For most Canon inkjet printers the current
    support status is still EXPERIMENTAL, see
    http://gimp-print.sourceforge.net/p_Supported_Printers.php
  For details see the NEWS file.

-------------------------------------------------------------------
Wed Oct  7 13:13:31 CEST 2015 - jsmeix@suse.de

- Version upgrade to 5.2.10pre11.2 which is the
  second pre-release of Gutenprint 5.2.11.
  Major changes in this release (compared to 5.2.10pre11.1):
  * Support for a few additional Epson inkjet printers.
  For details see the NEWS file.
- define_GNU_SOURCE_makes_isblank_known.patch is obsolete
  because it is fixed in the sources.

-------------------------------------------------------------------
Thu Jul 16 10:45:14 CEST 2015 - jsmeix@suse.de

- Make it build again for SLE10 (cf. "SLE10" spec file comments).
- define_GNU_SOURCE_makes_isblank_known.patch adds
  "#define _GNU_SOURCE" in escputil/d4lib.c because isblank()
  needs _XOPEN_SOURCE >= 600 (see "man 3 isblank"
  and "man 7 feature_test_macros") otherwise compile fails
  with "error: implicit declaration of function 'isblank'".

-------------------------------------------------------------------
Mon Jun 29 11:10:43 CEST 2015 - jsmeix@suse.de

- Version upgrade to 5.2.10pre11.1 which is the
  first pre-release of Gutenprint 5.2.11.
  Major changes in this release:
  * Initial support for Datamax-O'Neil label printers:
    the Performance series and the Workstation printer.
  * Support for additional dye sublimation printers,
    and improvements, bug fixes for others.
  * Support for additional Canon inkjet printers,
    and bug fixes for others.
  For details see the NEWS file.

-------------------------------------------------------------------
Wed Mar 18 16:53:46 CET 2015 - jsmeix@suse.de

- Make it build for SLE12 with traditional CUPS 1.5.4 to ensure
  it works on SLE12 both with CUPS 1.7.5 and CUPS 1.5.4 because
  for SLE12 by default CUPS 1.7.5 is provided and alternatively
  CUPS 1.5.4 is provided in the "legacy" module, cf.
  https://www.suse.com/releasenotes/x86_64/SUSE-SLES/12/

-------------------------------------------------------------------
Tue Mar 17 09:21:54 CET 2015 - jsmeix@suse.de

- To make it build on SLE11 it BuildRequires cupsddk because
  on SLE11 with its CUPS 1.3.9 there is the separated package
  cupsddk (otherwise it is cups-ddk a sub-package of cups).

-------------------------------------------------------------------
Mon Jun  2 12:16:55 CEST 2014 - jsmeix@suse.de

- Version upgrade to 5.2.10:
  * Added a unified CUPS backend 'gutenprint52+usb' that requires
    libusb 1.0 (or newer) to support selected dye sublimation
    printers. Support for all Canon SELPHY CP- and ES- printers
    has been improved considerably through that CUPS backend.
  * Added duplex support for the EPSON WorkForce 630, 635,
    and 645, and NX635.
  * Many new printers supported in this release.
  * Very many new printers supported experimentally.
  For details see the NEWS file.
- For openSUSE 11.4 or newer BuildRequires libusb-1_0-devel
  to build the 'gutenprint52+usb' backend. When libusb-1.0 is
  not installed, the configure magic does not build that backend.
  The installed /usr/share/cups/usb/net.sf.gimp-print.usb-quirks
  needs a current CUPS version (that supports usb quirks).
  Older CUPS versions would ignore gutenprint's usb quirks
  which means that the generic CUPS backend 'usb' reports
  in particular the dye sublimation printers that do not work
  with it but require the special 'gutenprint52+usb' backend.

-------------------------------------------------------------------
Wed Jan 23 10:36:27 CET 2013 - jsmeix@suse.de

- Do no longer send SIGHUP to cupsd in RPM post install script
  (which would let the cupsd recognize new and updated PPD files
   see the entry dated "Fri Sep 24 10:45:28 CEST 2010" below)
  because SIGHUP to cupsd makes active print jobs fail
  (see bnc#637455 starting at comment#3).
- Added explicit "Requires: ghostscript" if suse_version > 1210
  because since openSUSE 12.2 cups only "Recommends: ghostscript"
  (to avoid a build dependency cycle) so that gutenprint needs
  an explicit "Requires: ghostscript" for the "cups" device in
  Ghostscript that is required by "rastertogutenprint" (compare
  the entry dated "Thu Apr 28 17:20:03 CEST 2011" below).

-------------------------------------------------------------------
Wed Sep 26 12:27:50 UTC 2012 - mmeister@suse.com

- Version upgrade to 5.2.9:
  Revert an inappropriate change to the internal library version
  number that was introduced in the 5.2.8 release.
- Version upgrade to 5.2.8:
  The Canon driver has been significantly overhauled. Its output
  and functionality may be significantly different from previous
  releases. Further work in future releases is expected.
  Several Canon PIXMA and SELPHY printers were removed, as they
  are not supported.
  Several Canon printers do not offer a grayscale printing mode.
  CD printing support for some Canon PIXMA printers was added.
  Added borderless functionality to most Canon printers
  (except S series and BJC series).
  Many new Canon printers are now EXPERIMENTAL supported.
  A few new Epson printers are now supported.
  For details see the NEWS file.
- escputil-send_nulls-void.patch is obsolete because its fixed
  in the sources.
- compile-fix.patch is obsolete because its fixed in the sources.

-------------------------------------------------------------------
Thu Oct 13 11:46:24 UTC 2011 - aj@suse.de

- compile-fix.patch adds missing includes.

-------------------------------------------------------------------
Fri May 27 16:27:18 CEST 2011 - vuntz@opensuse.org

- Add python-cups BuildRequires to have postscriptdriver() Provides
  for the drivers in gutenprint.

-------------------------------------------------------------------
Tue May 17 16:00:52 CEST 2011 - jsmeix@suse.de

- Upgraded to version 5.2.7:
  This release features support for many additional Canon inkjets,
  some Epson inkjets, and some dye sublimation printers,
  greatly upgraded support for many Epson Stylus Pro printers,
  and numerous bug fixes.
  For details see the NEWS file.
- escputil-send_nulls-void.patch makes send_nulls a void function
  because nowhere is a return value of send_nulls used
  to fix a "no-return-in-nonvoid-function escputil.c:683" error.

-------------------------------------------------------------------
Thu Apr 28 17:20:03 CEST 2011 - jsmeix@suse.de

- Removed the needless RPM requirement for pstoraster.
- Removed the duplicate RPM requirement for ghostscript-library
  because there is a RPM requirement for cups
  and cups requires ghostscript.

-------------------------------------------------------------------
Wed Dec 29 17:54:20 CET 2010 - jsmeix@suse.de

- Added missing directories for /usr/lib/gimp/2.0/plug-ins/*
  to the "gimpplugin" files section in the RPM spec file.
- Marked /usr/share/gutenprint/doc/* as "doc" in the RPM
  spec file (see Novell/openSUSE Bugzilla bnc#661350).

-------------------------------------------------------------------
Fri Sep 24 10:45:28 CEST 2010 - jsmeix@suse.de

- Removed gutenprint-5.2.6-make_A4_DefaultPageSize.patch
  because it is useless because the DefaultPageSize in the PPD
  templates in /usr/share/cups/model/ does not matter because
  the cupsd sets the DefaultPageSize for PPDs in /etc/cups/ppd/
  by default according to the locale that the cupsd runs in or
  according to a DefaultPaperSize entry in /etc/cups/cupsd.conf.
- Run cups-genppdupdate in the RPM post install script to update
  Gutenprint PPD files in /etc/cups/ppd/ if such PPDs exist
  (see Novell/openSUSE Bugzilla bnc#637455).

-------------------------------------------------------------------
Thu Sep  2 11:25:03 CEST 2010 - jsmeix@suse.de

- Disable the PPD generator /usr/lib/cups/driver/gutenprint.5.2
  to avoid duplicated PPDs because we provide ready-made PPDs
  in /usr/share/cups/model/gutenprint/... in the RPM package
  (see Novell/openSUSE Bugzilla bnc#514994 comment#9
   the section "Regarding CUPS PPD files").

-------------------------------------------------------------------
Wed Sep  1 16:12:40 CEST 2010 - jsmeix@suse.de

- gutenprint-5.2.6-make_A4_DefaultPageSize.patch
  moves the paper definition for "A4" to the top of the list
  to make A4 the DefaultPageSize in the Gutenprint PPDs.
- Upgraded to version 5.2.6:
  This release offers additional support for Epson Stylus Pro
  printers, along with some changes for other Epson printers
  and support for additional Canon inkjets and PCL laser
  printers over 5.2.5. For details see the NEWS file.
- Upgraded to version 5.2.5:
  This release offers several fixes, new features, and support
  for new printers over 5.2.4. For details see the NEWS file.

-------------------------------------------------------------------
Fri Aug 13 13:28:17 CEST 2010 - jsmeix@suse.de

- Split gutenprint from the cups-drivers package to have it as a
  stand-alone package (see Novell/openSUSE Bugzilla bnc#514994).
  The IJS driver /usr/bin/ijsgutenprint is no longer provided
  because it is not recommend if CUPS is used. Only the native
  CUPS driver is provided as recommend, see the README file.
openSUSE Build Service is sponsored by