File libstoragemgmt.changes of Package libstoragemgmt

-------------------------------------------------------------------
Mon Jun 22 12:09:05 UTC 2020 - Callum Farmer <callumjfarmer13@gmail.com>

- Fixes for %_libexecdir changing to /usr/libexec

-------------------------------------------------------------------
Fri May 22 08:58:44 UTC 2020 - Michael Vetter <mvetter@suse.com>

- Update to 1.8.4:
  * Bug fix: #414
  * Re-work configure to be better about self configuration
  * Updates to travis CI docker script
  * Use jsmn JSON parser, remove YAJL and nlohmann
  * Make some of the simulator disks much larger
  * Introduce cformat makefile target to re-format C/C++ code
    requires clang-format

-------------------------------------------------------------------
Tue Feb 18 10:09:41 UTC 2020 - Michael Vetter <mvetter@suse.com>

- Update to 1.8.3:
  * Fix volume-raid-create pool ID issue (#410)
  * Update: JSON library
  * Few other fixes

-------------------------------------------------------------------
Mon Dec 16 11:44:34 UTC 2019 - Michael Vetter <mvetter@suse.com>

- Update to 1.8.2:
  * Compile fixes for Alpine Linux (#403, #402, #401)
  * Don't orphan lsmd process when displaying help (#399)

-------------------------------------------------------------------
Mon May 27 08:52:10 UTC 2019 - mvetter@suse.com

- Update to 1.8.1:
  * Fix bug https://bugzilla.redhat.com/show_bug.cgi?id=1585169
- Changes from 1.8.0:
  Bug fixes:
  * Invalid vpd 0x83 value, #376
  * Fix duplicate files in debian packaging
  * Add simple test integration script
  * Unable to control some slot LEDs via SES #383
  * Numerous corrections for arcconf plugin
  * Correct deprecated python & perl usage
  Enhancements:
  * arcconf pool member info
  * arcconf volume raid info
  * arcconf volume LED (on/off)
  * arcconf volume enable
- Changes from 1.7.3:
  Bug fixes:
  * https://bugzilla.redhat.com/show_bug.cgi?id=1670077
  * https://bugzilla.redhat.com/show_bug.cgi?id=1667096
  * https://bugzilla.redhat.com/show_bug.cgi?id=1667992
- Changes from 1.7.2:
  Bug fixes:
  * https://bugzilla.redhat.com/show_bug.cgi?id=1572137
  * https://bugzilla.redhat.com/show_bug.cgi?id=1583741
  * https://bugzilla.redhat.com/show_bug.cgi?id=1585169
  * https://bugzilla.redhat.com/show_bug.cgi?id=1624398
  * https://bugzilla.redhat.com/show_bug.cgi?id=1596731
  * https://bugzilla.redhat.com/show_bug.cgi?id=1583763
  * https://bugzilla.redhat.com/show_bug.cgi?id=1583681
  * https://bugzilla.redhat.com/show_bug.cgi?id=1584243
  * https://bugzilla.redhat.com/show_bug.cgi?id=1564151
  * https://bugzilla.redhat.com/show_bug.cgi?id=1583768
  * https://bugzilla.redhat.com/show_bug.cgi?id=1583765
  * https://bugzilla.redhat.com/show_bug.cgi?id=1591282
  * https://bugzilla.redhat.com/show_bug.cgi?id=1591282
  * https://bugzilla.redhat.com/show_bug.cgi?id=1571894
  * https://bugzilla.redhat.com/show_bug.cgi?id=1657407
- Changes from 1.7.1:
  * Fix up/add documentation and correct packaging lint errors

-------------------------------------------------------------------
Fri Nov  2 11:14:28 UTC 2018 - Jan Engelhardt <jengelh@inai.de>

- Fix RPM groups.

-------------------------------------------------------------------
Thu Oct 25 02:40:17 UTC 2018 - nwang@suse.com

- Update to new upstream release 1.7.0
  * Replace yajl with nlohmann/json for JSON handling.
  * Fix the file path of lsmd.conf manpage.
  * HPSA plugin: Support ssacli version 3.25+.
  * scan-scsi-target: Fix compiling on gcc 8.2.
  * Fix lsmcli on python 3.7.
  * Handle 'Warning:' message in hpsa plugin
  * SmartArray plugin: Remove the pyudev codes.
  * lsmd: Fix crash when plugin named as _lsmplugin.
  * Fix GCC 8 compiling warnings.
  * MegaRAID plugin: Fix cache information query.
  * Fix regression on SMI-S plugin.
- Remove patch compat-gcc8.patch: in upstream
- Polish the spec file by spec-cleaner

-------------------------------------------------------------------
Thu May  3 13:12:28 UTC 2018 - dimstar@opensuse.org

- Explicitly call autoreconf: patch compat-gcc8.patch touches the
  build system and thus we need to rebootstrap.

-------------------------------------------------------------------
Tue Mar 27 08:27:39 UTC 2018 - nwang@suse.com

- bsc#1084630, compat to gcc8
  Enlarge the err_msg to avoid [-Werror=format-truncation=]
  '-Wno-cast-function-type' for python c building
  Add automake to build requires in spec file.
- Add patch compat-gcc8.patch

-------------------------------------------------------------------
Tue Dec 19 05:43:41 UTC 2017 - nwang@suse.com

- bsc#1073088, change requirements to python3 for SLE15. 

-------------------------------------------------------------------
Thu Oct 26 08:57:13 UTC 2017 - mpluskal@suse.com

- Update to version 1.6.0:
  * New error number for deleting volume/fs with child dependency:
    + C: LSM_ERR_HAS_CHILD_DEPENDENCY
    + Python: lsm.ErrorNumber.HAS_CHILD_DEPENDENCY
  * Fix incorrect SCSI VPD query for 0x89 and 0xb1.
  * Fix regression on using libstoragemgmt with pywbem 0.7.0.
  * Updates on manpage and help message of lsmcli.
- Changes for version 1.5.0:
  * New plugin -- LibstorageMgmt NFS server plugin(nfs://).
  * New plugin -- LibstorageMgmt Local Pseudo plugin(local://).
  * New plugin -- LibstorageMgmt Microsemi storage plugin(arcconf://).
  * Removed support of lmiwbem due to missing self-signed CA verification and inactive upstream of lmiwbem.
  * Support SES actions on kernel bsg module(old code was using sg kernel module).
  * Add manpages for every C API using kernel-doc.
  * New URI parameter ca_cert_file for ONTAP, SMI-S, targetd plugin.
  * Bug fixes:
    + Fix the ONTAP SSL connection.
    + Sim plugin: Fix sqlite3 transaction of fs_child_dependency_rm().
    + MegaRAID: Handle when both perccli and storcli are installed.
    + MegaRAID plugin: Support pool status for rebuild and check.
    + Fixed C++ code compile warnings.
  * Library adds:
    + Query health status of local disk:
    + lsm_local_disk_health_status_get()/lsm.LocalDisk.health_status_get()
- Drop no longer needed patches:
  * 0001-Fix-gcc-warning-on-non-x86-platform.patch
  * 0001-Simc-plugin-Fix-gcc-warning-on-fallthrough-switch.patch
  * 0002-C-library-Bug-fix-for-incorrect-use-of-sizeof.patch

-------------------------------------------------------------------
Thu Jun  1 06:22:27 UTC 2017 - nwang@suse.com

- To unify the package in SLE and Leap.
- bsc#931426, bsc#980651 and bsc#988547 also fixed in this package

-------------------------------------------------------------------
Thu May 18 09:43:43 UTC 2017 - mliska@suse.cz

- Add 0001-Simc-plugin-Fix-gcc-warning-on-fallthrough-switch.patch to
  fix build with GCC 7.

-------------------------------------------------------------------
Tue May 16 10:30:33 UTC 2017 - mpluskal@suse.com

- Sync patches with fedora:
  * 0002-C-library-Bug-fix-for-incorrect-use-of-sizeof.patch

-------------------------------------------------------------------
Tue Apr 25 07:27:25 UTC 2017 - alarrosa@suse.com

- Add 0001-Fix-gcc-warning-on-non-x86-platform.patch to fix build in
  ppc64le/s390x.

-------------------------------------------------------------------
Mon Apr 24 11:10:59 UTC 2017 - alarrosa@suse.com

- Remove dependency for python-M2Crypto which is no longer needed 
- Add python-six dependency

-------------------------------------------------------------------
Fri Mar 24 10:32:50 UTC 2017 - mpluskal@suse.com

- Update to version 1.4.0:
  * Add Python3 support.
  * Add support of lmiwbem.
  * Allow plugin test to be run concurrently.
  * Bug fixes:
    + Fix megaraid plugin for dell PERC.
    + Fix local disk rotation speed query on NVMe disk.
    + Fix lsmcli incorrect try-expect on local disk query.
    + Fix all the gcc compile warnings.
    + Fix the obsolete usage of AC_OUTPUT in configure.ac.
  * Library adds:
    + Query serial of local disk:
      lsm_local_disk_serial_num_get()/lsm.LocalDisk.serial_num_get()
    + Query LED status of local disk:
      lsm_local_disk_led_status_get()/lsm.LocalDisk.led_status_get()
    + Query link speed of local disk:
      lsm_local_disk_link_speed_get()/lsm.LocalDisk.link_speed_get()
- Changes for version 1.3.5:
  * Bug fixes:
    + Fix anon_uid/anon_gid handling.
    + Fix HPSA plugin on capabilities, system status, system mode.
    + Fix running lsmcli on python 2.6.
    + Fix missing vpd83 optional property in C library.
  * Enhancements:
    + Rewrite C simulator plugin to support state saving.

-------------------------------------------------------------------
Sun Nov 27 21:06:22 UTC 2016 - jengelh@inai.de

- Adjust rpm group categories to match what is used in other
  packages.
- Avoid suppressing error outputs in scriptlets. If it happens,
  we want to know about it.

-------------------------------------------------------------------
Tue Aug  9 08:18:33 UTC 2016 - mpluskal@suse.com

- Update to version 1.3.4:
  * hpsa: Update cacheless variable

-------------------------------------------------------------------
Mon Aug  1 01:54:55 UTC 2016 - fge@redhat.com

- Update to version 1.3.3:
  * Bug fix release, check this link for detail:
    https://github.com/libstorage/libstoragemgmt/releases/tag/1.3.3

-------------------------------------------------------------------
Tue Jul 19 05:55:35 UTC 2016 - nwang@suse.com

- bsc#988547, add require of python-libstoragemgmt-clibs. 

-------------------------------------------------------------------
Thu May 19 03:08:21 UTC 2016 - fge@redhat.com
- Update to version 1.3.2 (boo#980653):
  * Fix local disk VPD83 searching in fakeroot(change root) when
    '/dev' is not mounted.
  * New configure option to skip memory leak check test.
  * Fix regression introduced by 1.3.1 when run as non-root user.
  * New configure option '--without-test' to skip all test cases and
    their build requirements.

-------------------------------------------------------------------
Fri May 13 13:59:32 UTC 2016 - fge@redhat.com

- Upgrade to version 1.3.1 (boo#980041):
  * Fix local disk querying in fakeroot(change root) when '/dev' 
    is not mounted.

-------------------------------------------------------------------
Fri May 13 13:52:43 UTC 2016 - fge@redhat.com

- Upgrade to version 1.3.0:
  * Change the raid card cache split (%read, %write)
  * Retrieve/update cache information of both the card and 
    physical disks (enable/disable caching etc.)
  * Turn on/off identify and fault LEDs
  * Retrieve information on batteries
  * Retrieve a physical disk RPM, link type and location string for 
    a disk
  * Retrieve the vpd 0x83 for directly attached disk(s)
  * Given a vpd 0x83 return list of local disk paths
  * Given a disk path return the vpd 0x83 value
  * Retrieve list of local disks
- Removed package:
  * libstoragemgmt-rest -- droped by upstream.

-------------------------------------------------------------------
Sat Feb  6 11:20:21 UTC 2016 - mpluskal@suse.com

- Make building more verbose
- Small spec file cleanups

-------------------------------------------------------------------
Wed Jun 24 08:05:23 UTC 2015 - fge@redhat.com

- Upgrade to version 1.2.3:
    * Bug fixes:
        * lsmcli bash completion: Fix syntax error.
        * lsmcli bash completion: Fix volume-delete.
        * lsmcli bash completion: Add missing completions.
        * Fix: selinux dac_override
        * Manpage: Update hpsa and megaraid plugin manpages.
        * HP Smart Array Plugin: Fix pool querying on P410i.
        * MegaRAID Plugin: Fix bug when no volume configured.

-------------------------------------------------------------------
Thu Jun 18 08:36:57 UTC 2015 - mpluskal@suse.com

- Cleanup changelog formatting
- Update dependencies

-------------------------------------------------------------------
Wed Jun 17 07:09:55 UTC 2015 - fge@redhat.com
- Upgrade to version 1.2.1.
- New sub-pacakges:
    * libstoragemgmt-megaraid-plugin
        New plugin in 1.2.0 release.
    * libstoragemgmt-hpsa-plugin
        New plugin in 1.2.0 release.
    * libstoragemgmt-udev
        The udev file has nothing to do with the libraray.
        It just scan the SCSI target when got 
        REPORTED_LUNS_DATA_HAS_CHANGED in udev.
- New rpmbuild switch: '--without test'
    Use to skip 'make check' test to save debug time.
- Fix incorrect post scripts for plugin packages.
    User case: 
      The libstoragemgmt daemon need to be restarted on new plugin 
      install or plugin uninstall, so that the daemon could create 
      new or stop existing plugin connection. 
    But old macros:
    * The %service_del_postun only try-restart daemon on upgrade 
      which is not required here. 
    * The %service_del_postun only 'daemon-reload' on uninstall 
      which is not required here. 
    * The %service_add_post does not restart daemon.
    So we have to use hardcoded systemd commands.
- Add bash-completion script for lsmcli.
- Use systemd-tmpfiles to create socket file in /run folder.
- Add %ghost ownership for socket file and folder in /run folder.

-------------------------------------------------------------------
Thu May 14 06:04:42 UTC 2015 - nwang@suse.com

- Add conditions for libyajl and macro tmpfiles_create to
  support build against SLE12.

-------------------------------------------------------------------
Thu Apr  9 09:00:24 UTC 2015 - mpluskal@suse.com

- Rename python package to match python packaging guidelines

-------------------------------------------------------------------
Wed Apr  8 14:24:08 UTC 2015 - mpluskal@suse.com

- Disable checks as they seem to fail on OBS

-------------------------------------------------------------------
Wed Apr  8 14:19:39 UTC 2015 - mpluskal@suse.com

- Use pkgconfig() dependencies
- Enable checks

-------------------------------------------------------------------
Mon Mar 16 16:27:48 UTC 2015 - mpluskal@suse.com

- More cleanups

-------------------------------------------------------------------
Fri Mar 13 15:14:18 UTC 2015 - mpluskal@suse.com

- Cleanup package

-------------------------------------------------------------------
Thu Dec 11 03:13:02 UTC 2014 - nwang@suse.com

- Initial package version 1.1.0 for Fate#314409.