File lua-lgi.changes of Package lua-lgi

-------------------------------------------------------------------
Wed Apr  4 12:06:12 UTC 2018 - sor.alexei@meowr.ru

- Update to version 0.9.2:
  * Fix assorted crashes in closure callback invocation code.
  * Fix a double-free bug caused by incorrect annotation of
    Gio.DBusProxy.get_interface_info.
  * Fix marshaling of arrays of pointers.
  * Make objects unusable in __gc metamethod.
  * Work around an API break in GLib 2.54.
  * Use structured GLib logging when available.
  * Add Gio.Async support also for static methods and global
    functions.
  * A better error message when Gtk.init fails.
  * Add support for Travis.
  * Do not hardcode the pkg-config executable.
  * Fix URI in GStreamer sample.
  * Fix flags for D-Bus samples.

-------------------------------------------------------------------
Mon Oct 30 14:45:32 UTC 2017 - jmatejek@suse.com

- do not build for Lua 5.2

-------------------------------------------------------------------
Mon Aug  7 11:18:02 UTC 2017 - jengelh@inai.de

- RPM group corrections

-------------------------------------------------------------------
Thu Jul 13 15:18:14 UTC 2017 - tchvatal@suse.com

- Switch to mutlibuild in order to compile all flavors as needed

-------------------------------------------------------------------
Sat May 28 15:43:12 UTC 2016 - sor.alexei@meowr.ru

- Update to version 0.9.1:
  * Marshal NULL strings as nil instead of empty strings.
    This allows use of e.g. DataInputStream:read_line() APIs.
  * Add support for arrays with lengths as struct fields.
  * Allow GLib.Variant construction for lightuserdata.
  * Fix gtop binding (certain structs could not be imported).
  * Adapt to new set of annotations in newer GLib.
  * Assorted Lua5.3 fixes, lgi is now fully Lua5.3 compatible.
  * Fix binding of Gdk.Rectangle from newer Gdk.

-------------------------------------------------------------------
Wed Sep  2 08:56:31 UTC 2015 - dimstar@opensuse.org

- Only depend on Lua(API) in Tumbleweed: openSUSE 13.2, Leap and
  SLE12 do not yet provide this symbol.

-------------------------------------------------------------------
Thu Jul 30 11:43:11 UTC 2015 - dimstar@opensuse.org

- Depend on Lua(API) = %{%lua_version}. Note: lua_version is only
  major.minor of lua (e.g 5.2, 5.3[...]). This is needed as the
  files are installed in /usr/share/lua/5.2 when built against
  lua 5.2.

-------------------------------------------------------------------
Wed Apr 29 09:21:46 UTC 2015 - sor.alexei@meowr.ru

- Update to 0.9.0:
  * Allow defining new properties on custom GObject subclasses
    implemented using lgi.
  * Improve compatibility with locales (turkish).
  * Fix GPtrArray handling.
  * Improve behavior when running in assorted multiple-embedded and
    concurrent scenarios.

-------------------------------------------------------------------
Fri Aug 15 13:05:56 UTC 2014 - freyes@suse.com

- new upstream package; version 0.8.0

-------------------------------------------------------------------
Tue Jan  8 18:48:57 UTC 2013 - adam@mizerski.pl

- new package; version 0.6.2