File 0001-SLE15-SP3-compatibility-patch-for-kni.patch of Package dpdk

From 430a4b50f2f7e5f21c7c2f81849588c575018501 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jaime=20Caama=C3=B1o=20Ruiz?= <jcaamano@suse.com>
Date: Mon, 21 Sep 2020 14:50:13 +0200
Subject: [PATCH] SLE15 SP3 compatibility patch for kni

Updated 2021-05-14

diff -Nur dpdk-stable-19.11.8/kernel/linux/kni/compat.h new/kernel/linux/kni/compat.h
--- dpdk-stable-19.11.8/kernel/linux/kni/compat.h	2021-04-16 10:13:47.000000000 +0200
+++ new/kernel/linux/kni/compat.h	2021-05-14 14:19:13.576601634 +0200
@@ -14,7 +14,10 @@
 #define SLE_VERSION(a, b, c) KERNEL_VERSION(a, b, c)
 #endif
 #ifdef CONFIG_SUSE_KERNEL
-#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 4, 57))
+#if (defined(CONFIG_SUSE_VERSION) && CONFIG_SUSE_VERSION == 15 && \
+     defined(CONFIG_SUSE_PATCHLEVEL) && CONFIG_SUSE_PATCHLEVEL == 3)
+#define SLE_VERSION_CODE SLE_VERSION(15, 3, 0)
+#elif (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 4, 57))
 /* SLES12SP3 is at least 4.4.57+ based */
 #define SLE_VERSION_CODE SLE_VERSION(12, 3, 0)
 #elif (LINUX_VERSION_CODE >= KERNEL_VERSION(3, 12, 28))
@@ -132,6 +135,7 @@
 #endif
 
 #if KERNEL_VERSION(5, 6, 0) <= LINUX_VERSION_CODE || \
+	(SLE_VERSION_CODE && SLE_VERSION_CODE == SLE_VERSION(15, 3, 0)) || \
 	(defined(RHEL_RELEASE_CODE) && \
 	 RHEL_RELEASE_VERSION(8, 3) <= RHEL_RELEASE_CODE)
 #define HAVE_TX_TIMEOUT_TXQUEUE
openSUSE Build Service is sponsored by