File jedit.changes of Package jedit

-------------------------------------------------------------------
Fri Dec 22 15:35:13 UTC 2017 - fstrba@suse.com

- Added patch:
  * jedit-jdk10.patch
    + Fix building with jdk10
    + Do not use custom doclet APIs removed in jdk10

-------------------------------------------------------------------
Mon Sep 18 22:53:29 UTC 2017 - fstrba@suse.com

- Added patch:
  * jedit-encoding.patch
    + fix javadoc generation with jdk9

-------------------------------------------------------------------
Mon Jul  7 11:59:51 UTC 2014 - tchvatal@suse.com

- Version bump to 5.1.0:
  * Various updates all raound the place
  * Few api changes
  * http://www.jedit.org/CHANGES51.txt

-------------------------------------------------------------------
Mon Jul  7 11:54:06 UTC 2014 - tchvatal@suse.com

- Cleanup with spec-cleaner

-------------------------------------------------------------------
Mon Jul  7 11:50:59 UTC 2014 - tchvatal@suse.com

- Fix jedit build with new xml-common-apis

-------------------------------------------------------------------
Mon Sep 30 11:32:39 UTC 2013 - mvyskocil@suse.com

- fix a build, added missing commons-logging and junit 

-------------------------------------------------------------------
Thu Mar  7 00:04:49 UTC 2013 - admin@damienradtke.org

- updated build to use openSUSE-packaged dependencies

-------------------------------------------------------------------
Thu Jan 17 20:28:53 UTC 2013 - admin@damienradtke.org

- update to 5.0.0
- fixed java version incompatability with openSUSE 12.1
- many bug fixes, API changes, editing and UI updates
- added missing documentation
- full changelog here: www.jedit.org/CHANGES50.txt

-------------------------------------------------------------------
Wed Jun 27 14:31:29 UTC 2012 - mvyskocil@suse.cz

- update to 4.5.1 (bugfix release)
- build it from source and don't bundle everything in a tarball
- strip documentation build and install as it's extremly complicated and needs
  a lot of dependencies
- reworked launcher script

-------------------------------------------------------------------
Sun Jun 17 08:00:29 UTC 2012 - factory-maintainer@kulow.org

- adding deps.sh as source

-------------------------------------------------------------------
Wed Feb 29 23:13:28 UTC 2012 - admin@damienradtke.org

- Update to 4.5.0
  * Performance improvements.
  * Elastic tabstop option now available.
  * Lots of old deprecated API's were removed.
  * Choose color ordering for subpixel antialising.
  * Desktop system tray icon added.
  * It is now possible to change look & feel without restarting jEdit.
  * It is now possible to specify a FILE_NAME_GLOB for an edit mode
    based on the full path.
  * File System Browser can now open files in desktop, using filename
    associations to launch another program.
  * Plugin Manager enhancements, filter field, bugs fixed.

-------------------------------------------------------------------
Thu Jan 12 12:13:13 UTC 2012 - mvyskocil@suse.cz

- Update to 4.4.2 
  * a lot of bugfixes
  * `elsif compiler directive added to verilog edit mode (#3261277)
  (Matthieu Casanova)
  * Methods to manage the cursor if the TextArea
  * Introduction of a new ThreadUtilities class implementing a
    threadpool using Java 1.6 Concurrent API.
  * File System Browser dynamic menu support (#2938170 - François Rey)
  * BufferSet api rewritten. Now each editPane have its own bufferSet,
    does not share it with other editPanes. The bufferset scope is the
  * Status bar widget : it is now possible to use labels starting with letters
    in status bar. (Matthieu Casanova)
  * Update for Stata-edit mode (goebbe, # 3019042)
  * Added "using" keyword to haXe edit mode (patch #3081482 from Bad Sector,
    Matthieu Casanova)

-------------------------------------------------------------------
Sun May 22 10:57:40 UTC 2011 - idonmez@novell.com

- Don't hardcode docbook-xsl-stylesheet version 

-------------------------------------------------------------------
Wed Aug 11 08:09:15 UTC 2010 - mvyskocil@suse.cz

- Update to 4.3.2
  * a lot of bugfixes
  * improved indenting rules of Python edit mode (Björn "Vampire" Kautler)
  * New options to select the width and the background color of the selection area
    in the gutter (which is visible when line numbers are not shown).
  * New button in Hypersearch dockable panel to stop an hypersearch
    (patch #2842444) (encorejane)
  * New Macro - "Text/Compose Tag". (Gordon Hollenbeck # 2644277)
  * New (restored?) Actions: dumb "home" and "end": not as smart as smart
    home/end - stays on the same line always. (Alan Ezust)
  * Smarter Smart-end - uses syntax info to determine end of code (before
    start of comment), giving smart-end 4 states instead of the previous 3.
    (Gordon Hollenbeck #2646484).
  * and many more - see CHANGES.txt
- fix bnc#629375 - jedit does not work because of wrong version of bsh2
  * jedit needs patched version of bsh2, we used the vanilla sources from
    bsh2-src package, apply patches from Debian and use the modified version
    for build

-------------------------------------------------------------------
Tue Dec 15 13:16:07 UTC 2009 - mvyskocil@suse.cz

- fixed build with bsh-2.0b5
  * added jedit-4.2-bsh-2.0b5.patch

-------------------------------------------------------------------
Tue Mar 10 01:34:30 CET 2009 - ro@suse.de

- ignore some subshell return values to fix build for now 

-------------------------------------------------------------------
Thu Aug  7 15:25:44 CEST 2008 - mvyskocil@suse.cz

- fixed a name clash under java6
- fix some rpmlint warnings:
  - bzipped source tarball
  - fix duplicates using fdupes
  - add a provides jedit-rhmenu  antlr-jedit
- quiet option to setup macro

-------------------------------------------------------------------
Tue Jan 29 11:52:03 CET 2008 - mmaher@suse.de

- added TextTools Plugin (#276446)
	The TextTools plugin provides a set of plugin actions for 
    manipulating text in a buffer. 

-------------------------------------------------------------------
Fri Mar  9 11:05:33 CET 2007 - sbrabec@suse.cz

- Removed obsolete hicolor icon symlink (#248676).

-------------------------------------------------------------------
Mon Sep 25 17:02:18 CEST 2006 - skh@suse.de

- don't use icecream
- use source="1.4" and target="1.4" for build with java 1.5

-------------------------------------------------------------------
Wed Jan 25 21:46:46 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Thu Nov  3 16:22:30 CET 2005 - jsmeix@suse.de

- added Obsoletes for antlr-jedit because since jedit version 4.2
  /usr/share/jedit/modes/antlr.xml is included in jedit.

-------------------------------------------------------------------
Wed Oct 19 15:15:00 CEST 2005 - jsmeix@suse.de

- Current version 4.2 from JPackage.org

-------------------------------------------------------------------
Tue Aug  9 16:33:03 CEST 2005 - mls@suse.de

- removed compat from neededforbuild

-------------------------------------------------------------------
Tue Sep 14 01:29:50 CEST 2004 - ro@suse.de

- removed apache-ant from neededforbuild
- added to neededforbuild: ant,xml-commons-apis,jpackage-utils
  update-alternatives,xerces-j2

-------------------------------------------------------------------
Mon Mar 08 18:05:43 CET 2004 - pmladek@suse.cz

- updated to version 4.1

-------------------------------------------------------------------
Sat Jan 10 18:35:36 CET 2004 - adrian@suse.de

- build as user

-------------------------------------------------------------------
Fri Sep 19 16:05:12 CEST 2003 - pmladek@suse.cz

- renamed the link /usr/share/doc/packages/jedit/users-guide to
  fix the update from older distributions [#31307]

-------------------------------------------------------------------
Mon Jul 14 17:58:50 CEST 2003 - pmladek@suse.cz

- fixed neededforbuild due to the renamed package jakarta-ant -> apache-ant

-------------------------------------------------------------------
Fri Jan 31 17:48:46 CET 2003 - pmladek@suse.cz

- updated BufferTabs plugin to version 0.7.8
- fixed jedit wrapper to require at least a JRE version 1.3,
  but to do not require exactly this version

-------------------------------------------------------------------
Mon Nov 11 11:26:13 CET 2002 - ro@suse.de

- changed neededforbuild <jade_dsl> to <openjade>
- changed neededforbuild <sp> to <opensp>

-------------------------------------------------------------------
Mon Aug 05 14:23:30 CEST 2002 - pmladek@suse.cz

- updated to version 4.0.3 with many improvents and bug fixes
- updated InfoViewer plugin to version 1.1
- removed obsolete patch
- removed obsolete EditBus plugin (it is included in jedit now)
- fixed jedit launcher to select strict java version 1.3.x
- fixed neededforbuild

-------------------------------------------------------------------
Thu Feb  7 12:08:28 CET 2002 - pmladek@suse.cz

- updated plugins:
	* BufferTabs to version 0.7.6
	* InfoViewer to version 1.0
- removed the plugin QuickNotepad, it does not work
- only plugins with makefile.jmk are compiled from sources

-------------------------------------------------------------------
Fri Nov 30 15:08:32 CET 2001 - ro@suse.de

- changed neededforbuild <docbktls> to <docbook-toys>

-------------------------------------------------------------------
Tue Nov 20 10:58:41 CET 2001 - pmladek@suse.cz

- fixed silly messages on start

-------------------------------------------------------------------
Tue Oct 30 10:37:04 CET 2001 - pmladek@suse.cz

- package creadted, version 3.2.2
openSUSE Build Service is sponsored by