File pavucontrol.changes of Package pavucontrol

-------------------------------------------------------------------
Mon Jan 16 07:54:56 UTC 2017 - zaitor@opensuse.org

- Add pavucontrol-use-C++11-for-building.patch: Use C++11 for
  building, patch from upstream git.
- Following the above add libtool BuildRequires and pass autoreconf
  as the patch touches the buildsystem.
- Drop obsolete clean section and conditionals for obsolete
  versions of openSUSE.

-------------------------------------------------------------------
Tue Mar 24 15:35:09 UTC 2015 - dimstar@opensuse.org

- Update to version 3.0:
  + sinkwidget: add support for AAC pass-through.
  + added back support for gtkmm-2.4 builds.
  + pavucontrol: ellipsize labels to fix window resizing.
  + Don't crash if pa_stream_peek returns NULL.
  + Handle IO errors in icon setting code.
  + Reference the widget before returning it from ::create
    methods.
  + Do not instantiate cardwidget, devicewidget and rolewidget with
    a type of EventBox.
  + devicewidget, streamwidget: Show only one volume slider when
    channels are locked.
  + mainwindow: Catch Gdk::PixbufError.
  + Add a --maximize command line option.
  + Add horizontal scrollbars automatically.
  + mainwindow: Remember device visibility selections.
  + Build system fixes.
- Drop pavucontrol-2.0-reference-widget.patch: fixed upstream.

-------------------------------------------------------------------
Sun Oct 12 21:42:59 UTC 2014 - antoine.belvire@laposte.net

- Add pavucontrol-2.0-reference-widget.patch: Reference the widget
  before returning it from ::create methods (boo#900797).

-------------------------------------------------------------------
Wed Apr  3 17:32:05 UTC 2013 - dimstar@opensuse.org

- Update to version 2.0:
  + Fix theme under gtk3.
  + Support recent PulseAudio port feature additions
  + devicewidget: Move latency offset into an expander.
  + sinkwidget: Move format selection options to 'Advanced'
    expander.
  + Add a few known peak-detect stream clients to a source-output
    blacklist.

-------------------------------------------------------------------
Tue Sep 27 16:13:25 UTC 2011 - vuntz@opensuse.org

- Update to version 1.0:
  + Add GTK+3 support.
  + Add source output volume support.
  + Add digitial receiver UI.
  + Handle simple key events.
  + Bug fixes.
- Remove libglademm-devel BuildRequires: not needed anymore.
- Add pkgconfig(sigc++-2.0) BuildRequires: it was implicit before.
- Use favor_gtk2 to switch between gtk2 and gtk3 builds.
- Move to pkgconfig()-style BuildRequires:
  + Old ones: gtkmm2-devel, libcanberra-devel, libpulse-devel.
  + New ones: gtkmm-2.4/gtkmm-3.0,
    libcanberra-gtk/libcanberra-gtk3, libpulse,
    libpulse-mainloop-glib.
- Add xz BuildRequires because we can't build a package for a
  xz-compressed tarball without explicitly specifying that... See
  bnc#697467 for more details.

-------------------------------------------------------------------
Sat Feb 12 19:38:28 CET 2011 - vuntz@opensuse.org

- Call relevant macros in %post/%postun:
  + %desktop_database_post/postun because the package ships at
    least one desktop file.
- Pass %{?no_lang_C} to %find_lang so that english documentation
  can be packaged with the program, and not in the lang subpackage.
- Split lang subpackage.

-------------------------------------------------------------------
Sun Aug  8 07:14:06 CEST 2010 - vuntz@opensuse.org

- Add explicit gtkmm2-devel BuildRequires.
- Remove libcanberra-gtk and libsndfile-devel BuildRequires.

-------------------------------------------------------------------
Fri Dec  4 19:43:08 CET 2009 - vuntz@opensuse.org

- Update to version 0.9.10:
  + volume: Set the scale properly for delta changes via
    mouse/keyboard.
  + events: Hide output streams with a stream restore designator
    for the event widget.
  + Build fixes.
  + Updated translations.

-------------------------------------------------------------------
Sat Sep 19 00:34:36 UTC 2009 - sreeves@novell.com

- Update to version 0.9.9 
  + make sure that two card profiles with the same priority
    don't collide with each other
  + Add support for changing ports
  + Change 'Default' to 'Use as fallback'
  + Create the event role widget early so that it's always top of
    the list.
  + More changes in the UI to try and make things neater.
  + Hide the terminate button.
  + Do not disable the default button when it's set.
  + Don't use a hyperlink to display the device, just use a
    regular button.
  + Add support for changing ports.

-------------------------------------------------------------------
Thu May  7 03:25:42 CEST 2009 - vuntz@novell.com

- Review changes.
- Drop pavucontrol.png: there's no reason to install this icon. Was
  probably a left-over.
- Remove autoreconf call, which isn't needed.
- Pass --disable-lynx to configure, and remove lynx BuildRequires.
- Use parallel make.
- Do not add categories to the desktop file, since they're already
  there.
- Use standard commands for clean section.

-------------------------------------------------------------------
Thu Apr 30 19:53:25 CET 2009 - opensuse@sukimashita.com

- Update to version 0.9.8:
  + Support for changing card profiles.
  + Add Configuration tab.
  + Use the server provided icons.
  + Visualize base volume.
  + Configure steps for scales.
  + Don't show wait cursor forever if stream_restore extension is
    not available.
  + Reenable monitor streams.
  + Don't show failure msgbox twice.
  + Code reorganization.
  + Various cleanups.
  + Updated translations.
- Remove /usr/share/doc/pavucontrol since it's documentation that
  we already have elsewhere.

-------------------------------------------------------------------
Tue Sep 30 20:15:46 CEST 2008 - aj@suse.de

- Fix filelist.

-------------------------------------------------------------------
Tue Sep 16 13:15:18 CEST 2008 - rodrigo@suse.de

- Update to version 0.9.7 (fate#303943):
  + Show stream icons, and don't show our own monitor streams
  + Initilize client proplist properly
  + Make icons work
  + Fix Glade widget name case
  + Add a special track for controlling event sound volume
  + Update license headers for GPL 2.0+
  + Use system installed glade file
  + Add i18n
  + Beep when changing volume
  + Initialize maximum buffer length to automatic value
  + Updated translations
- Removed unneeded patch
- Added build dependency on libcanberra-devel|-gtk and intltool
- Added translations to package

-------------------------------------------------------------------
Wed Jul 30 12:41:34 CEST 2008 - rodrigo@suse.de

- Update to version 0.9.6:
  * Draw radio buttons instead of check boxes when moving streams
  * Fix crasher when connecting to a PA server that has no default
    sink/source configured

-------------------------------------------------------------------
Fri Jan 11 20:00:34 CET 2008 - rodrigo@suse.de

- Depend on libpulse-devel, not pulseaudio-devel 

-------------------------------------------------------------------
Tue Dec 11 21:52:14 CET 2007 - rodrigo@suse.de

- Updated to latest version (0.9.5):
  * Build fixes
  * Make stream title selectable (#140 in PulseAudio trac)
  * Add popup menu to sink/source to choose default device
  * Use pretty channel names
  * Add a combobox to the streams page, to filter app streams.
- Removed --disable-lynx from configure 

-------------------------------------------------------------------
Wed Jun 13 16:15:56 CEST 2007 - tiwai@suse.de

- initial version: 0.9.4
openSUSE Build Service is sponsored by