A new user interface for you! Read more...

File antlr.changes of Package antlr

-------------------------------------------------------------------
Fri Jan 12 11:53:47 UTC 2018 - tchvatal@suse.com

- Add condition about python2 module, the rewrite happened in antlr4
  for python3 support and it is completely different than the antlr2
  * The python module is not used by any package in TW bsc#1068226

-------------------------------------------------------------------
Thu Dec  7 14:35:50 UTC 2017 - dimstar@opensuse.org

- Fix build with RPM 4.14: a command that exits with error > 0
  aborts the build (and grep not finding a string is retval 1).

-------------------------------------------------------------------
Fri Nov  3 10:03:12 UTC 2017 - mpluskal@suse.com

- Explicitly require python2 [bsc#1068226, fate#323526]

-------------------------------------------------------------------
Fri Sep 29 13:23:59 UTC 2017 - fstrba@suse.com

- Require java-devel >= 1.6 to build, because of the source and
  target level

-------------------------------------------------------------------
Wed Sep  6 18:02:30 UTC 2017 - fstrba@suse.com

- fixes necessary to compile with Java 9
  * set javac source and target to 1.6

-------------------------------------------------------------------
Fri Jun  9 09:43:34 UTC 2017 - tchvatal@suse.com

- Drop the javadoc so we can be build with java bootstrapping reducing
  the cycle/failures

-------------------------------------------------------------------
Fri May 19 13:28:56 UTC 2017 - tchvatal@suse.com

- Reduce dependencies a bit

-------------------------------------------------------------------
Thu Dec  4 18:06:26 UTC 2014 - p.drouand@gmail.com

- Remove java-devel dependency; not needed anymore

-------------------------------------------------------------------
Fri Jul  4 11:17:42 UTC 2014 - tchvatal@suse.com

- Cleanup with spec-cleaner and fix the sle11 build properly.

-------------------------------------------------------------------
Wed Apr 30 13:58:14 UTC 2014 - darin@darins.net

- Set buildarch on SLE_11 or the python subpackage is packaged
  as noarch when they need be arch specific.
  http://lists.opensuse.org/opensuse-packaging/2014-04/msg00055.html

-------------------------------------------------------------------
Tue Apr 29 12:54:39 UTC 2014 - darin@darins.net

- supporess bytecode version check on SLE 
- fix perms for SLES

-------------------------------------------------------------------
Mon Sep  9 11:05:26 UTC 2013 - tchvatal@suse.com

- Move from jpackage-utils to javapackage-tools

-------------------------------------------------------------------
Thu Jul 11 13:04:14 UTC 2013 - dmueller@suse.com

- drop antlr-cshap, entirely unused and removes mono dependency 

-------------------------------------------------------------------
Wed Oct 31 10:23:55 UTC 2012 - mvyskocil@suse.com

- examples files are now 0644 to beeing able to fdupes them properly (bnc#784670) 

-------------------------------------------------------------------
Thu Jul 21 13:56:03 UTC 2011 - toddrme2178@gmail.com
  
- Modify descriptions (fix for RPMLINT warnings)
- Check for duplicate files (fix for RPMLINT warnings)

-------------------------------------------------------------------
Mon Aug 23 08:18:09 UTC 2010 - mvyskocil@suse.cz

- add missing java requires of antlr-java package 

-------------------------------------------------------------------
Thu Aug 19 12:43:18 UTC 2010 - mvyskocil@suse.cz

- enabled the python (python-antlr) and csharp (antlr-csharp) support
- moved jar files to new antlr-java package, which is required by main antlr
  one. This is to have jar files in noarch package
- do not use default make install, but install files manually with a
  compatibility links to /usr/share/antlr-2.7.7

-------------------------------------------------------------------
Wed Aug 18 18:32:11 UTC 2010 - tittiatcoke@opensuse.org

- Ensure that the development files are build too. The package is now a build
  requirement for the KDESDK4 package.
- Removed the structure to build just the native version.

-------------------------------------------------------------------
Mon Mar  3 11:02:35 CET 2008 - mvyskocil@suse.cz

- updated to 2.7.7
  * updated BaseAST.java to make the doWorkForAll method static. Same
    behaviour, except no ClassCastExceptions when sibling.getFirstChild()
    happens to return an AST that doesn't extend BaseAST.  Oliver Wong contributed
    the patch.
  * updated TokenStreamRewriteEngine.java to reflect bug fixes discovered
    in v3 counterpart.

-------------------------------------------------------------------
Wed Feb 20 16:34:59 CET 2008 - adrian@suse.de

- do not PreReq files to fix build env setup for other packages
- remove SL-9.1 traces

-------------------------------------------------------------------
Fri May  4 08:58:37 CEST 2007 - dbornkessel@suse.de

- added unzip to BuildRequires

-------------------------------------------------------------------
Sat Oct  7 11:54:36 CEST 2006 - dbornkessel@suse.de

- added check that checks whether deleted files ShowString.java and StreamConverter.java are really not in place 

-------------------------------------------------------------------
Thu Oct  5 17:27:00 CEST 2006 - dbornkessel@suse.de

- deleted
  antlr-2.7.6/examples/java/unicode.IDENTs/ShowString.java
  antlr-2.7.6/examples/java/unicode.IDENTs/StreamConverter.java
  from tar ball due to licensing issues (Bug #207621)


-------------------------------------------------------------------
Mon Sep 25 17:35:36 CEST 2006 - dbornkessel@suse.de

- fixes necessary to compile with Java 1.5.0
        - set source="1.4" and target="1.4" for ant "javac" tasks
        - set source="1.4" for ant "javadoc" tasks


-------------------------------------------------------------------
Wed Sep 20 10:35:11 CEST 2006 - dbornkessel@suse.de

- Provide: antlr-bootstrap
  Obsoletes: antlr-bootstrap
   

-------------------------------------------------------------------
Mon Sep 18 11:32:54 CEST 2006 - dbornkessel@suse.de

- update to 2.7.6 
  - added size, index methods to TokenStreamRewriteEngine.java
  - bug in syn preds for tree parsers.  Submitted by Ole Kniemeyer.
  - all Class.forName yanked out; uses thread context loader
  - option to prevent System.exit termination
  - added recover() method to lexers
  - fixed code gen bug for syn preds in tree parsers.  Thanks to Marc Horowitz.
  - BaseAST was not checking for null text in toString()
  - Scott added java line ouput in code gen
  - Prashant tweaked a few things for ANTLRStudio; a few new classes in ASdebug package
  - Give errors if the user attempts to set k>1 in a TreeWalker
  - Added missing Makefile.in for C++ heteroAST example and enabled it
    in configure.in
  - Many small C++ support code and codegen tweaks fixes to increase
    portability. (Compaq Tru64 UNIX V5.1, VC's)
  - Prevent '\' entering the bitset dump comments, might occur at end of
    line. Some compilers continue the comment to the next line (not sure
    if this is a compiler bug, should look it up)

-------------------------------------------------------------------
Wed Jan 25 21:45:44 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Tue Oct 25 14:01:10 CEST 2005 - jsmeix@suse.de

- removed sub-package antlr-jedit because since jedit version 4.2
  /usr/share/jedit/modes/antlr.xml is included in jedit.

-------------------------------------------------------------------
Wed Jul 27 14:11:08 CEST 2005 - jsmeix@suse.de

- Adjustments in the spec file.

-------------------------------------------------------------------
Tue Jul 19 17:35:03 CEST 2005 - jsmeix@suse.de

- Current version 2.7.4 from JPackage.org

-------------------------------------------------------------------
Wed Mar  2 16:14:37 CET 2005 - skh@suse.de

- added support for C++ output (#67164)

-------------------------------------------------------------------
Thu Sep 16 15:11:14 CEST 2004 - skh@suse.de

- Fix prerequires of javadoc subpackage
- conflict with pccts

-------------------------------------------------------------------
Thu Sep  2 15:58:43 CEST 2004 - skh@suse.de

- Initial package created with version 2.7.4 (JPackage 1.5)