A new user interface for you! Read more...

File boost-1.57.0-python-abi_letters.patch of Package boost

Index: boost_1_65_0/tools/build/src/tools/python.jam
===================================================================
--- boost_1_65_0.orig/tools/build/src/tools/python.jam
+++ boost_1_65_0/tools/build/src/tools/python.jam
@@ -99,7 +99,7 @@ py3-version = ;
 #   using python : 2.3 : /usr/local/bin/python ;
 #
 rule init ( version ? : cmd-or-prefix ? : includes * : libraries ?
-    : condition * : extension-suffix ? )
+    : condition * : extension-suffix ? : abi-letters ? )
 {
     project.push-current $(.project) ;
 
@@ -112,7 +112,7 @@ rule init ( version ? : cmd-or-prefix ?
         }
     }
 
-    configure $(version) : $(cmd-or-prefix) : $(includes) : $(libraries) : $(condition) : $(extension-suffix) ;
+    configure $(version) : $(cmd-or-prefix) : $(includes) : $(libraries) : $(condition) : $(extension-suffix) : $(abi-letters) ;
 
     project.pop-current ;
 }
@@ -659,7 +659,7 @@ local rule system-library-dependencies (
 
 # Declare a target to represent Python's library.
 #
-local rule declare-libpython-target ( version ? : requirements * )
+local rule declare-libpython-target ( version ? : requirements * : abi-letters ? )
 {
     # Compute the representation of Python version in the name of Python's
     # library file.
@@ -683,13 +683,13 @@ local rule declare-libpython-target ( ve
     }
 
     # Declare it.
-    lib python.lib : : <name>python$(lib-version) $(requirements) ;
+    lib python.lib : : <name>python$(lib-version)$(abi-letters) $(requirements) ;
 }
 
 
 # Implementation of init.
 local rule configure ( version ? : cmd-or-prefix ? : includes * : libraries ? :
-    condition * : extension-suffix ? )
+    condition * : extension-suffix ? : abi-letters ? )
 {
     local prefix ;
     local exec-prefix ;
@@ -705,6 +705,7 @@ local rule configure ( version ? : cmd-o
         extension-suffix ?= _d ;
     }
     extension-suffix ?= "" ;
+    abi-letters ?= "" ;
 
     local cmds-to-try ;
 
@@ -968,7 +969,7 @@ local rule configure ( version ? : cmd-o
     }
     else
     {
-        declare-libpython-target $(version) : $(target-requirements) ;
+        declare-libpython-target $(version) : $(target-requirements) : $(abi-letters) ;
 
         # This is an evil hack.  On, Windows, when Python is embedded, nothing
         # seems to set up sys.path to include Python's standard library