LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File 0001-build-Set-PKGDATADIR-to-gnome-color-manager.patch of Package gnome-color-manager (Project openSUSE:Leap:15.0:Update)

From 635ee49b83db46d2623826928cfa5202bdf1402a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Stefan=20Br=C3=BCns?= <stefan.bruens@rwth-aachen.de>
Date: Mon, 29 Jan 2018 20:45:01 +0100
Subject: [PATCH] build: Set PKGDATADIR to gnome-color-manager

It was set to gnome-software, which made any of the gcm-*
tools unable to find any of its data files.

https://bugzilla.gnome.org/show_bug.cgi?id=791158
---
 meson.build | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meson.build b/meson.build
index 3fd0963..d304ed1 100644
--- a/meson.build
+++ b/meson.build
@@ -85,7 +85,7 @@ prefixed_localedir = join_paths(get_option('prefix'), get_option('localedir'))
 prefixed_libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'))
 prefixed_mandir = join_paths(get_option('prefix'), get_option('mandir'))
 prefixed_datadir = join_paths(get_option('prefix'), get_option('datadir'))
-prefixed_pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'gnome-software')
+prefixed_pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'gnome-color-manager')
 
 libgio = dependency('gio-2.0', version : '>= 2.25.9')
 libgtk = dependency('gtk+-3.0', version : '>= 2.91.0')
-- 
2.16.1