File fix-build-with-cmake-3.5.patch of Package kfilemetadata5

From 1632a6972279d150aeb8de9e1cf0000ba1c3c380 Mon Sep 17 00:00:00 2001
From: Wolfgang Bauer <wbauer@tmo.at>
Date: Tue, 12 Feb 2019 10:31:01 +0100
Subject: Fix build with cmake 3.5

VERSION_GREATER_EQUAL requires cmake 3.7 or higher.
So use NOT VERSION_LESS instead, which is logically equivalent and also
works with older cmake versions.
Differential Revision: https://phabricator.kde.org/D18941
---
 src/extractors/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/extractors/CMakeLists.txt b/src/extractors/CMakeLists.txt
index 8795b48..6b4859c 100644
--- a/src/extractors/CMakeLists.txt
+++ b/src/extractors/CMakeLists.txt
@@ -36,7 +36,7 @@ if(LibExiv2_FOUND)
         KF5::FileMetaData
         LibExiv2::LibExiv2
     )
-    if(${LibExiv2_VERSION} VERSION_GREATER_EQUAL 0.26)
+    if(NOT ${LibExiv2_VERSION} VERSION_LESS 0.26)
         target_compile_definitions(kfilemetadata_exiv2extractor PRIVATE "-DHAVE_WEBP_SUPPORT")
     endif()
 
-- 
cgit v1.1