File libKF5NetworkManagerQt.changes of Package libKF5NetworkManagerQt

-------------------------------------------------------------------
Fri Feb 15 09:25:42 UTC 2019 - alarrosa@suse.com

- Downgrade the Qt version requirement to build with 5.9

-------------------------------------------------------------------
Sun Feb 10 22:03:20 UTC 2019 - lbeltrame@kde.org

- Update to 5.55.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
  * No code changes since 5.54.0

-------------------------------------------------------------------
Mon Jan 14 15:48:40 UTC 2019 - wbauer@tmo.at

- Refresh patches to fix build on Leap 42.3:
  * 0001-Revert-Add-IpTunnel-setting.patch
  * 0001-Revert-Add-missing-IPv6-options.patch
  * 0001-Revert-Add-missing-ipv4-setting-options.patch
  * 0001-Revert-Add-vxlan-setting.patch

-------------------------------------------------------------------
Mon Jan 14 06:08:54 UTC 2019 - lbeltrame@kde.org

- Update to 5.54.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
  * [proxysetting] Fix build with NM 1.4
  * Added DCB settings
  * A minor typo in ipv4 test
  * A minor bug in ipv4 and ipv6 test
  * macsec setting
  * TeamPortSetting: fix argument
  * team-port setting
  * match and tc setting
  * Add missing defines
  * ovs-patch and ovs-port setting
- Dropped patches, now upstream:
  * Add-missing-defines.patch
  * fix-build-with-NM-1.4.patch

-------------------------------------------------------------------
Wed Dec 12 13:50:16 UTC 2018 - wbauer@tmo.at

- Refresh patches:
  * 0001-Revert-Require-NetworkManager-1.4.0-and-newer.patch
  * 0001-Revert-Add-missing-ipv4-setting-options.patch
  * 0001-Revert-Add-vxlan-setting.patch
- Add some more patches to fix build with older NetworkManager
  versions (as in Leap 42.3 in particular):
  * 0001-Revert-Add-IpTunnel-setting.patch
  * 0001-Revert-Add-missing-IPv6-options.patch
  * Add-missing-defines.patch
  * fix-build-with-NM-1.4.patch

-------------------------------------------------------------------
Sun Dec 09 19:43:45 UTC 2018 - lbeltrame@kde.org

- Update to 5.53.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
  * Get rid of some unneeded defines
  * Fixed a bug(error?) in ipv4 & ipv6 settings
  * Add missing defines
  * Add ovs-bridge and ovs-interface setting
  * Update Ip-tunnel settings
  * Add proxy and user setting
  * Add IpTunnel setting
  * We can now build tun setting test all the time
  * Add missing IPv6 options
  * Listen for added DBus interfaces instead of registered services (kde#400359)
  * Remove qt include prefix
  * normalize signal/slot

-------------------------------------------------------------------
Mon Nov 12 10:35:54 UTC 2018 - wbauer@tmo.at

- Add patches that remove some new settings on Leap 42.3 (that
  would require a newer NetworkManager) to fix the build:
  * 0001-Revert-Add-missing-ipv4-setting-options.patch
  * 0001-Revert-Add-vxlan-setting.patch

-------------------------------------------------------------------
Sun Nov 11 19:48:08 UTC 2018 - lbeltrame@kde.org

- Update to 5.52.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
  * Remove unused variable
  * Add missing ipv4 setting options
  * Add vxlan setting
  * Create own categories file

-------------------------------------------------------------------
Tue Oct 16 08:02:46 UTC 2018 - Luca Beltrame <lbeltrame@kde.org>

- Run spec-cleaner

-------------------------------------------------------------------
Mon Oct 15 11:50:39 UTC 2018 - lbeltrame@kde.org

- Update to 5.51.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.51.0.php
- Changes since 5.50.0:
  * More nullptr usage
  * Use matching enum value AuthEapMethodUnknown to compare a AuthEapMethod
  * Fix minor EBN issues

-------------------------------------------------------------------
Fri Sep 14 14:48:33 UTC 2018 - Wolfgang Bauer <wbauer@tmo.at>

- Add 0001-Revert-Require-NetworkManager-1.4.0-and-newer.patch to
  make it build on Leap 42.3 which only has NetworkManager 1.0.

-------------------------------------------------------------------
Thu Sep 13 21:58:46 UTC 2018 - lbeltrame@kde.org

- Update to 5.50.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
  * Remove notes from API documentation about older NM versions
  * Require NetworkManager 1.4.0 and newer
  * manager: add support to R/W the GlobalDnsConfiguration property
  * Actually allow to set the refresh rate for device statistics

-------------------------------------------------------------------
Sun Aug 19 09:19:32 UTC 2018 - christophe@krop.fr

- Update to 5.49.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
  * None

-------------------------------------------------------------------
Mon Jul 16 04:37:45 UTC 2018 - lbeltrame@kde.org

- Update to 5.48.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.48.0.php
- Changes since 5.47.0:
  * Remove QT definitions duplicated from KDEFrameworkCompilerSettings or dead

-------------------------------------------------------------------
Wed Jun 27 08:54:26 UTC 2018 - bjorn.lie@gmail.com

- Align with what cmake looks for:
  * Drop pkgconfig(NetworkManager), pkgconfig(libnm-glib) and
    pkgconfig(libnm-util) BuildRequires and Requires.
  * Add pkgconfig(libnm) BuildRequires and Requires.

-------------------------------------------------------------------
Tue Jun 12 21:26:08 UTC 2018 - lbeltrame@kde.org

- Update to 5.47.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
  * Add missing override
  * Use override
  * Make information about unhandled property just debug messages
  * WirelessSetting: implement assignedMacAddress property

-------------------------------------------------------------------
Sun May 13 21:03:07 UTC 2018 - lbeltrame@kde.org

- Update to 5.46.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.46.0.php
- Changes since 5.45.0:
  * None

-------------------------------------------------------------------
Sat Apr 14 13:19:07 CEST 2018 - lbeltrame@kde.org

- Update to 5.45.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.45.0.php
- Changes since 5.44.0:
  * Export the NetworkManager include dirs.
  * Start requiring NM 1.0.0
  * We depend against 5.8.0
  * We use qt5.8.0
  * device: define StateChangeReason and MeteredStatus as Q_ENUMs
  * Fix conversion of AccessPoint flags to capabilities

-------------------------------------------------------------------
Mon Mar 12 23:29:42 CET 2018 - lbeltrame@kde.org

- Update to 5.44.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
  * None

-------------------------------------------------------------------
Mon Feb 12 23:42:10 CET 2018 - lbeltrame@kde.org

- Update to 5.43.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
  * None

-------------------------------------------------------------------
Tue Jan 16 22:50:21 CET 2018 - lbeltrame@kde.org

- Update to 5.42.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.42.0.php
- Changes since 5.41.0:
  * Remove not necessary virtual keyword
  * 802-11-x: support for PWD EAP method
  * it was split

-------------------------------------------------------------------
Sun Dec 17 09:43:49 CET 2017 - lbeltrame@kde.org

- Update to 5.41.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
  * Remove redundant map look-ups
  * Don't do unnecessary QString allocations to convert parts of it into strings

-------------------------------------------------------------------
Mon Nov 13 07:01:16 CET 2017 - lbeltrame@kde.org

- Update to 5.40.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.40.0.php
- Changes since 5.39.0:
  * Fix 8021xSetting unit test
  * 8021xSetting: domain-suffix-match is defined in NM 1.2.0 and newer
  * Support "domain-suffix-match" in Security8021xSetting

-------------------------------------------------------------------
Mon Oct 23 06:41:45 CEST 2017 - lbeltrame@kde.org

- Update to 5.39.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.39.0.php
- Changes since 5.38.0:
  * None

-------------------------------------------------------------------
Tue Sep 12 07:11:18 CEST 2017 - lbeltrame@kde.org

- Update to 5.38.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
  * None

-------------------------------------------------------------------
Sat Aug 12 09:23:42 UTC 2017 - christophe@krop.fr

- Update to 5.37.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.37.0.php
- Changes since 5.36.0 :
  * Adding support to ipv*.route-metric
  * Fix undefined NM_SETTING_WIRELESS_POWERSAVE_FOO enums (kde#382051)
  * Add .arcconfig
- Drop Fix-undefined-enums.patch (merged upstream)

-------------------------------------------------------------------
Wed Jul 12 09:57:14 UTC 2017 - wbauer@tmo.at

- Add Fix-undefined-enums.patch to make it build with NM 1.0.x on
  Leap 42 (kde#382051)

-------------------------------------------------------------------
Wed Jul 12 07:14:03 CEST 2017 - lbeltrame@kde.org

- Update to 5.36.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.36.0.php
- Changes since 5.35.0:
  * Too many changes to list here

-------------------------------------------------------------------
Sun Jun 11 09:27:44 CEST 2017 - lbeltrame@kde.org

- Update to 5.35.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
  * None

-------------------------------------------------------------------
Mon May 15 13:53:11 CEST 2017 - fabian@ritter-vogt.de

- Update to 5.34.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.34.0.php
- Changes since 5.33.0:
  * Fix crash when retrieving active connection list. (kde#373993)
  * -Wheader-guard
  * -Wheader-guard
  * Fix unit test
  * Set default value for auto-negotiation based on running NM version
  * One more attempt to fix unit test for active connections
  * Fix unit test for active connections

-------------------------------------------------------------------
Sat Apr 15 10:11:58 CEST 2017 - lbeltrame@kde.org

- Update to 5.33.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.33.0.php
- Changes since 5.32.0:
  * Upgrade ECM and KF5 version requirements for 5.33.0 release.
  * WiredSetting: return autonegotiate even when it's disabled
  * Prevent signals in glib2 be defined by Qt
  * prevent signals in glib2 be defined by Qt
  * WiredSetting: Speed and duplex can be set only when auto-negotiation is off
  * Auto-negotiate value for wired setting should be false
  * Upgrade KF5 version to 5.33.0.

-------------------------------------------------------------------
Sun Mar 19 14:51:14 CET 2017 - lbeltrame@kde.org

- Update to 5.32.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
  * Upgrade ECM and KF5 version requirements for 5.32.0 release.
  * Sync introspections and generated files with NM 1.6.0
  * Manager: Fix emitting deviceAdded twice when NM restarts
  * Upgrade KF5 version to 5.32.0.

-------------------------------------------------------------------
Thu Feb  9 09:35:57 UTC 2017 - hrvoje.senjan@gmail.com

- Update to 5.31.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.31.0.php

-------------------------------------------------------------------
Sun Jan  8 23:44:51 UTC 2017 - hrvoje.senjan@gmail.com

- Update to 5.30.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.30.0.php

-------------------------------------------------------------------
Sun Dec  4 02:06:11 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.29.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.29.0.php

-------------------------------------------------------------------
Wed Nov 16 06:23:32 UTC 2016 - hrvoje.senjan@gmail.com

- Raise (Build)Required NM version to 0.9.10.0 (as per CMakeLists.txt)

-------------------------------------------------------------------
Sat Nov  5 22:13:03 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.28.0
  * Fix include dir in pri file
  * Fix moc error due to Q_ENUMS being used in a namespace,
    with Qt branch 5.8
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.28.0.php

-------------------------------------------------------------------
Sun Oct  2 13:01:53 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.27.0
  * We need to set the state during initialization
  * Replace all blocking calls for initialization with
    just one blocking call
  * Use standard o.f.DBus.Properties interface for PropertiesChanged
    signal for NM 1.4.0+ (kde#367938)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.27.0.php
- Drop upstreamed fix-icons-with-NM-1.4.0.patch

-------------------------------------------------------------------
Sun Sep 25 11:30:38 UTC 2016 - wbauer@tmo.at

- Add fix-icons-with-NM-1.4.0.patch to work around a bug in
  NetworkManager 1.4.0 that causes wrong status icons (kde#367938)

-------------------------------------------------------------------
Tue Sep  6 20:55:11 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.26.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.26.0.php

-------------------------------------------------------------------
Sun Aug  7 21:58:22 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.25.0
  * Qt >= 5.5 is now required
  * Default to WPA2-PSK and WPA2-EAP when getting security
    type from connection settings
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.25.0.php

-------------------------------------------------------------------
Sun Jul 10 00:44:57 UTC 2016 - hrvoje.senjan@gmail.com

- Raise NM BuildRequires to 0.9.10.0 so it matches reality

-------------------------------------------------------------------
Wed Jul  6 15:07:20 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.24.0
  * Do not set peap label based on peap version
  * Make network manager version checks in runtime
    (to avoid compile vs. run-time (kde#362736))
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.24.0.php

-------------------------------------------------------------------
Mon Jun  6 21:28:55 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.23.0
  * Revert "drop WiMAX support for NM 1.2.0+" as it breaks ABI
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.23.0.php

-------------------------------------------------------------------
Sat May  7 18:34:50 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.22.0 (boo#980066)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.22.0.php

-------------------------------------------------------------------
Mon Apr  4 14:23:13 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.21.0 (boo#974793)
  * ConnectionSettings: Initialize gateway ping timeout
  * New TunSetting and Tun connection type
  * Create devices for all known types
  * Upgrade Qt version requirement to 5.4.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.21.0.php

-------------------------------------------------------------------
Sun Mar  6 10:03:54 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.20.0 (boo#970856)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.20.0.php

-------------------------------------------------------------------
Sat Feb  6 18:08:53 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.19.0 (boo#967668)
  * Re-check connection state and other properties to be sure
    they are actual (version 2) (kde#352326)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.19.0.php

-------------------------------------------------------------------
Sat Jan  2 17:46:05 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.18.0
  * Make it work with older NM versions
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.18.0.php
- Drop upstreamed 0001-make-it-work-with-older-NM-versions.patch

-------------------------------------------------------------------
Wed Dec 16 08:23:24 UTC 2015 - alarrosa@suse.com

- Added 0001-make-it-work-with-older-NM-versions.patch committed also
  upstream. This adds some #ifdefs around code that needs NM 0.9.10
  so it also builds with NM 0.9.8

-------------------------------------------------------------------
Thu Dec 10 23:11:43 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.17.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.17.0.php

-------------------------------------------------------------------
Sun Nov  8 17:05:53 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.16.0 (boo#955067)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.16.0.php

-------------------------------------------------------------------
Mon Oct  5 17:37:41 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.15.0
  * Fix introspections, LastSeen should be in AccessPoint and
    not in ActiveConnection
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.15.0.php

-------------------------------------------------------------------
Tue Sep  8 17:13:41 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.14.0
  * Added new properties from the latest NM snapshot/releases
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.14.0.php

-------------------------------------------------------------------
Tue Aug  4 19:20:52 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.13.0
  * The Qt version requirement has been bumped from 5.2 to 5.3
  * Debug output has been ported to categorized output, for less
    noise by default
  * Docbook documentation has been reviewed and updated
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.13.0.php

-------------------------------------------------------------------
Sun Jul  5 18:45:30 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.12.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.12.0.php

-------------------------------------------------------------------
Sun Jun  7 19:08:01 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.11.0
  * Drop WiMAX support for NM 1.2.0+
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.11.0.php

-------------------------------------------------------------------
Sun May  3 19:50:46 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.10.0
  * The installed headers are now organized like all other frameworks
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.10.0.php

-------------------------------------------------------------------
Sat Apr  4 14:41:02 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.9.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.9.0.php
- NetworkManager is a public dep, so add the correct requires to
  devel package (pkgconfig(NetworkManager), pkgconfig(libnm-glib)
  and pkgconfig(libnm-util))

-------------------------------------------------------------------
Sat Mar  7 16:59:01 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.8.0
  * Add new properties and methods from NetworkManager 1.0.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.8.0.php

-------------------------------------------------------------------
Sun Feb  8 18:15:38 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.7.0
  * Do not print a message about unhandled "AccessPoints" property
  * Added support for NetworkManager 1.0.0 (not required)
  * Fixed VpnSetting secrets handling
  * Added class GenericSetting for connections not managed by
    NetworkManager
  * Added property AutoconnectPriority to ConnectionSettings
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.7.0.php
- Drop vpn.patch, merged upstream

-------------------------------------------------------------------
Tue Jan 13 19:21:59 UTC 2015 - hrvoje.senjan@gmail.com

- Added vpn.patch from upstream

-------------------------------------------------------------------
Sat Jan  3 18:03:26 UTC 2015 - hrvoje.senjan@gmail.com

- Libary is now officially a part of KDE Frameworks 5 libraries
- Update to 5.6.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.6.0.php
- Update summary and descriptions
- Be more explicit about BuildRequires (using pkgconfig, etc)
- Added baselibs.conf

-------------------------------------------------------------------
Thu Dec 11 18:00:02 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.1.2:
  * Bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.1.2.php

-------------------------------------------------------------------
Thu Nov  6 20:14:18 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.1.1:
  * Bugfix release
  * Do not notify about changed VpnState twice
  * Watch for changes when constructing new ModemDevice
  * Add workaround to properly update IpInterface
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.1.1.php

-------------------------------------------------------------------
Thu Oct  9 21:24:35 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.1 Final:
  * Bugfixes since RC1
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.1.0.php

-------------------------------------------------------------------
Fri Sep 26 14:27:31 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.0.95:
   * Mnor bugfixes since previous release

-------------------------------------------------------------------
Sun Aug 10 22:16:00 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.0.92
   * Bugfix release

-------------------------------------------------------------------
Fri Jul 11 19:32:41 UTC 2014 - hrvoje.senjan@gmail.com

- Version update to 5.0.91

-------------------------------------------------------------------
Thu Jul  3 21:48:53 UTC 2014 - hrvoje.senjan@gmail.com

- Activate libKF5NetworkManagerQt package