File apache-commons-validator.changes of Package apache-commons-validator

-------------------------------------------------------------------
Mon Mar 25 17:53:26 UTC 2019 - Fridrich Strba <fstrba@suse.com>

- Remove pom parent, since we don't use it when not building with
  maven
- Remove special conditions for suse_version 1110

-------------------------------------------------------------------
Fri Dec 21 20:53:20 UTC 2018 - Fridrich Strba <fstrba@suse.com>

- Build against commons-digester >= 1.8
- Removed patch:
  * commons-validator-1.5.0-digester.patch
    + building against commons-digester >= 1.8, this patch is
      superfluous

-------------------------------------------------------------------
Fri Dec 21 13:56:05 UTC 2018 - Fridrich Strba <fstrba@suse.com>

- Update to 1.5.0
- Install the maven pom file
- Removed patch:
  * commons-validator-1.3.1-crosslink.patch
    + not needed
- Added patch:
  * commons-validator-1.5.0-digester.patch
    + fix build with older versions of commons-digester
- Modified patches:
  * commons-validator-1.3.1-srcencoding.patch ->
    commons-validator-1.5.0-srcencoding.patch
    + specify encoding utf-8 for javac and javadoc invocation
      instead of escaping characters
  * commons-validator-1.3.1-locale.patch ->
    commons-validator-1.5.0-locale.patch
    + Adapt the patch to the 1.5.0 context
    + Add the sysproperty to the junit task

-------------------------------------------------------------------
Tue May 15 13:22:32 UTC 2018 - fstrba@suse.com

- Build with source and target 8 to prepare for a possible removal
  of 1.6 compatibility

-------------------------------------------------------------------
Mon Oct  9 10:31:46 UTC 2017 - fstrba@suse.com

- Fix build and running of junit tests with Java 9+
- Added patch:
  * commons-validator-1.3.1-locale.patch
    + Made two different test.routines target, one with java <= 1.8
      and one with java 9+, since the locale providers changed
      between java 1.8 and 9. Moreover, the options that Java 9
      needs to run in compatibility mode break build with lower
      versions of Java.

-------------------------------------------------------------------
Thu Sep 14 15:12:50 UTC 2017 - fstrba@suse.com

- Build with java source and target 1.6
- Use java-devel < 1.9 because with jdk9, some unit tests fail
- Clean spec file

-------------------------------------------------------------------
Tue Jul  8 12:28:41 UTC 2014 - tchvatal@suse.com

- Cleanup with spec-cleaner and fix build on Factory.

-------------------------------------------------------------------
Mon Apr 14 14:22:53 UTC 2014 - darin@darins.net

- add requirements for SLES 

-------------------------------------------------------------------
Fri Jun 15 12:13:29 UTC 2012 - mvyskocil@suse.cz

- update to 1.3.1 
- rename to apache-commons-validator

-------------------------------------------------------------------
Mon Sep 25 14:02:15 CEST 2006 - skh@suse.de

- don't use icecream
- use source="1.4" and target="1.4" for build with java 1.5

-------------------------------------------------------------------
Wed Jan 25 21:46:39 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Thu Jul 28 14:47:42 CEST 2005 - jsmeix@suse.de

- Current version 1.1.4 from JPackage.org

-------------------------------------------------------------------
Mon Jul 18 16:30:30 CEST 2005 - jsmeix@suse.de

- Current version 1.1.3 from JPackage.org

-------------------------------------------------------------------
Tue Feb 22 13:31:53 CET 2005 - skh@suse.de

- Update to version 1.1.3

-------------------------------------------------------------------
Sun Sep  5 23:44:26 CEST 2004 - skh@suse.de

- Initial package created with version 1.0.2 (Jakarta 1.5)