File atkmm-glibmm-bump.patch of Package atkmm

From 67c7de95d50f96656171c7d7654a8c1bec20af9f Mon Sep 17 00:00:00 2001
From: Kjell Ahlstedt <kjellahlstedt@gmail.com>
Date: Mon, 26 Mar 2018 12:56:04 +0200
Subject: Use glibmm-2.58 instead of glibmm-2.56

We have changed the ABI name in glibmm.
---
 codegen/Makefile.am | 2 +-
 configure.ac        | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/codegen/Makefile.am b/codegen/Makefile.am
index d46fbc4..2597de4 100644
--- a/codegen/Makefile.am
+++ b/codegen/Makefile.am
@@ -30,7 +30,7 @@ dist_noinst_SCRIPTS = generate_defs_and_docs.sh
 noinst_PROGRAMS  = extradefs/generate_extra_defs
 
 extradefs_generate_extra_defs_SOURCES = extradefs/generate_extra_defs_atk.cc
-extradefs_generate_extra_defs_LDADD   = $(ATKMM_LIBS) -lglibmm_generate_extra_defs-2.56
+extradefs_generate_extra_defs_LDADD   = $(ATKMM_LIBS) -lglibmm_generate_extra_defs-2.58
 extradefs_generate_extra_defs_LDFLAGS = -no-undefined -avoid-version
 
 AM_CPPFLAGS = -I$(top_builddir) $(GTHREAD_CFLAGS) $(ATKMM_CFLAGS)
diff --git a/configure.ac b/configure.ac
index 03fb934..b482c7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,18 +51,18 @@ MM_AX_CXX_COMPILE_STDCXX([14], [noext], [mandatory])
 AC_DISABLE_STATIC
 LT_INIT([win32-dll])
 
-AC_SUBST([ATKMM_MODULES], ['atk >= 1.18 glibmm-2.56 >= 2.53.1.1'])
+AC_SUBST([ATKMM_MODULES], ['atk >= 1.18 glibmm-2.58 >= 2.53.1.1'])
 PKG_CHECK_MODULES([ATKMM], [$ATKMM_MODULES])
 
 MM_PKG_CONFIG_SUBST([GTHREAD_CFLAGS], [--cflags-only-other gthread-2.0])
-MM_PKG_CONFIG_SUBST([GMMPROC_DIR], [--variable=gmmprocdir glibmm-2.56])
+MM_PKG_CONFIG_SUBST([GMMPROC_DIR], [--variable=gmmprocdir glibmm-2.58])
 
 MM_ARG_DISABLE_DEPRECATED_API
 
 MM_ARG_ENABLE_DOCUMENTATION
 MM_ARG_WITH_TAGFILE_DOC([libstdc++.tag], [mm-common-libstdc++])
 MM_ARG_WITH_TAGFILE_DOC([libsigc++-3.0.tag], [sigc++-3.0])
-MM_ARG_WITH_TAGFILE_DOC([glibmm-2.56.tag], [glibmm-2.56])
+MM_ARG_WITH_TAGFILE_DOC([glibmm-2.58.tag], [glibmm-2.58])
 
 AC_LANG([C++])
 MM_ARG_ENABLE_WARNINGS([ATKMM_WXXFLAGS],
-- 
cgit v0.12
openSUSE Build Service is sponsored by