File 0001-Fix-include-path-for-system-libqhull.patch of Package python-matplotlib

From e75ca533cc5a590d7831507794a2db25ca46e07e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Stefan=20Br=C3=83=C2=BCns?= <stefan.bruens@rwth-aachen.de>
Date: Thu, 13 Jul 2017 21:38:16 +0200
Subject: [PATCH] Fix include path for system libqhull

Current libqhull uses the libqhull subdirectory. If the system libqhull
is not found, it falls back to a much older bundled version.
---
 setupext.py      | 4 ++--
 src/qhull_wrap.c | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/setupext.py b/setupext.py
index 3819636..8894b17 100644
--- a/setupext.py
+++ b/setupext.py
@@ -1175,14 +1175,14 @@ class Qhull(SetupPackage):
         self.__class__.found_external = True
         try:
             return self._check_for_pkg_config(
-                'qhull', 'qhull/qhull_a.h', min_version='2003.1')
+                'qhull', 'libqhull/qhull_a.h', min_version='2003.1')
         except CheckFailed as e:
             self.__class__.found_pkgconfig = False
             # Qhull may not be in the pkg-config system but may still be
             # present on this system, so check if the header files can be
             # found.
             include_dirs = [
-                os.path.join(x, 'qhull') for x in get_include_dirs()]
+                os.path.join(x, 'libqhull') for x in get_include_dirs()]
             if has_include_file(include_dirs, 'qhull_a.h'):
                 return 'Using system Qhull (version unknown, no pkg-config info)'
             else:
diff --git a/src/qhull_wrap.c b/src/qhull_wrap.c
index 06d278e..7d6ace4 100644
--- a/src/qhull_wrap.c
+++ b/src/qhull_wrap.c
@@ -7,7 +7,7 @@
  */
 #include "Python.h"
 #include "numpy/noprefix.h"
-#include "qhull/qhull_a.h"
+#include <libqhull/qhull_a.h>
 #include <stdio.h>
 
 
-- 
2.13.2