File libpt2.changes of Package libpt2

-------------------------------------------------------------------
Wed Sep 27 16:11:35 UTC 2017 - dimstar@opensuse.org

- Disable esd plugin (openSUSE has moved through various other
  sound daemons since esd was useful):
  + Drop esound-devel BuildRequires
  + No longer pass --enable-esd to configure
  + Drop libpt2_10_11-plugins-esd subpackage.
- Add an explicit alsa-devel BuildRequires: this uses to be pulled
  in by esound devel.

-------------------------------------------------------------------
Fri Aug 25 22:20:20 UTC 2017 - mgorse@suse.com

- Add libpt2-openssl11.patch: port to OpenSSL 1.1 (boo#1055477).

-------------------------------------------------------------------
Mon Aug 14 12:44:07 UTC 2017 - schwab@suse.de

- missing-decls.patch: fix missing declarations

-------------------------------------------------------------------
Tue May 24 21:05:57 UTC 2016 - dimstar@opensuse.org

- Update to version 2.10.11:
  + Bug fixes.
- Bump _version to 2_10_11.
- Add libpt2-2.10.11-gcc6.patch: Fix build against GCC 6.x

-------------------------------------------------------------------
Wed May  6 20:04:48 UTC 2015 - dmueller@suse.com

- add libpt2-gcc5-fixes.patch: Fix build against GCC 5.x

-------------------------------------------------------------------
Fri Jan 30 18:34:48 UTC 2015 - crrodriguez@opensuse.org

- Build with -fvisibility-inlines-hidden, shrinks the
  exported symbol table around 50%

-------------------------------------------------------------------
Tue Jan 20 14:12:43 UTC 2015 - dimstar@opensuse.org

- Add libpt2-bison-3.0.patch: Fix build with bison 3.0.

-------------------------------------------------------------------
Sun Feb 16 11:13:30 CET 2014 - ro@suse.de

- libpt2-ppc64le.patch: Add support for ppc64le

-------------------------------------------------------------------
Sun Jun 16 02:54:14 UTC 2013 - jengelh@inai.de

- Add explicit cyrus-sasl-devel and libopenssl-devel BuildRequires:
  They used to be pulled in by openldap-devel.

-------------------------------------------------------------------
Fri Mar 29 18:19:34 UTC 2013 - schwab@suse.de

- libpt2-aarch64.patch: Add support for aarch64

-------------------------------------------------------------------
Tue Feb 26 10:10:41 UTC 2013 - dimstar@opensuse.org

- Update to version 2.10.10:
  + Several fixes for H.323.
  + Fix subscribing/unsubscribing when enabling and disabling SIP
    accounts.
  + Bug fixes.

-------------------------------------------------------------------
Mon Dec  3 19:46:40 UTC 2012 - dimstar@opensuse.org

- Update to version 2.10.9:
  + Various SIP interoperability fixes.
  + Added SIP Service-Route header support (RFC 3608).
  + Various SIP/SIMPLE presence related fixes.
  + Fixed registration to broken registrars.
  + Unregister all accounts on quit.
  + Publish offline presence on quit.
  + Refresh NAT bindings with SIP OPTIONS requests.
  + Support for DNS SRV caching.
- Pass --enable-ipv6 to configure: enable IPv6 support.

-------------------------------------------------------------------
Thu Aug 23 22:33:52 UTC 2012 - dimstar@opensuse.org

- Update to version 2.10.7:
  + Add global flag to prevent trying to get canonical name when
    doing host lookup by name.
  + Add support for GNU/Hurd.
- Changes from version 2.10.6:
  + Add encryption (StartTLS) support for LDAP
  + Use more intuitive Pulse default device name.
  + IPv6 support for PDNS.
  + Disable IPv6 by default.
  + Various bug fixes and other code changes.

-------------------------------------------------------------------
Fri May 18 19:06:25 UTC 2012 - zaitor@opensuse.org

- Update to 2.10.5:
  + Numours changes, please see changelogfile.
- Add new subpackage: libpt-plugins-pulse. Brings PulseAudio
  support to libpt. New BuildRequires added pkgconfig(libpulse) due
  to this.
- Enable build of avc plugin.

-------------------------------------------------------------------
Thu Apr 19 03:00:40 CEST 2012 - jeffm@suse.de

- Update to 2.10.4:
  + Numours changes, please see changelogfile.
- Drop libpt2-2.6.7-missing_links.patch, libpt2-gcc47.patch,
  ptlib-pkg_config.patch, fixed upstream.
- Add libpt2-fix-avc-plugin

-------------------------------------------------------------------
Thu Mar 15 21:01:15 UTC 2012 - dimstar@opensuse.org

- Add libpt2-gcc47.patch: Fix build with gcc 4.7.

-------------------------------------------------------------------
Wed Jul  6 09:55:14 UTC 2011 - dimstar@opensuse.org

- Disable build of v4l plugin on openSUSE 12.1+, based on
  build_v4l define, we change the spec:
  + Conditionally pass --enable-v4l to configure
  + Obsolete libpt%{_version}-plugins-v4l
  + Do not create the libpt%{_version}-plugins-v4l subpackage.
- Stop using source services, as Factory is moving away from it.

-------------------------------------------------------------------
Thu Oct 14 10:25:41 CEST 2010 - vuntz@opensuse.org

- Disable the build of the avc plugin, like we did for the dc
  plugin: it doesn't work with the new libraw1394. We have a
  %build_avc define to easily switch this back, and when the build
  %is disabled, we make libpt%{_version} obsolete the plugin
  %subpackage, to make sure it gets removed from install.

-------------------------------------------------------------------
Thu Oct  7 01:08:54 UTC 2010 - reddwarf@opensuse.org

- Add libpt2-2.6.7-missing_links.patch
  + Fixes build with -Wl,--no-undefined

-------------------------------------------------------------------
Mon Oct  4 12:56:34 CEST 2010 - vuntz@opensuse.org

- Disable the build of the dc plugin, since we're moving to the new
  libraw1394 and libdc1394, and the code is not ready for this. We
  have a %build_dc define to easily switch this back, and when the
  build is disabled, we make libpt%{_version} obsolete the plugin
  subpackage, to make sure it gets removed from install.

-------------------------------------------------------------------
Tue Jul 27 23:48:02 UTC 2010 - reddwarf@opensuse.org

- Update to version 2.6.7:
  + Add bpp 16 support.
  + IPv6 fixes.
  + Fix build on Solaris.
- Changes from version 2.6.6:
  + Fixed issue when during deletion of a safe object from the last
    safe pointer, that safe pointer is again set to NULL, causing
    recursion and death.
  + Fix for FreeBSD over GlibC.
  + Fix possible crash when PTLib code accessed by thread not
    created by PTlib.
  + Compatibility with newer OpenSSL library.
  + Fixed including tab character as white space for MIME extension
    lines.
  + Fixed issue with only HighestPriority threads being boosted,
    now both HighPriority and HighestPriority threads will use the
    SCHED_RR policy and set the sched_priority field accordingly.
  + Fixed compatibility with pre 2.6.16 Linux kernels.
  + Make sure an error is set on the channel if unsupported WAV
    file format used.
  + Build fixes.
- Follow SLPP, and don't break ABI changing the soname in a way
  that anyway was wrong. This also means libpt2-devel is renamed to
  libpt-devel.
- Add pkg-config BuildRequires.
- Add ptlib-pkg_config.patch: this remove abusive link flags from
  the pkg-config file. Also remove SDL-devel, libexpat-devel,
  openldap2-devel and openssl-devel Requires from devel package.
- Drop libpt2-2.6.2.patch: nobody knew exactly what it did, so
  remove it to go back to upstream behavior.
- Drop libpt2-soname.diff: this is what was done wrong and is now
  unneede since we follow the shared library packaging policy.
- We can now remove the calls to autoreconf and aclocal thanks to
  the removed patches.
- Use %configure macro.
- Reenable ESD support: as it could be useful for PulseAudio.
- Ship the v4l2 plugin by default instead of the v4l plugin.
- Remove static library.

-------------------------------------------------------------------
Tue Oct  6 15:46:20 CEST 2009 - dimstar@opensuse.org

- Update to version 2.6.5:
  + Fixed base 64 encoder for strings less than 3 characters long,
  + Fixed failure to use STUN sockets with symmetric NAT
  + The absence of libv4l2 should not block V4L2 plugin
  + Changed default for AVC plug in to be disabled until someone
    fixes it.
  + remconn option need config-file option
- Clean spec file using spec-cleaner.

-------------------------------------------------------------------
Sun Jul 19 13:37:42 CEST 2009 - dominique-obs@leuenberger.net

- Update to version 2.6.4:
  + Bugfix release.

-------------------------------------------------------------------
Tue May 19 21:41:45 CEST 2009 - dominique-obs@leuenberger.net

- Update to version 2.6.2:
  + Bugfix release
  + Rebased patch ptlib2-2.4.2.diff to ptlib2-2.6.2.patch

-------------------------------------------------------------------
Wed Apr 29 22:14:21 CEST 2009 - vuntz@novell.com

- Update to version 2.6.1:
  + This is a major update of ptlib/opal with the following main
    features:
    - Instant Messaging. Using several different “standards”:
      RFC4975, MSRP, T.140, SIP-IM etc etc.
    - Much improved support for SIP event handling
      (SUBSCRIBE/NOTIFY/PUBLISH) using factories so more event
      packages can be added easily.
    - Support for SIP “dialog” event package.
    - Support for Shared Line Appearance (aka Multiple Line
      Appearance, Bridged Line Appearance or Busy Lamp Field)
    - Significant improvements in IPv6 support
    - Major enhancements to the video rate controller.
    - Removal of the old H.263 ffmpeg plug in and enhancement of
      the H.263-1998 plug it to take its place.
    - H.224 support (H.323 only).
    - SBC audio codec plug in.
    - G.722 audio codec plug in.
    - CELT audio codec plug in.
    - SWIG support for use in other languages, Java first.
    - Much improved multi-platform sample GUI client, OpenPhone.
      Now standard test environment replacing simpleOPAL.
- Add libv4l-devel BuildRequires for the v4l2 plugin.
- Remove part of ptlib-2.4.2.diff which changed P_OEXPAT to
  P_EXPAT, which was breaking the expat support from ptlib when
  used by opal.

-------------------------------------------------------------------
Thu Nov  6 22:13:01 CET 2008 - kkeil@suse.de

- do not create include/ptbuildopts.h.in from scratch
  This caused configuration errors in ekiga (bnc#440869)

-------------------------------------------------------------------
Sun Oct 26 17:44:45 CET 2008 - kkeil@suse.de

- update to bugfix release 2.4.2
  * Fix static linking for mingw
  * Move the defaults so we can overwrite them depending on the
    platform
  * Finally fix static and dynamic plugins on mingw
  * Fixed being able to pass a ip%interface form of address string
    to a PIPSocket::Address and it still works correctly, using the
    ip part if there
  * Fixed correct upper/lower case comparisons as per RFC952
  * Make vfw configurable
  * STUN was not working with Open NAT
  * Fixed incorrect port displayed in trace log for STUN
  * Make sure CreateSocketPair also works with open nat
  * Allow video file output device to work with new files
  * Fixed problem with PSafeCollection destructor deleting objects
    even if they still have a PSafePtr referencing them
  * Fix compilation without vfw

-------------------------------------------------------------------
Mon Oct 20 17:32:48 CEST 2008 - kkeil@suse.de

- remove windows build files to avoid license issues (bnc#436929)

-------------------------------------------------------------------
Mon Oct 13 15:52:38 CEST 2008 - kkeil@suse.de

- add version 2.4.1 needed for ekiga 3.0 (bnc#428117)
  this is the successor of pwlib, but with new API version 2
  so it does not replace pwlib yet

-------------------------------------------------------------------