File dogtail-wnck-3.0.patch of Package dogtail

Index: dogtail-0.9.0/dogtail/tree.py
===================================================================
--- dogtail-0.9.0.orig/dogtail/tree.py
+++ dogtail-0.9.0/dogtail/tree.py
@@ -84,6 +84,8 @@ except ImportError:  # pragma: no cover
 
 # We optionally import the bindings for libWnck.
 try:
+    import gi
+    gi.require_version('Wnck', '3.0')
     from gi.repository import Wnck
     gotWnck = True  # pragma: no cover
 except ImportError:
openSUSE Build Service is sponsored by