File python-matplotlib.changes of Package python-matplotlib

-------------------------------------------------------------------
Wed May 20 14:06:24 UTC 2020 - Tomáš Chvátal <tchvatal@suse.com>

- Remove Qt4 backend as we don't want to ship Qt4 anymore

-------------------------------------------------------------------
Mon May 18 08:00:49 UTC 2020 - Tomáš Chvátal <tchvatal@suse.com>

- Update version to 2.2.5:
  * Latest 2.x series that supports python2 (we have 3x on TW)
- Make it agnostic between SLE and openSUSE jsc#SLE-11752
  * Same change done to 3.x series in TW

-------------------------------------------------------------------
Tue Aug 14 15:19:00 UTC 2018 - toddrme2178@gmail.com

- Update to version 2.2.3
  * Fix import failure on BSD systems
  * Fix import errors in Qt shims for PyQt5 5.11 and PyQt4 4.12
  * Fix import errors if bz2 module is not in standard library
  * Fix overflow in _path.h
  * Fix infinite recursion in transform repr
  * Fix bug with XKCD style
  * Remove unsafe usage of Popen

-------------------------------------------------------------------
Sat Jun  2 10:48:56 UTC 2018 - hpj@urpla.net

- don't use any lua expressions for suse_version < 1500

-------------------------------------------------------------------
Fri Jun  1 19:45:45 UTC 2018 - dimstar@opensuse.org

- Only recommend python-matplotlib-tk if tk is already flagged for
  installation. On most systems there is no reason to have tk
  available (those UIs are out of date and not well perceived
  anyway).

-------------------------------------------------------------------
Tue May 15 19:15:14 UTC 2018 - tbechtold@suse.com

- Add missing Requires for python-backports.functools_lru_cache (boo#1074491)

-------------------------------------------------------------------
Thu May 10 22:27:45 UTC 2018 - toddrme2178@gmail.com

- Fix building on SLE which doesn't have qhull.

-------------------------------------------------------------------
Sat Mar 17 19:29:36 UTC 2018 - arun@gmx.de

- update to version 2.2.2:
  * v2.2.1 did not actually restore matplotlib.verbose.

- changes from version 2.2.1:
  * This release fixes a number of critical bugs:
    + restores matplotlib.verbose (fixing embedding in pycharm)
    + preserve precision when color mapping small portions of data
      with extreme outliers
    + fixes saving long movies with ffmpeg
    + fixes UnbourdLocal error in contour labeling
    + fixes import failure on python 3.4.0 and 3.4.1
    + fixes compile time failures with clang on 32bit platforms
    + fixes an icon in the Tk backends
    + fixes several issues with Tables
    + fixes expanding offset boxes with tight_layout
    + revert changes to the font caching to avoid a possible bug in
      backports.lru_cache
    + numerous docstring and documentation fixes
  * We have reverted the deprecation of `font_manager.TempCache`.

-------------------------------------------------------------------
Thu Mar  8 04:49:03 UTC 2018 - arun@gmx.de

- specfile:
  * require kiwisolver
  * update required version for dateutil

- update to version 2.2.0:
  * The first release of the v2.2 LTS series and the last version of
    Matplotlib to support python2.  There will be bug-fix release for
    this series until 2020.
  * This release includes new features including:
    + An experimental constrained layout manager
    + Color blind friendly color map (cividis) and color cycle
      (tableau-colorblind10)
    + native support for numpy.datetime64 types
    + animated gif writing via pillow
    + TkAgg now works with pypy
    + cairo based backends for Qt, Tk, and WX
  * There are several API changes in this release:
    + To support the constrained layout Matplotlib has a new required
      dependency (kiwisolver).
    + The `matplotlib.finance` module has been removed, development
      has moved to a stand-alone project.

-------------------------------------------------------------------
Tue Jan 30 10:30:10 UTC 2018 - rolf@rotkraut.de

- Update versions of required packages.

-------------------------------------------------------------------
Sun Jan 28 18:52:20 UTC 2018 - arun@gmx.de

- specfile:
  * update copyright year

- update to version 2.1.2:
  * This release fixes a number of critical bugs:
    + fix a typo in mlab.cohere which yielded incorrect results
    + allow nonposx / nonposy to pass through loglog
    + fix color comparisons when finding handles with legend
    + fixes a recursive draw bug and a major performance regression in
      Qt5Agg backend
    + fix a re-draw bug in WxAgg
    + fix image scaling with high-bit depth integers
    + revert the busy-cursor

-------------------------------------------------------------------
Wed Jan 17 07:16:06 UTC 2018 - thod_@gmx.de

- dependency changed to python-six >= 1.10
  (see "site-packages/matplotlib/__init__.py", line 187)

-------------------------------------------------------------------
Sat Dec 16 23:02:44 UTC 2017 - arun@gmx.de

- update to version 2.1.1:
  * The first and only planned bug-fix release for the 2.1 series.
  * This release include many bug and documentation fixes.  Highlights
    are:
    + change default logscale behavior to clip
    + fixed webagg import errors
    + tweaks to polar ticks
    + fixed exception when guessing afm family names
    + update manifest to include all doc files
    + improve masked array handling in pcolormesh
    + fix segfault from reading invalid png
    + fix blocking_input
    + fix bug resulting in huge multi-page pdf files
    + make `show` in nbagg take args as other backends do
    + several fixes to OSX backend
    + restore positional arg handling on Figure.legend
    + fix bugs in interactive navigation
    + fix issues when panning with invalid limits
    + fix bug with fully masked arrays passed to imshow

-------------------------------------------------------------------
Thu Oct 26 17:37:41 UTC 2017 - toddrme2178@gmail.com

- Update to version 2.1.0
  + New features
    * String categorical values
    * Interactive JS widgets for animation
    * Enhancements to polar plot
    * Figure class now has subplots method
    * Metadata savefig keyword argument
    * Busy Cursor
    * PolygonSelector
    * Added matplotlib.ticker.PercentFormatter
    * Reproducible PS, PDF and SVG output
    * Orthographic projection for mplot3d
    * voxels function for mplot3d
  + Improvements
    * Add capstyle and joinstyle attributes to Collection
    * CheckButtons widget get_status function
    * Add fill_bar argument to AnchoredSizeBar
    * Annotation can use a default arrow style
    * Barbs and Quiver Support Dates
    * Hexbin default line color
    * Figure.legend() can be called without arguments
    * Multiple legend keys for legend entries
    * New parameter clear for :func:`~matplotlib.pyplot.figure`
    * Specify minimum value to format as scalar for LogFormatterMathtext
    * New quiverkey angle keyword argument
    * Colormap reversed method
    * Artist.setp (and pyplot.setp) accept a file argument
    * streamplot streamline generation more configurable
    * Axis.set_tick_params now responds to rotation
    * Shading in 3D bar plots
    * New which Parameter for autofmt_xdate
    * New Figure Parameter for subplot2grid
    * Interpolation in fill_betweenx
    * New keyword argument sep for EngFormatter
    * Extend MATPLOTLIBRC behavior
    * density kwarg to hist
  + Internals
    * New TransformedPatchPath caching object
    * Abstract base class for movie writers
    * Stricter validation of line style rcParams
  + Performance
    * Path simplification updates
    * Implement intersects_bbox in c++\
- Remove upstream-included patches:
  * 0001-Fix-include-path-for-system-libqhull.patch
  * 0001-Allow-divmod-to-be-overridden-by-num.patch
  * 166a14473272_Fix-contour-colour-level-determination.patch
  * 97e170d2fc2c_Pass-integers-to-np_linspace.patch

-------------------------------------------------------------------
Mon Oct  9 22:33:02 UTC 2017 - stefan.bruens@rwth-aachen.de

- Fix/enhance build with tests:
  - set PYTHONPATH, otherwise tests will not find the python
    modules installed to the buildroot
  - Add BuildRequires for several tex styles/resources
  - Add BuildRequires: xorg-x11-Xvfb, needed for Qt backend tests
  - Remove python-Pillow, tests are only using png, not e.g jpeg
  - increase image compare tolerance, our Freetype 2.7 renders
    slightly different to the baseline FT 2.6
  - Add upstream 0001-Allow-divmod-to-be-overridden-by-num.patch,
    to cope with numpy 1.13 changes
  - Add upstream 166a14473272_Fix-contour-colour-level-determination.patch
  - Add upstream 97e170d2fc2c_Pass-integers-to-np_linspace.patch

-------------------------------------------------------------------
Mon Oct  9 03:11:03 UTC 2017 - stefan.bruens@rwth-aachen.de

- Also remove runtime-only python-tk dependecy from BuildRequires:

-------------------------------------------------------------------
Sat Oct  7 23:16:35 UTC 2017 - stefan.bruens@rwth-aachen.de

- Rebase the matplotlib setup.cfg on upstream version
- Guard several BuildRequires: which are not necessary for building
  with the "tests" conditional, most backends are pure python
- Do not install/package baseline images only necessary for tests,
  shrinks the main package by 60 MByte

-------------------------------------------------------------------
Thu Aug 10 16:01:33 UTC 2017 - toddrme2178@gmail.com

- Update to version 2.0.2
  Critical bug fixes for 2.0.1
  * fixed Qt4 support
  * fixed LogFormatter
  * fixed hatched artists in legends
  * fixed segfault with large images
- Update to version 2.0.1
  Bug fix release for 2.0.x series
  This release includes bug fixes, documentation updates and one major change.
  + API
    * Do not clip the linewidth used for dash pattern scaling.  This is
      an API change, but is a major improvement.
    * Deprecate 'vega' color names in favor of 'tab'.
  + Bug Fixes
    * Hatching color follows edge color again.
    * Fixes a critical bug with masked images.
    * Improved high-dpi support for Qt5.
    * Log ticking no never skip minor ticks
    * Do not skip points surrounded by nan/inf in vector outputs.
- Disable backends on releases that don't support them.

-------------------------------------------------------------------
Thu Jul 13 20:06:48 UTC 2017 - stefan.bruens@rwth-aachen.de

- Add 0001-Fix-include-path-for-system-libqhull.patch
  Avoid falling back to outdated bundled version

-------------------------------------------------------------------
Sun Apr 30 17:33:15 UTC 2017 - toddrme2178@gmail.com

- Restore qt4 backend since qt4 still has maintained,
  python3-comptible python bindings.
- Provide/obsolete gtk backend to avoid conflicts.
  It doesn't have maintained, python3-compatible python bindings.

-------------------------------------------------------------------
Mon Mar 27 16:06:41 UTC 2017 - toddrme2178@gmail.com

- Implement single-spec version
- Drop old qt4 and gtk2 backends
- Drop unmaintained qt designer widget

-------------------------------------------------------------------
Fri Mar 10 17:46:10 UTC 2017 - toddrme2178@gmail.com

- Fix file list

-------------------------------------------------------------------
Fri Jan 20 23:24:45 UTC 2017 - toddrme2178@gmail.com

- Add python-functools32 dependency.

-------------------------------------------------------------------
Tue Jan 17 17:04:31 UTC 2017 - toddrme2178@gmail.com

- update to version 2.0.0
  + Highlights include:
    * 'viridis' is default color map instead of jet.
    * Modernized the default color cycle.
    * Many more functions respect the color cycle.
    * Line dash patterns scale with linewidth.
    * Change default font to DejaVu, now supports most Western alphabets (including Greek, Cyrillic and Latin with diacritics), math symbols and emoji out of the box.
    * Faster text rendering.
    * Improved auto-limits.
    * Ticks out and only on the right and bottom spines by default.
    * Improved auto-ticking, particularly for log scales and dates.
    * Improved image support (imshow respects scales and eliminated a class of artifacts).

-------------------------------------------------------------------
Fri Dec  2 12:15:46 UTC 2016 - sbahling@suse.com

- update to version 1.5.3 
  * Changed default autorange behavior in boxplots (introduced with
    1.5.2)
- Change BuildRequires and Recommends from python-Pillow to
  python-imaging to allow for SLE 12 builds. (python-Pillow
  provides python-imaging)

-------------------------------------------------------------------
Sat Jul 30 13:30:11 UTC 2016 - jengelh@inai.de

- Make use of wxWidgets 3

-------------------------------------------------------------------
Fri Feb 26 13:09:54 UTC 2016 - tbechtold@suse.com

- Require python-python-dateutil. package was renamed

-------------------------------------------------------------------
Mon Jan 11 08:22:25 UTC 2016 - toddrme2178@gmail.com

- Update to version 1.5.1:
  First bug fix release for 1.5.x series.

-------------------------------------------------------------------
Wed Dec  2 16:12:14 UTC 2015 - egeorget@openmailbox.org

- Enabled qt5 on Leap 42.1
- Enabled wx on Leap 42.1

-------------------------------------------------------------------
Wed Nov 25 22:20:53 UTC 2015 - p.drouand@gmail.com

- Drop agg-devel dependenxy; useless

-------------------------------------------------------------------
Fri Oct 30 11:14:56 UTC 2015 - toddrme2178@gmail.com

- Add new python-Cycler dependency

-------------------------------------------------------------------
Fri Oct 30 09:07:44 UTC 2015 - toddrme2178@gmail.com

- Update to 1.5.0
  * Auto-redraw using the object-oriented API.
  * Most plotting functions now support labeled data API.
  * Color cycling has extended to all style properties.
  * Four new perceptually uniform color maps, including the 
    soon-to-be default 'viridis'.
  * More included style sheets.
  * Many small plotting improvements.
  * Proposed new framework for managing the GUI toolbar and tools.

-------------------------------------------------------------------
Wed Jul  1 12:26:33 UTC 2015 - toddrme2178@gmail.com

- Disable qt5 on SLE 12
- Disable wx on SLE 11 and 12
- Disable latex and gtk3 on SLE 11
- Don't require texlive-sfmath on SLE 12
- Disable qt5 on ppc and arm
- Depend on libxml2 instead of libxml2-tools

-------------------------------------------------------------------
Thu May 21 15:01:06 UTC 2015 - toddrme2178@gmail.com

- Fix installed files

-------------------------------------------------------------------
Mon Mar  2 15:41:02 UTC 2015 - toddrme2178@gmail.com

 - specfile:
   * update url
   * update source url to point to pypi

- update to version 1.4.3:
  *  Many bugs are fixed including:
    - fixing drawing of edge-only markers in AGG
    - fix run-away memory usage when using %inline or saving with a
      tight bounding box with QuadMesh artists
    - improvements to wx and tk gui backends
  * Additionally the webagg and nbagg backends were brought closer to
    feature parity with the desktop backends with the addition of
    keyboard and scroll events thanks to Steven Silvester.

-------------------------------------------------------------------
Mon Oct 27 12:29:14 UTC 2014 - toddrme2178@gmail.com

- Update to 1.4.2.  This is a bug-fix release for the 1.4 series.
  - corrected boxplot in pyplot.py
  - added extra paths to default search paths for freetype

-------------------------------------------------------------------
Mon Oct 20 10:46:01 UTC 2014 - toddrme2178@gmail.com

- Update to 1.4.1.  This is a bug-fix release for the 1.4 series.
  - reverts the changes to interactive plotting so ion will work as
    before in all cases fixed boxplot regressions
  - fixes for finding freetype and libpng
  - sundry unicode fixes (looking up user folders, importing
    seaborn/pandas/networkx with macosx backend)
  - nbagg works with python 3 + new font awesome
  - fixed saving dialogue in QT5

-------------------------------------------------------------------
Thu Sep 18 15:21:01 UTC 2014 - toddrme2178@gmail.com

- Create subpackage to pull in latex dependencies so they are more
  visible to users.
- Comment out testing BuildRequires since we aren't doing testing.
  We aren't doing testing because it takes a long time and a lot
  of packages depend on matplotlib, so it slows down the build
  process for python packages too much.

-------------------------------------------------------------------
Wed Sep 17 15:23:25 UTC 2014 - jmatejek@suse.com

- downgrade Recommends for texlive (and other big packages) to Suggests
  (this means texlive is not pulled in by default zypper settings)

-------------------------------------------------------------------
Wed Sep 10 10:52:26 UTC 2014 - toddrme2178@gmail.com

- Dependency and spec file cleanups
- Remove unneeded use-setuptools.diff

-------------------------------------------------------------------
Thu Aug 28 14:10:38 UTC 2014 - dmueller@suse.com

- adjust python-tz buildrequires to match runtime requires (python-pytz) 

-------------------------------------------------------------------
Wed Aug 27 10:08:07 UTC 2014 - toddrme2178@gmail.com

- Add new python-cairocffi dependency.  This is the recommended
  dependency for the cairo backend upstream.
- Split out the cairo backend into its own subpackage.  It is no
  longer tied to gtk, so people can use it on its own without
  pulling in any gtk dependencies.
- Fixed issues with qt.  The qt5 backend is actually a generic
  qt backend, which the qt4 backend depends on.  So it needs to be
  available for the qt4 backend to work at all.  However, we need
  to pull in the python-qt5 package to make it work, and that 
  package is only available for openSUSE > 13.1.  So we need to
  split the generic qt stuff, including the qt5 stuff, into a
  package both the qt4 and qt5 backends can depend on, and then
  create a stub qt5 package that just pulls in python-qt5
- Reorganized some other backend packages based on backend changes

-------------------------------------------------------------------
Tue Aug 26 12:26:40 UTC 2014 - toddrme2178@gmail.com

- Update to 1.4.0
  * New colormap for red-green color blind users
  * Documentation changes
    - Phil Elson rewrote of the documentation and userguide for both 
        Legend and PathEffects.
  * New plotting features
    - Power-law normalization
    - Fully customizable boxplots
    - Support for datetime axes in 2d plots
    - Support for additional spectrum types
    - Support for detrending and windowing 2D arrays in mlab
    - Support for strides in mlab
    - Formatter for new-style formatting strings
    - Consistent grid sizes in streamplots
    - Get a list of all tick labels (major and minor)
    - Separate horizontal/vertical axes padding support in ImageGrid
    - Support for skewed transformations
    - Support for specifying properties of wedge and text in pie 
      charts.
    - Fixed the direction of errorbar upper/lower limits
    - More consistent add-object API for Axes
    - Violin Plots
    - More `markevery` options to show only a subset of markers
    - Added size related functions to specialized `Collections`
    - Fixed the mouse coordinates giving the wrong theta value in 
      Polar graph
    - Simple quiver plot for mplot3d toolkit
    - polar-plot r-tick locations
  * Date handling
    - n-d array support for date conversion
  * Configuration (rcParams)
    - 'savefig.transparent' added
    - 'axes.titleweight'
    - 'axes.formatter.useoffset' added
  * XDG compliance
    - Matplotlib now looks for configuration files (both rcparams and 
      style) in XDG compliant locations.
  * 'style' package added
    -  You can now easily switch between different styles using the 
       new 'style' package
  * Backends
    - Qt5 backend added
    - Qt4 backend
      + Rudolf Höfler changed the appearance of the subplottool.
      + In the figure options dialog one can now choose to 
        (re-)generate a simple automatic legend.
      + Interactive performance of the Qt4 backend has been 
        dramatically improved under windows.
      + The mapping of key-signals from Qt to values matplotlib 
        understands was greatly improved (For both Qt4 and Qt5).
    - Cairo backends
      +  The Cairo backends are now able to use the cairocffi 
        bindings, which are more actively maintained than the pycairo
        bindings.
    - Gtk3Agg backend
      +  The Gtk3Agg backend now works on Python 3.x, if the cairocffi 
        bindings are installed.
    - PDF backend
      +  Added context manager for saving to multi-page PDFs.
  * Text
    - Text URLs supported by SVG backend
    - Anchored sizebar font
  * Sphinx extensions
    -  The context directive in the plot_directive Sphinx extension 
        can now accept an optional reset setting, which will cause the 
        context  to be reset.
  * Widgets
    - Span Selector
      * Added an option span_stays to SpanSelector which makes the 
        selector rectangle stay on the axes after you release the 
        mouse.
  * GAE integration
    -  Matplotlib will now run on google app engine.
- Added python-qt5 backend on openSUSE > 13.1
- Spec file cleanups

-------------------------------------------------------------------
Wed Jul 16 14:42:54 UTC 2014 - toddrme2178@gmail.com

- Set dummy XDG_RUNTIME_DIR to fix building on openSUSE:Factory

-------------------------------------------------------------------
Thu Apr 10 16:48:36 UTC 2014 - dmueller@suse.com

- install LICENSE directory and fix license tag 

-------------------------------------------------------------------
Wed Apr  9 09:18:56 UTC 2014 - dmueller@suse.com

- add use-setuptools.diff: build against old setuptools as well 

-------------------------------------------------------------------
Fri Mar 28 15:48:46 UTC 2014 - speilicke@suse.com

- Package doc/users/license.rst

-------------------------------------------------------------------
Mon Mar 17 17:47:12 UTC 2014 - i@marguerite.su

- fix bnc#863451
- added windowing.* to python-matplotlib-tk
- It's windowing instead of Windows, a module required by tk backend

-------------------------------------------------------------------
Sat Mar  8 18:01:21 UTC 2014 - bwiedemann@suse.com

- Recommend python-matplotlib-tk because it is the default config

-------------------------------------------------------------------
Thu Jan  9 12:46:20 UTC 2014 - dmueller@suse.com

- remove qt4/designer subpackages for SLE11, as those can
  not be installed without additional updates on a SLES+SDK system

-------------------------------------------------------------------
Thu Nov 14 14:52:44 UTC 2013 - toddrme2178@gmail.com

- Enable all backends
- Split most backends into separate packages
- Update dependencies
- Add many optional dependencies
- Make %setup.py quiet

-------------------------------------------------------------------
Thu Oct 24 12:47:42 UTC 2013 - speilicke@suse.com

- Update to version 1.3.1:
  + Many changes

-------------------------------------------------------------------
Thu Aug 29 14:37:16 UTC 2013 - jmatejek@suse.com

- add Requires: python-pyparsing
  (the pyparsing module is required for mathtext rendering)

-------------------------------------------------------------------
Wed Aug 21 05:25:57 UTC 2013 - highwaystar.ru@gmail.com

- update to 1.3.0
- New features:
 * xkcd-style sketch plotting
 * New eventplot plot type
 * Triangular grid interpolation
 * Baselines for stackplot
 * Rectangular colorbar extensions
 * Calling subplot() without arguments
- Drawing:
 * Independent alpha values for face and edge colors
 * Path effects on lines
 * Easier creation of colormap and normalizer for levels with colors
 * Full control of the background color
 * Improved bbox_inches="tight" functionality
 * Initialize a rotated rectangle
- Text:
 * Anchored text support
 * Better vertical text alignment and multi-line text
 * Left and right side axes titles
 * Improved manual contour plot label positioning
- Configuration (rcParams) 
 * Quickly find rcParams
 * Changes to font rcParams
- Backends
 * WebAgg backend
 * Remember save directory 
- Documentation and examples:
 * Numpydoc docstrings
 * Example reorganization
 * Examples now use subplots()
- Infrastructure
 * Housecleaning
 * New setup script
 * XDG base directory support
 * Catch opening too many figures using pyplot
- for API changes see 
  http://matplotlib.org/api/api_changes.html#changes-in-1-3   
- removed patches needed for python3 package

-------------------------------------------------------------------
Mon Nov 12 04:24:19 UTC 2012 - highwaystar.ru@gmail.com

- update to 1.2.0
 * Python 3.x support
 * PGF/TikZ backend
 * Locator interface
 * Tri-Surface Plots
 * Control the lengths of colorbar extensions
 * Figures are picklable
 * Set default bounding box in matplotlibrc
 * New Boxplot Functionality
 * New RC parameter functionality
 * Streamplot
 * New hist functionality
 * Updated shipped dependencies
 * Face-centred colors in tripcolor plots
 * Hatching patterns in filled contour plots, with legends 
- python3 package added

-------------------------------------------------------------------
Tue Aug 21 02:47:37 UTC 2012 - highwaystar.ru@gmail.com

- bugfix upstream release 1.1.1

-------------------------------------------------------------------
Thu Apr 26 12:03:33 UTC 2012 - toddrme2178@gmail.com

- Remove configobj buildrequires, all configobj files should have
  been removed from matplotlib years ago

-------------------------------------------------------------------
Tue Mar 20 10:08:51 UTC 2012 - toddrme2178@gmail.com

- Fix Qt Designer plugin directories

-------------------------------------------------------------------
Fri Mar 16 15:13:32 UTC 2012 - toddrme2178@gmail.com

- Cleaned up spec file formatting
- Removed tests for obsolete openSUSE versions
- Added Qt Designer plugin from Python(x,y) project

-------------------------------------------------------------------
Tue Jan 10 11:38:24 CET 2012 - kukuk@suse.de

- Fix spec file for SLE11 (Group entries did go lost)

-------------------------------------------------------------------
Wed Dec 14 08:56:13 UTC 2011 - highwaystar.ru@gmail.com

- update to 1.1.0
 * module for drawing sankey diagrams;
 * environment for creating animated graphics – module animation;
 * automated positioning charts, labels, and axes on the canvas – a 
   team tight_layout () will distribute them so that they are not 
   people came to each other;
 *  Work on integration with PySide, although functional is still 
    in the beta-version and it is recommended to continue using 
    PyQt4;
 * improved mapping and positioning of the legend;
 * simplified work with three-dimensional graphs (module mplot3d), 
   also significantly expanded and updated documentation on mplot3d;
 * uniform markers;
 * completely removed the old module support Numerix, now all 
   users must use Numpy;
 * fixes some bugs.
- removed patches that now upstream

-------------------------------------------------------------------
Thu Dec  8 13:54:40 UTC 2011 - coolo@suse.com

- fix license to be in spdx.org format

-------------------------------------------------------------------
Tue Oct 11 12:27:54 UTC 2011 - jmatejek@suse.com

- fix build failing because Tkinter has a faulty __version__

-------------------------------------------------------------------
Mon Aug 15 02:00:37 CEST 2011 - ro@suse.de

- fix build for platform == linux3 

-------------------------------------------------------------------
Mon Jan 24 12:58:1 UTC 2011 - toddrme2178@gmail.com

- new version 1.0.1

  This is a bugfix release:
  + Fixed error with Hammer projection. 
  + Fixed the placement and angle of axis labels in 3D plots. 
  + New rc parameters examples.download and examples.directory
    allow bypassing the download mechanism in get_sample_data.
  + Change Axis.set_view_interval() so that when updating an
    existing interval, it respects the orientation of that
    interval, and can enlarge but not reduce the interval.
  + Handle NaN's correctly in path analysis routines.  
  + Fix bug in patch alpha handling, and in bar color kwarg
  + Return Qt4's default cursor when leaving the canvas

- cleanup specfile

-------------------------------------------------------------------
Wed Dec 29 15:03:06 CET 2010 - sbrabec@suse.cz

- Compile with wxWidgets (STL variant).

-------------------------------------------------------------------
Sat Dec 11 21:51:21 UTC 2010 - coolo@novell.com

- remove buildrequire on libstdc++

-------------------------------------------------------------------
Sat Jul 17 00:00:00 UTC 2010 - werner.ho@gmx.de

- new version 1.0.0

-------------------------------------------------------------------
Sat Oct 10 00:00:00 UTC 2009 - werner.ho@gmx.de

- new version 0.99.1.1
- config file added (seen at home:ocefpaf project)

-------------------------------------------------------------------
Fri Dec 19 21:40:55 CET 2008 - lars@linux-schulserver.de

- Update to 0.98.5.2
  + Fix bug where a line with NULL data limits prevents
    subsequent data limits from calculating correctly
  + Major documentation generator changes
  + Fixed dpi-dependent behavior of Legend and fancybox in Text
  + Fix \$ in non-math text with usetex off
  + Fix anti-aliasing when auto-snapping
  + Fix grid lines not moving correctly during pan and zoom
  + Fixed warning in hist() with numpy 1.2
  + Removed the prints in the set_*style commands.  Return the
    list of pprinted strings instead
- 10.2 is gone: remove specific fixes for this distribution

-------------------------------------------------------------------
Mon Nov 24 00:00:00 UTC 2008 - werner.ho@gmx.de

- replaced scipy by numpy as build requirement

-------------------------------------------------------------------
Wed Aug 20 00:00:00 UTC 2008 - werner.ho@gmx.de

- removed python-scipy from the requirements list
- added python-dateutil to the requirements list
- added python-pytz to the requirements list

-------------------------------------------------------------------
Sat Aug  9 00:00:00 UTC 2008 - werner.ho@gmx.de

- new major version 0.98.3

-------------------------------------------------------------------
Tue Aug  5 00:00:00 UTC 2008 - werner.ho@gmx.de

- new version 0.91.4
 
-------------------------------------------------------------------
Wed Jul 16 00:00:00 CET 2008 - Andrea Florio <andrea@opensuse.org>

- fixed spec file adding missing buildrequires
- made rpmlint happyer

-------------------------------------------------------------------
Sat Jun 07 00:00:00 CET 2008 - Werner Hoch <werner.ho@gmx.de>

- new version 0.91.3

-------------------------------------------------------------------
Fri Feb 01 00:00:00 CET 2008 - Werner Hoch <werner.ho@gmx.de>

- new version 0.91.2

-------------------------------------------------------------------
Fri Dec 07 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- added configobj as an extra requirement
- thus matplotlib will not provide configobj

-------------------------------------------------------------------
Sun Dec 02 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- new version 0.91.1
- removed build patches, as the build system has been changed

-------------------------------------------------------------------
Sat Sep 08 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- fixed build issus of openSUSE 10.3

-------------------------------------------------------------------
Sun Jun 03 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- new version 0.90.1
- added enable_BUILD_WXAGG.patch

-------------------------------------------------------------------
Thu Mar 22 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- removed X-server patches, use Xvfb instead
- created extra wx and tk packages

-------------------------------------------------------------------
Tue Mar 20 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- default backend is GTKAgg now
- TkAgg backend works now. Patched the X-Server dependancy away when building

-------------------------------------------------------------------
Sun Mar 11 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- improved the BuildRequires list. Tkinter backend has still problems

-------------------------------------------------------------------
Thu Mar 01 00:00:00 CET 2007 - Werner Hoch <werner.ho@gmx.de>

- new version 0.90.0

-------------------------------------------------------------------
Tue Oct 31 00:00:00 CET 2006 - Werner Hoch <werner.ho@gmx.de>

- new version 0.87.7

-------------------------------------------------------------------
Thu Sep 28 00:00:00 CET 2006 - Werner Hoch <werner.ho@gmx.de>

- Initial build.