File jsp-api.patch of Package freemarker

--- build.xmlorig	2017-10-16 02:17:50.000000000 +0100
+++ build.xml	2017-12-06 20:05:59.056142612 +0000
@@ -303,36 +303,21 @@
       verify="yes" stubversion="1.2"
     />
 
-    <ivy:cachepath conf="build.jsp2.0" pathid="ivy.dep.jsp2.0" />
+    <ivy:cachepath conf="build.jsp2.1" pathid="ivy.dep.jsp2.1" />
     <javac srcdir="build/src-main-java-filtered" destdir="build/classes" deprecation="off" 
       debug="on" optimize="off" target="1.5" source="1.5" encoding="utf-8"
       includeantruntime="false"
-      classpathref="ivy.dep.jsp2.0"
+      classpathref="ivy.dep.jsp2.1"
       bootclasspath="${boot.classpath.j2se1.5}"
       includes="
         freemarker/ext/jsp/**,
         freemarker/ext/servlet/**,
         freemarker/cache/WebappTemplateLoader.java"
       excludes="
-        freemarker/ext/jsp/_FreeMarkerPageContext21.java,
-        freemarker/ext/jsp/FreeMarkerJspFactory21.java,
-        freemarker/ext/jsp/FreeMarkerJspApplicationContext.java"
+        freemarker/ext/jsp/_FreeMarkerPageContext2.java,
+        freemarker/ext/jsp/FreeMarkerJspFactory2.java"
     />
     
-    <!-- There's no build.jsp2.0, as those classes are part of the common build subset. -->
-    
-    <ivy:cachepath conf="build.jsp2.1" pathid="ivy.dep.jsp2.1" />
-    <javac srcdir="build/src-main-java-filtered" destdir="build/classes" deprecation="off" 
-      debug="on" optimize="off" target="1.5" source="1.5" encoding="utf-8"
-      includeantruntime="false"
-      classpathref="ivy.dep.jsp2.1"
-      bootclasspath="${boot.classpath.j2se1.5}"
-      includes="
-        freemarker/ext/jsp/_FreeMarkerPageContext21.java,
-        freemarker/ext/jsp/FreeMarkerJspFactory21.java,
-        freemarker/ext/jsp/FreeMarkerJspApplicationContext.java"
-    />
-
     <ivy:cachepath conf="build.jython2.0" pathid="ivy.dep.jython2.0" />
     <javac srcdir="build/src-main-java-filtered" destdir="build/classes" deprecation="off" 
       debug="on" optimize="off" target="1.5" source="1.5" encoding="utf-8"
--- ivy.xml.orig	2018-03-30 22:03:42.000000000 +0100
+++ ivy.xml	2018-08-22 08:53:03.369873853 +0100
@@ -45,9 +45,6 @@
         description="for building FreeMarker without dependencies that optinal dependencies"
     />
 
-    <conf name="build.jsp2.0" extends="build.base"
-        description="for building FreeMarker with JSP 2.0 support"
-    />
     <conf name="build.jsp2.1" extends="build.base"
         description="for building FreeMarker with JSP 2.1 support"
     />
@@ -104,9 +101,7 @@
       <exclude org="xml-apis" module="xml-apis" />
     </dependency>
     
-    <dependency org="javax.servlet.jsp" name="jsp-api" rev="2.0" conf="build.jsp2.0->default" />
-    <dependency org="javax.servlet" name="servlet-api" rev="2.4" conf="build.jsp2.0->default" />
-    <dependency org="javax.servlet.jsp" name="jsp-api" rev="2.1" conf="build.jsp2.1->default" />
+    <dependency org="javax.servlet" name="jsp-api" rev="2.1" conf="build.jsp2.1->default" />
     <dependency org="javax.servlet" name="servlet-api" rev="2.5" conf="build.jsp2.1->default" />
     
     <dependency org="rhino" name="js" rev="1.6R1" conf="build.base->default" />
@@ -183,7 +178,7 @@
     
     <!-- Ensure that JSP versions don't accidentally hide each-other -->
     
-    <conflict org="javax.servlet.jsp" module="jsp-api" manager="strict" />
+    <conflict org="javax.servlet" module="jsp-api" manager="strict" />
     
   </dependencies>
 </ivy-module>
openSUSE Build Service is sponsored by