File libosip2.changes of Package libosip2

-------------------------------------------------------------------
Sun May 25 21:03:52 UTC 2014 - fisiu@opensuse.org

- Update to 4.1.0:
  * fix sdp re-allocation
  * increase max length size
  * osip_trace_initialize returns 0 if log are compiled.
  * timer e and timer g will use #define DEFAULT_T2 instead of 4000.
  * handle additionnal possible malloc failure.
  * fix compatibility with old UA for INVITE retransmission.
  * fix osip_sem_destroy leak on apple.
  * accept lowercase sip/2.0.
- Rebase libosip2-3.5.0.dif and rename to libosip2-4.1.0.patch.
- Rebase libosip2-3.5.0-pthread.patch and rename to libosip2-4.1.0-pthread.patch.

-------------------------------------------------------------------
Thu Jun 20 12:23:05 UTC 2013 - fisiu@opensuse.org

- Update to 4.0.0:
  * reduce path len // remove path in front of logs.
  * accept only SIP/D.D format message.
  * fix bug when releasing request with missing major headers.
  * fix minor memory leak // remove limitation on fifo size.
  * use system independant time for osip_gettimeofday on unix platform.
  * To compile/use osip based application in multi threaded
    env, you don't need to define -DOSIP_MT any more. Instead,
    if you wish to disable the feature, you can compile with
    -DOSIP_MONOTHREAD.
  * A few other clean up were made inside osip to avoid any
    define to appear in include files. Also to avoid conflict,
    config.h has been renamed to osip-config.h.
- Patches updated.
- Spec cleanup.

-------------------------------------------------------------------
Mon Feb 13 10:49:04 UTC 2012 - coolo@suse.com

- patch license to follow spdx.org standard

-------------------------------------------------------------------
Mon Nov 21 15:22:11 UTC 2011 - jengelh@medozas.de

- Remove redundant/unwanted tags/section (cf. specfile guidelines)
- Use %_smp_mflags for parallel building

-------------------------------------------------------------------
Sun Nov 20 06:16:57 UTC 2011 - coolo@suse.com

- add libtool as buildrequire to avoid implicit dependency

-------------------------------------------------------------------
Tue Apr 26 23:26:32 UTC 2011 - crrodriguez@opensuse.org

- fix botched pthread linkage,it is going to break sooner or later.

-------------------------------------------------------------------
Sun Jan 16 12:14:49 UTC 2011 - seife+obs@b1-systems.com

- update to version 3.5.0
  * iphone with TCP/TLS background support.
  * a lot of minor change/fix/improvments, sorry for not being
    able to have an history here...
- libosip2 (3.4.0)
  * remove CRLF before parsing SIP message.
  * modification to allow non-blocking socket for reliable transport.
  * fix race condition for non-atomic incrementation operation.
  * osip_list improvements.
  * osip_list prototypes and warnings fix.
  * new osip_strcasestr method.
- libosip2 (3.3.0)
  * new APPLE native interface for semaphore
  * add relative time in log information on linux/windows
  * fix: unescape last uri parameters.
- libosip2 (3.2.0)
  * return new error code for all API.

-------------------------------------------------------------------
Mon Feb 25 05:57:50 CET 2008 - crrodriguez@suse.de

- remove libtool archive with empty dependency_libs and static libraries
- update to version 3.1.0
	* Windows Mobile 5/6 improvments.
	* allow uncompliant/IMS authentication headers.
	* fix when a space appear as the first char in body.
	* terminate body with '\0' after parsing (don't rely on this!)

-------------------------------------------------------------------
Tue Dec 18 11:38:04 CET 2007 - mskibbe@suse.de

- update to version 3.0.3 which include
  o initial support for rtems
  o initial support for ucos.
  o Fix memory leaks
  o fix 64-bit (amd64) issue with hash
  o parser speed improvements
  o add NULL checks
  o automatic check for reliable protocol SCTP and TLS

-------------------------------------------------------------------
Wed May 16 15:15:22 CEST 2007 - ro@suse.de

- branch off devel package 

-------------------------------------------------------------------
Wed Jan 25 21:37:38 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Tue Mar 22 19:14:09 CET 2005 - hvogel@suse.de

- use the linphone version of 2.2.0
- package pkgconfig file

-------------------------------------------------------------------
Tue Nov  9 16:51:18 CET 2004 - ro@suse.de

- update to 2.2.0

-------------------------------------------------------------------
Wed Jul 28 18:09:12 CEST 2004 - ro@suse.de

- update to 2.1.0

-------------------------------------------------------------------
Tue Jan 13 18:13:26 CET 2004 - schwab@suse.de

- Remove old libtool macros.

-------------------------------------------------------------------
Mon Oct 20 18:26:01 CEST 2003 - ro@suse.de

- don't build as root 

-------------------------------------------------------------------
Fri Sep 26 00:46:50 CEST 2003 - ro@suse.de

- package created version 2.0.3-cvs