File 0001-Make-HAVE_JAVA6-be-always-false.patch of Package libreoffice

From 901eeaacd7219f61816b28873e45264c7d7de1ac Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Chv=C3=A1tal?= <tomas.chvatal@gmail.com>
Date: Thu, 23 Apr 2015 17:41:10 +0200
Subject: [PATCH] Make HAVE_JAVA6 be always false

Even if we have newer java for bundling we still test for 1.5 java
to be able to execute our bitecode.

Change-Id: I7bf5d86c4558b8ed583e3741c10e10daaaa825a7
NOTE: Do NOT upstream this.
---
 configure.ac | 6 ------
 1 file changed, 6 deletions(-)

diff --git a/configure.ac b/configure.ac
index 0d492ad..ba02fd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6725,9 +6725,6 @@ if test "$ENABLE_JAVA" != ""; then
             if test "$_jdk_ver" -lt 10500; then
                 AC_MSG_ERROR([IBM JDK is too old, you need at least 1.5])
             fi
-            if test "$_jdk_ver" -ge 10600; then
-                HAVE_JAVA6=TRUE
-            fi
 
             AC_MSG_RESULT([checked (IBM JDK $_jdk)])
 
@@ -6750,9 +6747,6 @@ you must use the "--with-jdk-home" configure option explicitly])
             if test "$_jdk_ver" -gt 10600; then
                 JAVA_CLASSPATH_NOT_SET="1"
             fi
-            if test "$_jdk_ver" -ge 10600; then
-                HAVE_JAVA6=TRUE
-            fi
             if test "$_jdk_ver" -ge 10900; then
                 HAVE_JAVA9=TRUE
             fi
-- 
2.3.5
openSUSE Build Service is sponsored by