File plplot-cmake36-pkg_check_pkgconfig_macro.patch of Package plplot

Index: plplot-5.11.1/cmake/modules/pkg-config.cmake
===================================================================
--- plplot-5.11.1.orig/cmake/modules/pkg-config.cmake
+++ plplot-5.11.1/cmake/modules/pkg-config.cmake
@@ -120,8 +120,10 @@ macro(pkg_check_pkgconfig _package _incl
   
   if(CMAKE_VERSION VERSION_LESS "3.1")
     _pkg_check_modules_internal(0 0 ${_prefix} "${_package}")
-  else(CMAKE_VERSION VERSION_LESS "3.1")
+  elseif(CMAKE_VERSION VERSION_LESS "3.6")
     _pkg_check_modules_internal(0 0 0 0 ${_prefix} "${_package}")
+  else(CMAKE_VERSION VERSION_LESS "3.1")
+    _pkg_check_modules_internal(0 0 0 0 0 ${_prefix} "${_package}")
   endif(CMAKE_VERSION VERSION_LESS "3.1")
     
   if(${_prefix}_FOUND)