File babl.changes of Package babl

-------------------------------------------------------------------
Tue Jun 21 18:00:38 UTC 2016 - zaitor@opensuse.org

- Update to version 0.1.18:
  + Bugfix: take alpha threshold in consideration when processing
    floats in SSE2.

-------------------------------------------------------------------
Fri Apr 15 17:03:45 UTC 2016 - mgorse@suse.com

- Update to GNOME 3.20  Fate#318572

-------------------------------------------------------------------
Fri Mar 11 12:26:19 UTC 2016 - zaitor@opensuse.org

- Update to version 0.1.16:
  + Improvements to half float reference, SIMD, and fast-paths, and
    CIE float fast paths; cleanups of fast path extensions.

-------------------------------------------------------------------
Thu Nov 26 03:30:16 UTC 2015 - zaitor@opensuse.org

- Update to version 0.1.14:
  + sRGB precision tuning
  + Stability fixes
  + Locale fix for setting error tolerance.

-------------------------------------------------------------------
Wed Feb 11 12:34:27 UTC 2015 - zaitor@opensuse.org

- Drop vala, libtool and gobject-introspection-devel BuildRequires,
  they are no longer needed.
- Due to above changes, no longer define build_vala, stop passing
  autogen.sh to configure, nor --enable-introspection or
  --without-vala.
- Drop typelib-1_0-Babl-0_1 Requires from devel package, it no
  longer exists.

-------------------------------------------------------------------
Sat Feb  7 17:57:15 UTC 2015 - sfalken@opensuse.org

- Update to version 0.1.12:
  + optimizations for floating point conversions, HSV and HSL
    color models
  + removal of dead code
  + fixed CIE Lab conversions
- Patches Dropped:
  + babl-fix-gir-build.patch
  + babl-fix-gir.patch
+ Modified .spec to remove typelib package and gir-related %files
  entries.  Package no longer provides them. 

-------------------------------------------------------------------
Tue Apr  3 08:16:25 UTC 2012 - vuntz@opensuse.org

- Update to version 0.1.10:
  + LUT based speedups for gamma correction / uncorrection.
- Changes from version 0.1.8:
  + Added support for indexed/pallette based formats.
  + Constified API.
- Pass --enable-introspection to configure to make sure we build
  introspection support.
- Add babl-fix-gir-build.patch: this fixes the build of
  introspection (as well as the generated data).
- Since the build of vala bindings is broken, temporarily disable
  it with a build_vala macro that helps us pass --without-vala to
  configure.

-------------------------------------------------------------------
Tue Jan 10 16:46:07 UTC 2012 - dimstar@opensuse.org

- Add babl-fix-gir.patch: Fix building of the .gir and .typelib
  files.
- Add vala and gobject-introspection BuildRequires to build the
  introspection and vala support.
- Create typelib-1_0-Babl-0_1 subpackage for typelib.
- Add typelib-1_0-Babl-0_1 Requires to -devel package.
- Add libtool BuildRequires and call to autogen.sh as the patch
  babl-fix-gir.patch touches the build system.

-------------------------------------------------------------------
Sun Nov 20 12:49:10 UTC 2011 - dimstar@opensuse.org

- Update to version 0.1.6:
  + Build improvements
  + Remove blatantly wrong conversions from extensions
  + Made it possible to distinguish format_n formats from others
  + Improvements to vala/gobject introspection support.

-------------------------------------------------------------------
Sat Sep 17 16:30:09 UTC 2011 - jengelh@medozas.de

- Remove redundant tags/sections from specfile
- Use %_smp_mflags for parallel build

-------------------------------------------------------------------
Sat Apr 16 20:44:50 UTC 2011 - mrdocs@opensuse.org

- Update to version 0.1.4: 
  + many build and autotool fixes
  + Add experimental introspection support - disabled by default
  + Add code to handle N-components.

-------------------------------------------------------------------
Mon May  3 06:15:36 UTC 2010 - coolo@novell.com

- buildrequire pkg-config to fix provides

-------------------------------------------------------------------
Fri Jan 15 15:23:06 CET 2010 - vuntz@opensuse.org

- Update to version 0.1.2:
  + Made babl mostly threadsafe (sufficient for GIMP/GEGLs needs).
  + Streamlined core functionality, reducing number of function
    calls and removing overeager instrumentation.
- Drop babl-fix-install.patch: fixed upstream. The autoreconf call
  can also be removed.
- Rename libbabl-0_0-0 to libbabl-0_1-0, following soname change.
  This also means we can remove the Provides/Obsoletes for
  babl-0_0.

-------------------------------------------------------------------
Fri May 22 14:30:48 CEST 2009 - vuntz@novell.com

- Update to version 0.1.0:
  + Support for RGBA representation in the frequency domain
  + Un-pre-multiply close-to-zero alpha values to complete black
    instead of slightly brighter than black
  + Add a BABL_ALPHA_THRESHOLD constantto the API
  + Do a complete overhaul of the babl API
  + Do some changes to increase portability of the library.
- Drop babl-undefined.patch: fixed upstream.
- Add babl-fix-install.patch to fix the build.
- Remove babl-0_0 package and make libbabl-0_0-0 provide/obsolete
  it.
- COPYING.lesser doesn't exist anymore. The package is LGPLv3+
  only (no more GPL).

-------------------------------------------------------------------
Mon Dec 15 19:16:10 CET 2008 - sbrabec@suse.cz

- Fixed undefined operation (bnc#449633).

-------------------------------------------------------------------
Wed Oct 22 09:32:55 CDT 2008 - maw@suse.de

- Make debug packages require a specific %{version}-%{release}.

-------------------------------------------------------------------
Mon Sep  8 13:44:15 CEST 2008 - dmueller@suse.de

- fix build

-------------------------------------------------------------------
Mon Jul 21 14:16:57 CEST 2008 - sbrabec@suse.cz

- New SuSE package.